PDA

View Full Version : rtl8180 on ibm r31 kernel 2.6.17-1.2145_FC5



axioms
11th July 2006, 12:56 AM
i've been working at this for a week now and still can't figure out what's wrong.


i'm trying to get my wifi card, generic rtl8180 chipset, to work on my IBM r31 minipci. card is not detected by lspci or pccardctl ident, but if i eject or plug it a message of pccard: card ejected from slot 0 appears. i tried adding the following parameters to the boot file:
pci=assign-busses pci=routeirq

didn't work, i tried both ndiswrapper and rtl drives provided by realtech and the one on sourcefore:
http://www.realtek.com.tw/downloads/downloads1-3.aspx?lineid=2002111&famid=All&series=2002121&Software=True
http://rtl8180-sa2400.sourceforge.net/

also didn't work. with ndiswrapper win2k driver installs but the hardware is not detected.

a website dedicated to linux on my laptop, http://lpn.rnbhq.org/R31/R31.shtml#pcmcia, says i have to make sure ISA support is installed on the kernel, i don't know how to check if its installed, and i don't want to recompile the kernel to install it (if thats possible).

I would appretiate any help, and please i'm a real amateur so explain any possible solution very clearly, if you need any additional info i'll be glad to post it.

Thanks for any help given.