PDA

View Full Version : libqt3-compat on Fedora Core 5 ?



DaScoobsta
9th July 2006, 04:01 PM
Hi,

I'm trying to install ksmoothdock on Fedora Core 5 from source. During the configure it bombs out with:-

checking for Qt... configure: error: Qt (>= Qt 3.0) (headers and libraries) not found. Please check your installation!

I have the Qt 4 development packages installed, but I guess I also need the older QT3 compatible libraries. I presumed libqt3-compat is what I needed but it's missing from Fedora Core or Extras repos.

Is libqt3-compat what I need to get past this problem, or am I barking up the wrong tree?

markkuk
9th July 2006, 04:05 PM
You need the qt-devel package. FC5 uses Qt 3 by default, so you don't need any "compat-" libraries.

DaScoobsta
11th July 2006, 04:01 PM
I already have the standard FC5 qt and qt-devel packages installed. I also have qt4 and qt4-devel installed... could this be causing a conflict?

markkuk
11th July 2006, 08:06 PM
Check your Qt environment variables:

env | grep 'QT'
They should point to the Qt3 directories if you want to compile with Qt 3.3:

QTDIR=/usr/lib/qt-3.3
QTINC=/usr/lib/qt-3.3/include
QTLIB=/usr/lib/qt-3.3/lib

DaScoobsta
12th July 2006, 09:33 AM
My QT environment variables look ok:-

QTDIR=/usr/lib/qt-3.3
QTINC=/usr/lib/qt-3.3/include
QTLIB=/usr/lib/qt-3.3/lib

Any ideas?

igknighted
3rd February 2008, 08:04 AM
My QT environment variables look ok:-

QTDIR=/usr/lib/qt-3.3
QTINC=/usr/lib/qt-3.3/include
QTLIB=/usr/lib/qt-3.3/lib

Any ideas?

I know this thread is ancient, but I stumbled across it trying to compile ksmoothdock. If anyone is wondering, you need to set the qt directory to get past this manually with an option at the ./configure step. It should look like this:

./configure --with-qt-dir=/usr/lib/qt-3.3/