PDA

View Full Version : java plug in issue



skifly
6th July 2006, 04:52 PM
Hello All I have Installed JRE 1.5.0 (limewire works well) I have created a Simb link to Firefox plug in directory
[root@localhost firefox-1.5.0.1]# cd /usr/lib/firefox-1.5.0.1/plugins
[root@localhost plugins]# dir
libjavaplugin_oji.so libnullplugin.so libunixprintplugin.so
[root@localhost plugins]#
The LIBJAVAPLUGIN__OJI.SO Is there and the file is not Broken But still No Java when i run Firefox I am Missing Something ? But not sure What. By the way FC5 i386 and firefox 1.5.0.1

THANKS FOR HELP !


chris http://forum.fedoraforum.org/newthread.php?do=newthread&f=9#

jmarius
6th July 2006, 08:12 PM
You need to place the symlink in /usr/lib/mozilla/plugins or /home/username/.mozilla/plugins.

bob
6th July 2006, 08:31 PM
Check this site: http://stanton-finley.net/fedora_core_5_installation_notes.html#Java You've already done the jre install, but what I want you to look at is the 'ln -s (etc)' that creates the symlink and think it through. After the 'ln -s', it's telling the computer to link a path from one file down a path to a plugins folder. It might help to actually browse to the exact location of your libjavaplugin_oji.so so you can physically see the path, then browse to the firefox or mozilla plugins folder and see how to describe where to place it. If you have a symlink that doesn't work in the plugins folder, remove it before starting fresh.

skifly
6th July 2006, 11:07 PM
Thanks for you Help jmarius, and Bob I see Its better to understand and write you own commands ,rather than copy Ha ha
Java works fine now,The thing About Linux is It makes you think.........

Chris