PDA

View Full Version : wireless card and ndiswrapper



acmemetalfab
4th July 2006, 03:19 AM
i've got the fedora 5 os installed and operating properly, but i can't figure out yet how to make the wireless card i've got in the machine (linksys WMP54GS) work in the linux environment. linksys says they don't support the os (big shock, it seems like no manufacturers want to know from linux), but i found something online called ndiswrapper which will supposedly allow me to use the windows driver that came with the card. i don't understand how to do this. anybody know how?
fwiw, here's something i found on a wiki here:
http://ndiswrapper.sourceforge.net/mediawiki/index.php/List#L

the wiki says the following regarding my card:

Card: Linksys #[WMP54GS] Wireless-G PCI Adapter with Speedbooster -- [link here|List#WMP54GS]

* Chipset: Broadcom Corporation BCM94306 802.11g (rev 03)
* pciid: 14e4:4320
* Driver: Linksys ftp://ftp.linksys.com/pub/network/WMP54GS_20050406.exe (new version)
* Other: Ndiswrapper 0.11 and 0.12. Works fine with 64-bit WEP key and WPA supplicant (Fedora core-2, Kernel 2.6.8 and 2.6.9). Use WMP54GS.inf

ok, what do i do with this info?
thanks!

centos_x
4th July 2006, 06:30 PM
To be sure what chipset you have /sbin/lspci look through that for your card

I've got the bcm4306 b chipset, works great and supports 128WEP and 3 WPA modes

I built mine from source, basically after install have to find executable

mine is in /usr/sbin/ndiswrapper
copy the driver folder to a temp folder cd into that folder

next type

/usr/sbin/ndiswrapper -i drivername.inf

drivername is the driver want to install next type

/usr/sbin/ndiswrapper -l

should see something like this

@localhost ~]$ /usr/sbin/ndiswrapper -l
Installed drivers:
bcmwla driver installed, hardware present

next try to install the module

/sbin/modprobe ndiswrapper

keep your fingers crossed you don't lock up at this point, if goes back to the bash prompt good to go
to check can type
/sbin/lsmod
look through the list for ndiswrapper

next can add the alias to modprobe.conf
@localhost ~]$ /usr/sbin/ndiswrapper -m

this should say it added and show the line it added

now open your network manager select new and select wireless, go through it shoudl see it listed as ndiswrapper select that and set rest up as would any other wireless connection in windows, add your key/s, ip if applicable, start at boot etc.....

acmemetalfab
6th July 2006, 12:50 AM
i'm sorry, i just don't have the expertise to fully understand what that means. i went to the /sbin/lspci site and it said nothing about these cards. i don't suppose you could explain, step by step, what needs to be done here? just so you know, i messed around with it and thought about it for two days, it's not for lack of trying.

also-

-you say "i built mine from SOURCE"...what's source?
-while we're at it, what's RPM? I keep seeing it referenced but i don't know what it is. i tried looking this stuff up, but to no avail.

step by step, how would i use ndiswrapper to make this all work? again, sorry to be so dense, but this is all new to me. thanks for your help!

acmemetalfab
7th July 2006, 09:49 PM
bump.
surely someone here is willing to take a few moments to help out.

centos_x
8th July 2006, 04:17 PM
First thing is to install ndiswrapper. there are 2 ways to accomplish this one is by a rpm package the other is by source file, these are the files you see as ndiswrapper.tar.gz on the site for download

In order to build from source need other tools such as make, gcc,kernel headers, etc installed. would go with rpm package route if you are new to this.......

next type su and supply root password then procceed with the following.

the rpm is easiest just download the rpm file ndiswrapper and type rpm -ivh ndiswrapper-(version).rpm

once that is done need to find a driver for your wireless

copy the driver folder to a temporary folder your home folder will work /home/yourusername

next cd into that folder with cd /home/yourusername

next type

/usr/sbin/ndiswrapper -i drivername.inf

drivername is the driver want to install next type

next type

/usr/sbin/ndiswrapper -l

should see something like the following

@localhost ~]$ /usr/sbin/ndiswrapper -l
Installed drivers:
bcmwla driver installed, hardware present

next try to install the module

/sbin/modprobe ndiswrapper

keep your fingers crossed you don't lock up at this point, if goes back to the bash prompt good to go
to check the status can type
/sbin/lsmod
look through the list for ndiswrapper

next can add the alias to modprobe.conf
@localhost ~]$ /usr/sbin/ndiswrapper -m

this should say it added and show the line it added

now open your network manager click on new at the top and select wireless, go through it shoudl see it listed as ndiswrapper select that and set rest up as would any other wireless connection in windows, add your key/s, ip if applicable, start at boot etc.....

then type

/sbin/iwconfig

see if it lists your access point, something like following

wifi0 IEEE 802.11b ESSID:"yourSSID" Nickname:"localhost.localdomain"
Mode:Managed Frequency:2.457 GHz Access Point: 00:0C:41:50:1E:C4
Bit Rate:11 Mb/s Sensitivity=1/3
Retry min limit:8 RTS thr:off Fragment thr:off
Power Management:off

wlan0 IEEE 802.11b ESSID:"yourSSID" Nickname:"localhost.localdomain"
Mode:Managed Frequency:2.457 GHz Access Point: 00:0C:41:50:1E:C4
Bit Rate:11 Mb/s Sensitivity=1/3
Retry min limit:8 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=26/70 Signal level=-62 dBm Noise level=-88 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

If where it says Access Point has all 4's or something similar you not associated to your access point

try doing this next if your not associated
/sbin/iwconfig wlan0 key restricted 123456789A

tyoe your key instead where it says 123456789A

now try /sbin/iwconfig again see if it has a proper mac address listed

wlan0 IEEE 802.11b ESSID:"yourSSID" Nickname:"localhost.localdomain"
Mode:Managed Frequency:2.457 GHz (((Access Point: 00:0C:41:50:1E:C4)))
Bit Rate:11 Mb/s Sensitivity=1/3
Retry min limit:8 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=26/70 Signal level=-62 dBm Noise level=-88 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

the part in ((( ))) is what you are looking for if it still has a string of same numbers or letters you have bigger issues..........

blue13130
8th July 2006, 05:58 PM
Here is a good link for you to learn about RPM packages and how to use them:
http://fedoranews.org/alex/tutorial/rpm/

Here is a good link on how to install ndiswrapper using a prebuilt rpm:
http://fedoramobile.org/fc-wireless/ndis-yum-livna/

acmemetalfab
8th July 2006, 08:09 PM
thank you both kindly. i'll see if i can use that info to get the job done.

bercy46
12th July 2006, 01:41 AM
Hi,

I'm also trying to install my wireless card on Fedora Core 5 (my card is a Linksys WPC55AG). I'm using this guide, which resembles very much what has been said so far in this thread :

http colon slash slash fedoramobile.org/fc-wireless/ndis-yum-livna

When I get at step 13 (the modprobe step), I get :

FATAL: Module ndiswrapper not found

I noticed that I have the 2.16-15 kernel installed if I do a "uname -r". However, the procedure to install ndiswrapper seems to install a version for the 2.16-17 kernel...

If I go in /lib/modules/... 2.16-17/..., I can find the ndiswrapper module.

But not in the /lib/modules/... 2.16-15/...

So I'm guessing that when I try to use modprobe, it's looking in the 15 folder, because that's the kernel I have installed...

Could someone please confirm that this could in fact be my problem, and if so, how do I resolve it ? Do I try to install ndiswrapper for 2.16-15, and if so, where do I find it, and how do I install it ? Or do I upgrade my kernel to 2.16-17, and if so, how ?

Detailed steps would really be appreciated, I'm a complete newbie when it comes to administering a linux box...

Thanks a million.

centos_x
12th July 2006, 11:04 PM
ndiswrapper is dependant on the running kernel version, I always build from source my self so never have to pay attention to version, package should corespond to the version of ndiswrapper and your kernel

acmemetalfab
13th July 2006, 02:23 PM
i think bercy and i share a common (or at least similar) problem. i've got ndiswrapper installed and when i use the "ndiswrapper -l" comand get the following:

[root@localhost ~]# ndiswrapper -l
Installed drivers:
wmp54gs driver installed, hardware present
You have new mail in /var/spool/mail/root

this leads me to beleive that the hardware is detected and the proper driver is properly installed. all that remains is for me to run the command "modprobe ndiswrapper", but when i do i get the ollowing error message:

[root@localhost ~]# modprobe ndiswrapper
FATAL: Error inserting ndiswrapper (/lib/modules/2.6.15-1.2054_FC5smp/misc/ndiswrapper.ko): Invalid module format

i too am running the most current fedora kernel i could find; the command "uname -r" yeilds this:

[root@localhost ~]# uname -r
2.6.15-1.2054_FC5smp

-but-
the ndiswrapper version i'm using tells me this when i use the "su --login -c 'yum install kmod-ndiswrapper'" command:

[root@localhost ~]# su --login -c 'yum install kmod-ndiswrapper'
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
livna [1/4]
livna 100% |=========================| 951 B 00:00
core [2/4]
core 100% |=========================| 1.1 kB 00:00
updates [3/4]
updates 100% |=========================| 951 B 00:00
extras [4/4]
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
primary.xml.gz 100% |=========================| 377 kB 00:01
updates : ################################################## 1058/1058
Added 170 new packages, deleted 470 old in 2.71 seconds
primary.xml.gz 100% |=========================| 1.2 MB 00:02
extras : ################################################## 4205/4205
Added 133 new packages, deleted 66 old in 5.09 seconds
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for kmod-ndiswrapper to pack into transaction set.
kmod-ndiswrapper-1.18-2.2 100% |=========================| 6.1 kB 00:00
---> Package kmod-ndiswrapper.i686 0:1.18-2.2.6.17_1.2145_FC5 set to be installed
--> Running transaction check
--> Processing Dependency: ndiswrapper-kmod-common >= 1.18 for package: kmod-ndiswrapper
--> Processing Dependency: kernel-i686 = 2.6.17-1.2145_FC5 for package: kmod-ndiswrapper
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for ndiswrapper to pack into transaction set.
ndiswrapper-1.18-1.lvn5.i 100% |=========================| 6.4 kB 00:00
---> Package ndiswrapper.i386 0:1.18-1.lvn5 set to be updated
---> Downloading header for kernel to pack into transaction set.
kernel-2.6.17-1.2145_FC5. 100% |=========================| 177 kB 00:00
---> Package kernel.i686 0:2.6.17-1.2145_FC5 set to be installed
--> Running transaction check

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Installing:
kmod-ndiswrapper i686 1.18-2.2.6.17_1.2145_FC5 livna 87 k
Installing for dependencies:
kernel i686 2.6.17-1.2145_FC5 updates 15 M
ndiswrapper i386 1.18-1.lvn5 livna 29 k

Transaction Summary
================================================== ===========================
Install 3 Package(s)
Update 0 Package(s)
Remove 0 Package(s)
Total download size: 15 M
Is this ok [y/N]: y
Downloading Packages:
(1/3): ndiswrapper-1.18-1 100% |=========================| 29 kB 00:00
(2/3): kernel-2.6.17-1.21 100% |=========================| 15 MB 00:39
(3/3): kmod-ndiswrapper-1 100% |=========================| 87 kB 00:00
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID a109b1ec
Public key for ndiswrapper-1.18-1.lvn5.i386.rpm is not installed
Retrieving GPG key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna
Importing GPG key 0xA109B1EC "Livna.org rpms <rpm-key@livna.org>"
Is this ok [y/N]: y
Key imported successfully
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing: kernel ######################### [1/3]
Installing: kmod-ndiswrapper ######################### [2/3]
Installing: ndiswrapper ######################### [3/3]

Installed: kmod-ndiswrapper.i686 0:1.18-2.2.6.17_1.2145_FC5
Dependency Installed: kernel.i686 0:2.6.17-1.2145_FC5 ndiswrapper.i386 0:1.18-1.lvn5
Complete!

it appears (to my inexperienced eyes, anyway) to be installing something called a "kmod-ndiswrapper" for kernel "2.2.6.17_1.2145_FC5", and mine is "2.6.15-1.2054_FC5smp". is that the problem? if so, what's the answer? where can one find the proper kmod-ndiswrapper file for my kernel or update my kernel to suite the kmod-ndiswrapper file i have?
so close, but yet so far...

blue13130
13th July 2006, 03:40 PM
acmemetalfab,
Yes you are correct in that the wrong version of kmod-ndiswrapper is being installed and that is what is leading to your problem. Try these steps to correct it:

1. Remove the i686 kernel and ndiswrapper packages
# yum remove kernel-2.6.17-1.2145_FC5 ndiswrapper
(make sure the proper kernel is being removed before you hit yes in yum when it asks for confirmation!)

2. install kmod-ndiswrapper-smp package
# yum install kmod-ndiswrapper-smp

You are running version 2.6.15-1.2054_FC5smp which is quite old. You should update to the latest kernel version (2.6.17_1.2145_FC5smp) before installing kmod-ndiswrapper-smp package
# yum update kernel

post back and let me know how it goes!

PS - just looking at your commands from above:
If you are logged in as root at the terminal you do not need to do "su --login -c 'yum install kmod-ndiswrapper'" as that is only needed when you are logged in as non-root and wish to run commands with root rights. When you are logged in as root you can just run "yum install kmod-ndiswrapper-smp"

Are you normally logging in as root? You should normally use a non-root user account and only log in as root when you need to use root rights.

acmemetalfab
14th July 2006, 01:58 AM
i tried what you posted and it didn't work- untill i restarted the computer. it seems that when you download the kernel update it doesn't register with the "uname -r" command untill a restart occurs. once that was done, i reinstalled the ndiswrapper and it worked. thank you!
-now-
i am again at another impasse. this time, the card is recognized by the x windows network configuration tool, but when i try and activate the card it asks me if the cable is unplugged. any ideas?

josefwhiter
14th July 2006, 02:20 AM
it has been a very long time since I've done anything desktop related with fedora so somebody else may have a more helpfull suggestion, but if you could run a few commands this would be helpful

iwconfig
iwlist scan

and post them so I can take a look.

acmemetalfab
14th July 2006, 02:48 AM
lol, i think something may be amiss. i ran iwconfig and it told me something might be broken. at least linux doesn't mince words. here's what it said-

[root@localhost ~]# iwconfig
lo no wireless extensions.

eth1 no wireless extensions.

dev22325 no wireless extensions.

Warning: Driver for device eth2 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...

eth2 IEEE 802.11b/g ESSID:"CHili" Nickname:"localhost.localdomain"
Mode:Managed Frequency=2.462 GHz Access Point: Invalid
Bit Rate=11 Mb/s
RTS thr:off Fragment thr:off
Encryption key:3633-3136-3735-3630-3335-0000-00 Security mode:open
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

when i ran iwlist scan it said-

[root@localhost ~]# iwlist scan
lo Interface doesn't support scanning.

eth1 Interface doesn't support scanning.

dev22325 Interface doesn't support scanning.

Warning: Driver for device eth2 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...

eth2 Interface doesn't support scanning : No such device

sit0 Interface doesn't support scanning.

again, something broken. i don't know what i compiled with version 19 or 20 or what, i'm still new at this. any ideas? fwiw, i know for a fact that my wireless router works with linux; i pinged the router from the terminal with a hard connection to a nic card (not the wireless card) and it worked fine.
btw, thanks for the speedy reply.

josefwhiter
14th July 2006, 04:02 AM
Yeah I was getting this on another box I was trying to setup, but havent gotten back to it. Try

yum update wireless-tools

and then re-run the commands again, see if it acts a little bit saner.

blue13130
14th July 2006, 04:37 AM
take a look at the output from ndiswrapper -l
# /usr/sbin/ndiswrapper -l
Does it say "driver installed, hardware present"?

Here is a good tutorial page to look through. Ignore the compile and build steps as that is taken care of by installing the rpm via yum
http://ndiswrapper.sourceforge.net/mediawiki/index.php/Installation#Install_Windows_driver

wongfeihong
14th July 2006, 07:56 PM
I'm running Fedora 5 on a Dell 600 with the BRCD4309 wireless card. I download and extract ndiswrapper. When I try to install ndiswapper, I get the following error when I run 'make':

[root@localhost ndiswrapper-1.19]# make
make -C driver
make[1]: Entering directory `/root/Desktop/ndiswrapper-1.19/driver'
Can't find kernel build files in /lib/modules/2.6.15-1.2054_FC5/build;
give the path to kernel build directory with
KBUILD=<path> argument to make
make[1]: *** [prereq_check] Error 1
make[1]: Leaving directory `/root/Desktop/ndiswrapper-1.19/driver'
make: *** [all] Error 2
[root@localhost ndiswrapper-1.19]#


Any suggestions will be appreciated.

blue13130
14th July 2006, 08:10 PM
I'm running Fedora 5 on a Dell 600 with the BRCD4309 wireless card. I download and extract ndiswrapper. When I try to install ndiswapper, I get the following error when I run 'make':

[root@localhost ndiswrapper-1.19]# make
make -C driver
make[1]: Entering directory `/root/Desktop/ndiswrapper-1.19/driver'
Can't find kernel build files in /lib/modules/2.6.15-1.2054_FC5/build;
give the path to kernel build directory with
KBUILD=<path> argument to make
make[1]: *** [prereq_check] Error 1
make[1]: Leaving directory `/root/Desktop/ndiswrapper-1.19/driver'
make: *** [all] Error 2
[root@localhost ndiswrapper-1.19]#


Any suggestions will be appreciated.
2 suggestions:
1. You should not run your computer as root, you should use a non-root account and only switch to root when you need to. I only say this because you have the ndiswrapper folder on roots desktop.
2. you need to install the kernel-devel package. You can use yum to do it
# yum install kernel-devel

wongfeihong
14th July 2006, 08:42 PM
I install kernel-devel as suggested and this install fine. But I'm still getting the same error. Am I missing a symbolic link somewhere?

Thanks!

acmemetalfab
15th July 2006, 04:01 AM
wongfeihong- i had a similar error when i was trying to get min working. i had to create a symlink, but the path that i had to enter was slightly different than the one listed in the instructions. you might want to dig through the folders and see what the names of your directories are, that might help.

josefwhiter- thanks bud...i didn't realize you were sarah's boyfriend (fiancee?), i appreciate your help.

blue13130- the ndiswrapper -l command yields the following:

[root@localhost ~]# ndiswrapper -l
Installed drivers:
wmp54gs driver installed, hardware present

and the xwindows network tool sees the card and claims its status is "ok". i just can't get it to become active. when i hit the activate button, it asks me if the cable is unplugged. i know the router talks to fedora, i've pinged the router from the terminal with a hard connection to a nic card in the same computer and no problems.
here's the thing about the error message-

"Warning: Driver for device eth2 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken..."

since i can't find a new driver for the card that might support wireless extension version 20, i think i need to install the older version (version 19) to make it work. does this make sense?

josefwhiter
15th July 2006, 02:14 PM
I havent had a chance to look at the code to figure out what version its pulling, but I'm pretty sure that if you do

yum update wireless-tools

and then try to run iwconfig and iwlist scan to see if it spits the same error out. If it does I'll take a look at iwconfig and see where its pulling that version from so I can figure out what you need to update in order to be using version 20.

acmemetalfab
15th July 2006, 02:59 PM
i tried the command "yum update wireless-tools" and here's what i got-

[root@localhost ~]# yum update wireless-tools
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
livna [1/4]
livna 100% |=========================| 951 B 00:00
core [2/4]
core 100% |=========================| 1.1 kB 00:00
updates [3/4]
updates 100% |=========================| 1.2 kB 00:00
extras [4/4]
http://mirror.clarkson.edu/pub/distributions/fedora/linux/extras/5/i386/repodata/repomd.xml: [Errno 14] HTTP Error 404: Date: Sat, 15 Jul 2006 13:33:35 GMT
Server: Apache/2.0.52 (Red Hat)
Content-Length: 348
Connection: close
Content-Type: text/html; charset=iso-8859-1
Trying other mirror.
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
primary.xml.gz 100% |=========================| 145 kB 00:00
livna : ################################################## 457/457
Added 20 new packages, deleted 1 old in 0.55 seconds
primary.xml.gz 100% |=========================| 386 kB 00:00
updates : ################################################## 1080/1080
Added 27 new packages, deleted 5 old in 1.74 seconds
primary.xml.gz 100% |=========================| 1.2 MB 00:02
extras : ################################################## 4205/4205
Added 2467 new packages, deleted 497 old in 19.68 seconds
Could not find update match for wireless-tools
No Packages marked for Update/Obsoletion

it would seem that something is not kosher here. anyhow, here's what the iwconfig and iwlist yield after doing that...
first iwconfig-

[root@localhost ~]# iwconfig
lo no wireless extensions.

eth1 no wireless extensions.

dev1804289383 no wireless extensions.

Warning: Driver for device eth2 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...

eth2 IEEE 802.11b/g ESSID:"CHili" Nickname:"localhost.localdomain"
Mode:Managed Frequency=2.462 GHz Access Point: Invalid
Bit Rate=11 Mb/s
RTS thr:off Fragment thr:off
Encryption key:6316-7560-35 Security mode:open
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

[root@localhost ~]# iwconfig
lo no wireless extensions.

eth1 no wireless extensions.

dev1804289383 no wireless extensions.

Warning: Driver for device eth2 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...

eth2 IEEE 802.11b/g ESSID:"CHili" Nickname:"localhost.localdomain"
Mode:Managed Frequency=2.462 GHz Access Point: Invalid
Bit Rate=11 Mb/s
RTS thr:off Fragment thr:off
Encryption key:6316-7560-35 Security mode:open
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

then, iwlist scan-

[root@localhost ~]# iwlist scan
lo Interface doesn't support scanning.

eth1 Interface doesn't support scanning.

dev1804289383 Interface doesn't support scanning.

Warning: Driver for device eth2 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...

eth2 Interface doesn't support scanning : No such device

sit0 Interface doesn't support scanning.

is it possible that the wireless-tools update file is in a repository that i haven't told yum to look in? joe, while we're at it, since you're the guy in the know, if i wanted to get a wireless card that is natively compatible with fedora core 5 as a backup, what should i buy? i'm not giving up, it's just that my wife is banishing this computer (and me with it) to my lab/machine shop so she can have her windows box back on the desk in the house, and i have no way to get a connection out there other than wireless.

josefwhiter
15th July 2006, 09:43 PM
At this point I'd say go with anything on this list

http://bcm43xx.berlios.de/?go=Devices

as this driver appears to already be compiled and shipped with our kernel. Note, I have a friends laptop that I'm setting up with this chipset that I'm still futzing with (albiet I've not put much time at all into it) so I cannot attest to how well it works, but other people have said its a pretty solid driver. I'm going to work on the one I have here tomorrow so if I do get it all setup I'll let you know what I did. I'm also getting that weird "version 20" error as well, so I'm going to poke around in the source and figure out what its looking for, and when i get that all done I'll post back to here what I did.

blue13130
15th July 2006, 10:17 PM
I also get the Warning about the versions but my connection still works fine. Here is my output from iwlist scan

[sanjay@FC4 ~]$ iwlist scan
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

Warning: Driver for device wlan0 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...

wlan0 Scan completed :
Cell 01 - Address: 00:06:25:F4:6F:F1
ESSID:"SJP"
Protocol:IEEE 802.11b
Mode:Managed
Frequency:2.462 GHz (Channel 11)
Quality:0/100 Signal level:-65 dBm Noise level:-256 dBm
Encryption key:on
Bit Rate:1 Mb/s
Bit Rate:2 Mb/s
Bit Rate:5.5 Mb/s
Bit Rate:11 Mb/s
Extra:bcn_int=100
Extra:atim=0

I am wondering why your wireless connection is called eth2. Ndiswrapper will call them wlan0 by default so why is yours called eth2. This message from your iwlist output seems odd also "eth2 Interface doesn't support scanning : No such device" The 'no such device' seems to say something might be going on that we have addressed yet.

My connection was never able to connect by the GUI interface. I run a script that connects when I boot my laptop and it works for my needs. Try running these commands from the terminal and see what happens. (It would be a good idea to disable all WEP or WPA security on the router and then enable it after you know that you can connect)

Run these commands as root from the terminal

$ iwconfig wlan0 mode Managed
$ iwconfig wlan0 essid SSID (replace SSID with your ssid)
$ dhclient wlan0

See how that works for you. The first two commands will not give any output. The last will show output trying to get an IP address from your router. Replace wlan0 with eth2 in your case...

josefwhiter
17th July 2006, 12:52 AM
Ok here's what i did, download this

http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/wireless_tools.29.pre10.tar.gz

open up a terminal, and run the command

tar xvzf wireless_tools.29.pre10.tar.gz

and then cd into the directory that you unziped. Then, edit the Makefile file in there, and go down to the line that says something like

INSTALL_DIR= $(PREFIX)/sbin/

and change that to

INSTALL_DIR= /sbin/

then save that and then exit the editor. Then in that directory run the command

make install PREFIX=/usr

NOTE: You'll want to do the make as root. Then do an iwlist scan and see if it works. If it does not, run the commands

modprobe -r ndiswrapper
modprobe ndiswrapper
dmesg | tail -n 25
iwlist scan

and paste the output to here so I can see if something is going wrong.

acmemetalfab
18th July 2006, 02:56 PM
here's what i did-
1) i downloaded the tar from the link you posted. i used the gui to uncompress the files. this gave me a directory in Desktop called "wireless_tools.29".
2) i switched into the "wireless_tools.29" directory and tried to use the edit command on the file "Makefile". i didn't know how to close the edit program and save, so i just opened the file through the gui and edited the program that way. The file now looks like the following:

##
## Please check the configurion parameters below
##

## Installation directory. By default, go in /usr/local.
## Distributions should probably use /, but they probably know better...
ifndef PREFIX
PREFIX = /usr/local
endif

## Compiler to use (modify this for cross compile).
CC = gcc
## Other tools you need to modify for cross compile (static lib only).
AR = ar
RANLIB = ranlib

## Uncomment this to build tools using static version of the library.
## Mostly useful for embedded platforms without ldd, or to create
## a local version (non-root).
# BUILD_STATIC = y

## Uncomment this to build without using libm (less efficient).
## This is mostly useful for embedded platforms without maths.
# BUILD_NOLIBM = y

## Uncomment this to strip binary from symbols. This reduce binary size.
## by a few percent but make debug worse...
# BUILD_STRIPPING = y

## Uncomment this to build with only essential functionality.
## This leaves out the less used features and cut in half the tools.
## This is mostly useful for embedded platforms without limited feature needs.
# BUILD_WE_ESSENTIAL = y

# ************************************************** *************************
# ***** Most users should not need to change anything beyond this point *****
# ************************************************** *************************

# Version of the Wireless Tools
WT_VERSION := $(shell sed -ne "/WT_VERSION/{s:\([^0-9]*\)::;p;q;}" < iwlib.h )

# Version of Wireless Extensions.
WE_VERSION := $(shell sed -ne "/WE_VERSION/{s:\([^0-9]*\)::;p;q;}" < iwlib.h )

# Always use local header for wireless extensions
WEXT_HEADER = wireless.$(WE_VERSION).h

# Targets to build
STATIC=libiw.a
DYNAMIC=libiw.so.$(WT_VERSION)
PROGS= iwconfig iwlist iwpriv iwspy iwgetid iwevent ifrename
MANPAGES8=iwconfig.8 iwlist.8 iwpriv.8 iwspy.8 iwgetid.8 iwevent.8 ifrename.8
MANPAGES7=wireless.7
MANPAGES5=iftab.5
EXTRAPROGS= macaddr iwmulticall

# Composition of the library :
OBJS = iwlib.o

# Select which library to build and to link tool with
ifdef BUILD_STATIC
IWLIB=$(STATIC)
IWLIB_INSTALL=install-static
else
IWLIB=$(DYNAMIC)
IWLIB_INSTALL=install-dynamic
endif

# Standard name for dynamic library so that the dynamic linker can pick it.
# We will just create a symbolic link to the real thing.
DYNAMIC_LINK= libiw.so

# Install directories
INSTALL_DIR= /sbin/
INSTALL_LIB= $(PREFIX)/lib/
INSTALL_INC= $(PREFIX)/include/
INSTALL_MAN= $(PREFIX)/man/

# Various commands
RM = rm -f
RM_CMD = $(RM) *.BAK *.bak *.d *.o *.so ,* *~ *.a *.orig *.rej *.out
LDCONFIG = ldconfig

# Do we want to build with or without libm ?
ifdef BUILD_NOLIBM
LIBS=
WELIB_FLAG= -DWE_NOLIBM=y
else
LIBS= -lm
endif

# Stripping or not ?
ifdef BUILD_STRIPPING
STRIPFLAGS= -Wl,-s
else
STRIPFLAGS=
endif

# Do we want to build with only essential functionality ?
ifdef BUILD_WE_ESSENTIAL
WEDEF_FLAG= -DWE_ESSENTIAL=y
endif

# Other flags
CFLAGS=-Os -W -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow \
-Wpointer-arith -Wcast-qual -Winline -I.
#CFLAGS=-O2 -W -Wall -Wstrict-prototypes -I.
DEPFLAGS=-MMD
XCFLAGS=$(CFLAGS) $(DEPFLAGS) $(WARN) $(HEADERS) $(WELIB_FLAG) $(WEDEF_FLAG)
PICFLAG=-fPIC

# Standard compilation targets
all:: $(IWLIB) $(PROGS)

%: %.o
$(CC) $(LDFLAGS) $(STRIPFLAGS) $(XCFLAGS) -o $@ $^ $(LIBS)
%.o: %.c wireless.h
$(CC) $(XCFLAGS) -c $<
%.so: %.c wireless.h
$(CC) $(XCFLAGS) $(PICFLAG) -c -o $@ $<

iwconfig: iwconfig.o $(IWLIB)

iwlist: iwlist.o $(IWLIB)

iwpriv: iwpriv.o $(IWLIB)

iwspy: iwspy.o $(IWLIB)

iwgetid: iwgetid.o $(IWLIB)

iwevent: iwevent.o $(IWLIB)

ifrename: ifrename.o $(IWLIB)

macaddr: macaddr.o $(IWLIB)

# Always do symbol stripping here
iwmulticall: iwmulticall.o
$(CC) $(LDFLAGS) -Wl,-s $(XCFLAGS) -o $@ $^ $(LIBS)

# It's a kind of magic...
wireless.h:
cp $(WEXT_HEADER) wireless.h

# Compilation of the dynamic library
$(DYNAMIC): $(OBJS:.o=.so)
$(CC) -shared -o $@ -Wl,-soname,$@ $(STRIPFLAGS) $(LIBS) -lc $^

# Compilation of the static library
$(STATIC): $(OBJS:.o=.so)
$(RM) $@
$(AR) cru $@ $^
$(RANLIB) $@

# Installation : So crude but so effective ;-)
# Less crude thanks to many contributions ;-)
install:: $(IWLIB_INSTALL) install-bin install-hdr install-man

# Install the dynamic library
install-dynamic:: $(DYNAMIC)
install -m 755 -d $(INSTALL_LIB)
install -m 755 $(DYNAMIC) $(INSTALL_LIB)
ln -sfn $(DYNAMIC) $(INSTALL_LIB)/$(DYNAMIC_LINK)
@echo "*** Don't forget to add $(INSTALL_LIB) to /etc/ld.so.conf, and run ldconfig as root. ***"
@$(LDCONFIG) || echo "*** Could not run ldconfig ! ***"

# Install the static library
install-static:: $(STATIC)
install -m 755 -d $(INSTALL_LIB)
install -m 644 $(STATIC) $(INSTALL_LIB)

# All the binaries. Careful, no dependancy on install-dynamic
install-bin:: all
install -m 755 -d $(INSTALL_DIR)
install -m 755 $(PROGS) $(INSTALL_DIR)

# Headers to go with the wireless lib (dev)
install-hdr:: wireless.h
install -m 755 -d $(INSTALL_INC)
install -m 644 iwlib.h $(INSTALL_INC)
install -m 644 wireless.h $(INSTALL_INC)

# How could you live without those manapages ?
install-man::
install -m 755 -d $(INSTALL_MAN)/man8/
install -m 644 $(MANPAGES8) $(INSTALL_MAN)/man8/
install -m 755 -d $(INSTALL_MAN)/man7/
install -m 644 $(MANPAGES7) $(INSTALL_MAN)/man7/
install -m 755 -d $(INSTALL_MAN)/man5/
install -m 644 $(MANPAGES5) $(INSTALL_MAN)/man5/

install-iwmulticall:: iwmulticall
install -m 755 -d $(INSTALL_DIR)
install -m 755 $< $(INSTALL_DIR)/iwconfig
( cd $(INSTALL_DIR) ; \
ln -f -s iwconfig iwlist ; \
ln -f -s iwconfig iwspy ; \
ln -f -s iwconfig iwpriv ; \
ln -f -s iwconfig iwgetid )

clean::
$(RM_CMD)

realclean::
$(RM_CMD)
$(RM) $(STATIC) $(DYNAMIC) $(PROGS) $(EXTRAPROGS) libiw* wireless.h

uninstall::
for f in $(PROGS); do \
$(RM) $(INSTALL_DIR)/$$f; \
done
$(RM) $(INSTALL_LIB)/$(STATIC)
$(RM) $(INSTALL_LIB)/$(DYNAMIC)
$(RM) $(INSTALL_LIB)/$(DYNAMIC_LINK)
$(RM) $(INSTALL_INC)/iwlib.h
$(RM) $(INSTALL_INC)/wireless.h
for f in $(MANPAGES8); do \
$(RM) $(INSTALL_MAN)/man8/$$f; \
done
for f in $(MANPAGES7); do \
$(RM) $(INSTALL_MAN)/man7/$$f; \
done
for f in $(MANPAGES5); do \
$(RM) $(INSTALL_MAN)/man5/$$f; \
done

# Include dependancies
-include *.d

so although i couldn't do the editing the way you instructed me to, i think i got the dog walked anyhow. if not, please let me know.

-continued on next post-

acmemetalfab
18th July 2006, 02:58 PM
-continued from above-


3) i went back to the terminal and ran the "make install PREFIX=/usr" command in the "wireless_tools.29" directory. here's the result of my doing that:

[root@localhost wireless_tools.29]# make install PREFIX=/usr
cp wireless.21.h wireless.h
gcc -Os -W -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow -Wpointer-arith -Wcast-qual -Winline -I. -MMD -fPIC -c -o iwlib.so iwlib.c
gcc -shared -o libiw.so.29 -Wl,-soname,libiw.so.29 -lm -lc iwlib.so
install -m 755 -d /usr/lib/
install -m 755 libiw.so.29 /usr/lib/
ln -sfn libiw.so.29 /usr/lib//libiw.so
*** Don't forget to add /usr/lib/ to /etc/ld.so.conf, and run ldconfig as root. ***
gcc -Os -W -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow -Wpointer-arith -Wcast-qual -Winline -I. -MMD -c iwconfig.c
gcc -Os -W -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow -Wpointer-arith -Wcast-qual -Winline -I. -MMD -o iwconfig iwconfig.o libiw.so.29 -lm
gcc -Os -W -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow -Wpointer-arith -Wcast-qual -Winline -I. -MMD -c iwlist.c
gcc -Os -W -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow -Wpointer-arith -Wcast-qual -Winline -I. -MMD -o iwlist iwlist.o libiw.so.29 -lm
gcc -Os -W -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow -Wpointer-arith -Wcast-qual -Winline -I. -MMD -c iwpriv.c
gcc -Os -W -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow -Wpointer-arith -Wcast-qual -Winline -I. -MMD -o iwpriv iwpriv.o libiw.so.29 -lm
gcc -Os -W -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow -Wpointer-arith -Wcast-qual -Winline -I. -MMD -c iwspy.c
gcc -Os -W -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow -Wpointer-arith -Wcast-qual -Winline -I. -MMD -o iwspy iwspy.o libiw.so.29 -lm
gcc -Os -W -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow -Wpointer-arith -Wcast-qual -Winline -I. -MMD -c iwgetid.c
gcc -Os -W -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow -Wpointer-arith -Wcast-qual -Winline -I. -MMD -o iwgetid iwgetid.o libiw.so.29 -lm
gcc -Os -W -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow -Wpointer-arith -Wcast-qual -Winline -I. -MMD -c iwevent.c
gcc -Os -W -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow -Wpointer-arith -Wcast-qual -Winline -I. -MMD -o iwevent iwevent.o libiw.so.29 -lm
gcc -Os -W -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow -Wpointer-arith -Wcast-qual -Winline -I. -MMD -c ifrename.c
gcc -Os -W -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow -Wpointer-arith -Wcast-qual -Winline -I. -MMD -o ifrename ifrename.o libiw.so.29 -lm
install -m 755 -d /sbin/
install -m 755 iwconfig iwlist iwpriv iwspy iwgetid iwevent ifrename /sbin/
install -m 755 -d /usr/include/
install -m 644 iwlib.h /usr/include/
install -m 644 wireless.h /usr/include/
install -m 755 -d /usr/man//man8/
install -m 644 iwconfig.8 iwlist.8 iwpriv.8 iwspy.8 iwgetid.8 iwevent.8 ifrename.8 /usr/man//man8/
install -m 755 -d /usr/man//man7/
install -m 644 wireless.7 /usr/man//man7/
install -m 755 -d /usr/man//man5/
install -m 644 iftab.5 /usr/man//man5/

so far, seems like no error messages.

4)here's where i think things start show signs they've gone wrong; i use the "iwlist scan" command and it says the following:

[root@localhost wireless_tools.29]# iwlist scan
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

eth2 Interface doesn't support scanning : No such device

eth1 Interface doesn't support scanning.

sit0 Interface doesn't support scanning.

fyi, my computer recognies the wieless card as eth02, and now it says there is no such advice.

5) i subsequently ran the "modprobe -r ndiswrapper", "modprobe ndiswrapper", "dmesg | tail -n 25", and "iwlist scan" commands, one at a time and in that order. here's what the computer had to say about that:

[root@localhost wireless_tools.29]# modprobe -r ndiswrapper
[root@localhost wireless_tools.29]# modprobe ndiswrapper
[root@localhost wireless_tools.29]# dmesg | tail -n 25
Netfilter messages via NETLINK v0.30.
ip_conntrack version 2.4 (8192 buckets, 65536 max) - 224 bytes per conntrack
eth1: link up, 100Mbps, full-duplex, lpa 0x45E1
bcm43xx: set security called
bcm43xx: .level = 0
bcm43xx: .enabled = 0
bcm43xx: .encrypt = 0
SoftMAC: Associate: Scanning for networks first.
SoftMAC: Associate: failed to initiate scan. Is device up?
bcm43xx: PHY connected
bcm43xx: Error: Microcode "bcm43xx_microcode5.fw" not available or load failed.
SELinux: initialized (dev rpc_pipefs, type rpc_pipefs), uses genfs_contexts
Bluetooth: Core ver 2.8
NET: Registered protocol family 31
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
Bluetooth: L2CAP ver 2.8
Bluetooth: L2CAP socket layer initialized
Bluetooth: RFCOMM socket layer initialized
Bluetooth: RFCOMM TTY layer initialized
Bluetooth: RFCOMM ver 1.7
Bluetooth: HIDP (Human Interface Emulation) ver 1.1
SELinux: initialized (dev autofs, type autofs), uses genfs_contexts
eth1: no IPv6 routers present
ndiswrapper version 1.18 loaded (preempt=no,smp=yes)
[root@localhost wireless_tools.29]# iwlist scan
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

eth2 Interface doesn't support scanning : No such device

eth1 Interface doesn't support scanning.

sit0 Interface doesn't support scanning.

i wish fedora core 5 had an ear. then i would twist said ear untill the box cried in pain, said uncle, and played nice with the wireless card, lol.

josefwhiter
18th July 2006, 03:44 PM
Hmm, thats fishy. Can you post the output from the following commands

lspci
ndiswrapper -l

If i'm right we may be able to do this without ndiswrapper.

Mordacil
18th July 2006, 05:17 PM
Ok, when I list the drivers, I come up with this:

bcmwl5 driver installed, hardware present
bcmwl5a driver installed, hardware present

Ndiswrapper has loaded fine with modprobe, and is listed in lsmod. When I try making an alias, it gives me this message:

Adding "alias wlan0 ndiswrapper" to /etc/modprobe.d/ndiswrapper

But it doesn't show up when I go to network setup. Help?

Edit: I added 'alias wlan0 ndiswrapper' to /etc/modprobe.conf, and in network config, 'wlan0' appeared as an option in wireless. So I set it up, but when trying to activate it, I'm given this message:

ndiswrapper device wlan0 does not seem to be present, delaying initialization.

acmemetalfab
18th July 2006, 11:02 PM
wish i knew what to tell you mordacil. it would appear that you have more expertise than me.

anyhow, here's what happens when i enter "lspci" :

[root@localhost ~]# lspci
00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
00:01.0 PCI bridge: Intel Corporation 82865G/PE/P PCI to AGP Controller (rev 02)00:03.0 PCI bridge: Intel Corporation 82865G/PE/P PCI to CSA Bridge (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801EB (ICH5) SATA Controller (rev 02)00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV38 [GeForce FX 5950 Ultra] (rev a1)
02:01.0 Ethernet controller: Intel Corporation 82547EI Gigabit Ethernet Controller (LOM)
03:05.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
03:0a.0 Ethernet controller: D-Link System Inc RTL8139 Ethernet (rev 10)
You have new mail in /var/spool/mail/root

huh? i have new mail? to bad i don't know how to check that, lol. anyhow, here is the result of entering the "ndiswrapper -l" command:

[root@localhost ~]# ndiswrapper -l
Installed drivers:
wmp54gs driver installed, hardware present

so i guess that much is good.

josefwhiter
19th July 2006, 02:39 AM
Oh sweet you already have a bcm43xx card, good that one works without ndiswrapper. Follow these instructions

http://fedoramobile.org/fc-wireless/bcm43xx-yum-livna

and also give me the output of

uname -a
cat /etc/modprobe.conf

and then I'll tell you what you need to do so it initializes everything on boot.

Mordacil
19th July 2006, 08:27 AM
[Cory@Laptoppy 80211g]$ uname -a
Linux Laptoppy 2.6.17-1.2157_FC5 #1 Tue Jul 11 22:55:46 EDT 2006 i686 athlon i386 GNU/Linux
[Cory@Laptoppy 80211g]$ cat /etc/modprobe.conf
alias eth0 sky2
alias snd-card-0 snd-atiixp
options snd-card-0 index=0
options snd-atiixp index=0
remove snd-atiixp { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-atiixp
alias /dev/ttySHSF[0-9]* /dev/ttySHSF
alias /dev/modem /dev/ttySHSF
alias char-major-240-* /dev/ttySHSF
alias char-major-240-* /dev/ttySHSF
options hsfserial serialmajor=240
alias char-major-242-* hsfosspec
alias char-major-242-* hsfosspec
alias /dev/hsfdiag* /dev/hsfdiag
alias /dev/hsfdiag* /dev/hsfdiag
alias char-major-243-* /dev/hsfdiag
alias eth1 ndiswrapper
options ndiswrapper if_name=eth1
alias char-major-243-* /dev/hsfdiag
options hsfosspec dcpmajor=242 diagmajor=243
alias symbol:cnxthwhda_probe hsfhda
alias symbol:cnxthwhda_resume hsfhda
alias symbol:cnxthwhda_suspend hsfhda
alias /dev/ttySHSF[0-9]* /dev/ttySHSF
alias /dev/ttySHSF[0-9]* /dev/ttySHSF
alias char-major-240-* /dev/ttySHSF
alias char-major-242-* hsfosspec
alias /dev/hsfdiag* /dev/hsfdiag
alias char-major-243-* /dev/hsfdiag
alias /dev/ttySHSF[0-9]* /dev/ttySHSF
alias char-major-240-* /dev/ttySHSF
alias char-major-242-* hsfosspec
alias /dev/hsfdiag* /dev/hsfdiag
alias char-major-243-* /dev/hsfdiag
alias /dev/ttySHSF[0-9]* /dev/ttySHSF
alias char-major-240-* /dev/ttySHSF
alias char-major-242-* hsfosspec
alias /dev/hsfdiag* /dev/hsfdiag
alias char-major-243-* /dev/hsfdiag
alias /dev/ttySHSF[0-9]* /dev/ttySHSF
alias char-major-240-* /dev/ttySHSF
alias char-major-242-* hsfosspec
alias /dev/hsfdiag* /dev/hsfdiag
alias char-major-243-* /dev/hsfdiag
alias /dev/ttySHSF[0-9]* /dev/ttySHSF
alias char-major-240-* /dev/ttySHSF
alias char-major-242-* hsfosspec
alias /dev/hsfdiag* /dev/hsfdiag
alias char-major-243-* /dev/hsfdiag
alias /dev/ttySHSF[0-9]* /dev/ttySHSF
alias char-major-240-* /dev/ttySHSF
alias char-major-242-* hsfosspec
alias /dev/hsfdiag* /dev/hsfdiag
alias char-major-243-* /dev/hsfdiag
alias /dev/ttySHSF[0-9]* /dev/ttySHSF
alias char-major-240-* /dev/ttySHSF
alias char-major-242-* hsfosspec
alias /dev/hsfdiag* /dev/hsfdiag
alias char-major-243-* /dev/hsfdiag
alias /dev/ttySHSF[0-9]* /dev/ttySHSF
alias char-major-240-* /dev/ttySHSF
alias char-major-242-* hsfosspec
alias /dev/hsfdiag* /dev/hsfdiag
alias char-major-243-* /dev/hsfdiag
alias /dev/ttySHSF[0-9]* /dev/ttySHSF
alias char-major-240-* /dev/ttySHSF
alias char-major-242-* hsfosspec
alias /dev/hsfdiag* /dev/hsfdiag
alias char-major-243-* /dev/hsfdiag
alias /dev/ttySHSF[0-9]* /dev/ttySHSF
alias char-major-240-* /dev/ttySHSF
alias char-major-242-* hsfosspec
alias /dev/hsfdiag* /dev/hsfdiag
alias char-major-243-* /dev/hsfdiag
alias /dev/ttySHSF[0-9]* /dev/ttySHSF
alias char-major-240-* /dev/ttySHSF
alias char-major-242-* hsfosspec
alias /dev/hsfdiag* /dev/hsfdiag
alias char-major-243-* /dev/hsfdiag
alias /dev/ttySHSF[0-9]* /dev/ttySHSF
alias char-major-240-* /dev/ttySHSF
alias char-major-242-* hsfosspec
alias /dev/hsfdiag* /dev/hsfdiag
alias char-major-243-* /dev/hsfdiag
install /dev/ttySHSF /sbin/modprobe hsfpcibasic2; /sbin/modprobe hsfmc97ich; /sbin/modprobe hsfmc97via; /sbin/modprobe hsfmc97ali; /sbin/modprobe hsfmc97ati; /sbin/modprobe hsfmc97sis; [ -e /lib/modules/`uname -r`/extra/hsfusbcd2.ko ] && /sbin/modprobe hsfusbcd2; /sbin/modprobe snd_hda_intel; /bin/true
[Cory@Laptoppy 80211g]$

acmemetalfab
19th July 2006, 04:37 PM
here's what happened- i followed all the instructions except that instead of downloading a driver from the list obtained by using the "gedit /usr/share/doc/bcm43xx-fwcutter-004/README" command i used the bcm43xx-fwcutter on the driver i had for the card that i had placed in the drivers directory in the ndiswrapper directory. that driver originally came from the disk supplied with the card a few months ago, i used it because i didn't know which other driver from the list to pick. i don't think that was a problem, because the screen output from then on was identical to the one shown on the http://fedoramobile.org/fc-wireless/bcm43xx-yum-livna site. the first potential problem i saw was this when i enetered the "'system-config-network'" command.

[root@localhost ~]# 'system-config-network'
/usr/share/system-config-network/netconfpkg/NC_functions.py:30: DeprecationWarning: rhpl.log is deprecated and will be removed; use python's logging instead
import rhpl.log
Warning: Driver for device eth2 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...

/usr/share/system-config-network/netconfpkg/gui/maindialog.py:962: GtkDeprecationWarning: gtk.timeout_remove is deprecated, use gobject.source_remove instead
gtk.timeout_remove(self.tag)

but the gui network window still opened, so i proceeded with the instructions. i didn't have to configure the settings at all; every detail from the MAC address to the hex key was already inputted. i saved it, but when i tried to activate it claimed i should see if it was plugged in. anyhow, here's the output of the command "uname -a" :

uname -a
Linux localhost.localdomain 2.6.17-1.2145_FC5smp #1 SMP Sat Jul 1 13:19:14 EDT 2006 i686 i686 i386 GNU/Linux

and here is the output of the command "cat /etc/modprobe.conf" :

[root@localhost ~]# cat /etc/modprobe.conf
alias scsi_hostadapter ata_piix
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
options snd-intel8x0 index=0
remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias eth1 8139too
alias eth0 e1000
alias eth2 bcm43xx
alias dev22531 e1000
alias dev22325 e1000
alias dev1804289383 e1000

i don't get it. here's an additional peice of info- i have a seperate hard drive with windows on it that makes use of the wireless card without problem. when i check the mac address on it, it's different than the one sensed by the fedora hard drive. isn't the mac address specific to a peice of hardware? shouldn't the mac address of the wireless card remain the same regardless of the environment it's installed on?
thanks again for all your help. this is a real pain in the arse for me, i'm sure it's even more anoying when it's not even your problem, lol.

Mordacil
19th July 2006, 04:53 PM
At josefwhiter:

Your suggestion worked. Thanks a bunch!

josefwhiter
19th July 2006, 06:59 PM
acmemetalfab, ok heres what I want you to do. reboot first of all, sometimes it just needs a good kick, and then when it comes up, open a terminal and run the commands

modprobe -r bcm43xx
modprobe bcm43xx
dmesg | taill -n 25

and give me the output. If worse comes to worse you can just bring the laptop to work next week and hand it off to sarah and I can fix it for you.

acmemetalfab
20th July 2006, 04:28 AM
ok joe, i did what you said...ithink we may be getting somewhere. btw, my name is craig. anyhow, i enetered the commands. the first two just went in with no comment from the machine, the third (which i assume should have read "dmesg | tail -n 25" and not "dmesg | taill -n 25") yielded the following:

[root@localhost ~]# dmesg | tail -n 25
bcm43xx: Chip initialized
bcm43xx: DMA initialized
bcm43xx: 80211 cores initialized
bcm43xx: Keys cleared
SoftMAC: Associate: Scanning for networks first.
SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
ADDRCONF(NETDEV_UP): eth2: link is not ready
bcm43xx: ASSERTION FAILED (radio_attenuation < 10) at: drivers/net/wireless/bcm43xx/bcm43xx_phy.c:1485:bcm43xx_find_lopair()
SoftMAC: Scanning finished
SoftMAC: Queueing Authentication Request to 00:16:b6:0c:c7:3d
SoftMAC: cannot associate without being authenticated, requested authentication
SoftMAC: Queueing Authentication Request to 00:16:b6:0c:c7:3d
SoftMAC: cannot associate without being authenticated, requested authentication
SoftMAC: Sent Authentication Request to 00:16:b6:0c:c7:3d.
SoftMAC: Sent Authentication Request to 00:16:b6:0c:c7:3d.
SoftMAC: Open Authentication completed with 00:16:b6:0c:c7:3d
SoftMAC: sent association request!
SoftMAC: sent association request!
SoftMAC: Authentication response received from 00:16:b6:0c:c7:3d but did not request authentication.
SoftMAC: associated!
ADDRCONF(NETDEV_CHANGE): eth2: link becomes ready
eth2: no IPv6 routers present
SoftMAC: Sent Authentication Request to 00:16:b6:0c:c7:3d.
SoftMAC: Open Authentication completed with 00:16:b6:0c:c7:3d

so it looked to me like the program found a way to make this work, and i opened the gui network box and tried to activate the eth2 (that's my wireless) connection. this time, instead of telling me pretty quickly that my cable was unplugged it told me "Determining IP information for eth2... failed.", and it took a while to let me know that.
i can hand off the box, but it isn't a laptop. alternatively, i can drive it to you and bring a case of beer. btw, i fix cars and build custom bikes and stuff, next time your ride breaks down don't hesitate to ask.

secretofnimh
20th July 2006, 06:01 AM
don't forget to depmod -a before modprobe'ing the bcm43xx driver. also, try setting it up to work with command line before using the network manager gui:

depmod -a
modprobe bcm43xx
/sbin/ifconfig eth2 up
/sbin/iwconfig eth2 key (open or restricted) ##############
/sbin/iwconfig eth2 essid ######
/sbin/dhclient eth2
/sbin/ifconfig eth0 down
/sbin/ifconfig eth1 down
ping google.com

Let me know if this works too.

acmemetalfab
20th July 2006, 03:35 PM
sorry bud, it didn't. thanks anyhow.

josefwhiter
20th July 2006, 04:41 PM
Ahh ok good we are getting a link, now we just need to get you connected to your wireless station. Don't use system-config-network, its crappy. Look at this article on how to use NetworkManager

http://www.redhat.com/magazine/003jan05/features/networkmanager/

Also, just to make sure, run the command

iwlist scan

to make sure that the NIC will actually scan stuff. If it does you are almost there, just follow along in that article and you should be good to go.

acmemetalfab
20th July 2006, 09:57 PM
sorry joe, no scanning here. the result of iwlist scan follows:

[root@localhost ~]# iwlist scan
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning : No such device

dev1804289383 Interface doesn't support scanning.

eth1 Interface doesn't support scanning.

sit0 Interface doesn't support scanning.

i'll read the article and get back to it on saturday when i get back from NY. enjoy the weekend.

Mordacil
22nd July 2006, 04:04 AM
Now I'm having problems accessing a WEP-encrypted network

acmemetalfab
23rd July 2006, 04:52 AM
i am also trying to gte on a wep encrypted network. maybe i wouldn't have problems if i took off the encryption? i'll try it, let's see...

Mordacil
23rd July 2006, 08:31 AM
SIOCSIFFLAGS: Permission denied

This is after I reinstalled Fedora, and redid fwcutter. That message appears when using 'sbin/ifconfig eth1 up' and '... eth1 down'.