PDA

View Full Version : Opera works - err shown started w/ terminal



jsabarese
3rd July 2006, 10:32 PM
Hello. I finally managed to get Opera installed on my Fedora Core 5.. i don't know what was the problem before-- but yesterday , i saw it in the prgrams list-- i'd searched Yum before, and nothing came up, so i went straight to Opera's page and d/l their RPM for v.9 on Fedora Core 5. all seemed to be okay (i did get a glitch at first ... don't recall exactly, but i re-installed opera and everthing seemed fine... )

everything seems fine when i'm running Opera, but i do get this error if i start Opear from the CLI:



~# opera
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.


suggestions? what does this mean to me?
thanks!

Jman
3rd July 2006, 11:05 PM
libjvm.so looks like Java. No idea about the error, though.

schwim
4th July 2006, 05:25 PM
Hi there :)

I know this doesn't help you, since you've already got it installed, but I figured I'd post this here in case anyone else is having an install problem with Opera:

Opera's .rpm for FC5 is flawed and checks for a misnamed dependency. You can see a related topic on the Opera website here (http://my.opera.com/community/forums/topic.dml?id=144487).

In short, installing the Opera rpm with the nodeps tag gets Opera running. That is assuming of course that your FC has all of the necessary deps required(mine did, and from browsing the web, this is usually the case).

Command:

rpm -Uvh --nodeps opera-9.0-20060616.6-shared-qt.i386-en.rpm

thanks,
json

jsabarese
4th July 2006, 10:33 PM
Re: HOW TO INSTALL OPERA 9 - CLI

Command:

rpm -Uvh --nodeps opera-9.0-20060616.6-shared-qt.i386-en.rpm

hey there! this is definitely good info to post here. i'm a believer in the whole forums-are-here-for-group-learning concept. i've learned a lot from reading about other peoples' problems and solutions-- it's the only way to learn some 'history' or be doomed to repeat it, right? what better place to read than right where people are talkin' about the troubles.

on to the question at hand-- although, i didn't use Schwim's method (perhaps i didn't need it because of my java situation (see below) my question is this: why the -Uvh ?

to clarify-- my concern is not w/ opera-- it/s whether this error indicates anything of a 'larger scale' which may also error on my system? of this IS a java error, the i should NOTE that i installed the JDK from Sun (http://ccl.net/cca/software/SOURCES/JAVA/JSDK-1.5/index.shtml) i welcome feedback on that issue, please.

anyway-- for the record, my opera gives me no problems that i've noticed. it installed okay-- i don't recall any errors during install. the 'glitch' i mentioned, far as i recall' was upon first run of the installation. .. an intial setup wizard i believe? i think that crashed on me. don't quote me on that though. ;)
whatever that glitch, all i know is i haven't had any probs since, and i've done heavy enough stuff-- swf's, zipped stuff, ftp, zooming, view source, validate, etc... so, if i can do all of that, i'm happy. oh, yeah-- and the panels too. :) is it just me, or does Opera 9 kick @ss?
my only disappointment w/ it is the lack of support for the G-Something's (shh... i didn't want to derail it there, but had to say it. sorry)

7edora5
5th July 2006, 03:47 PM
I think I am getting the same error in FC5 when starting Opera9.

And I noticed one other problem: I am getting weird black and white lines when I move the mouse pointer over a link. Almost looks like a bar code. Very irritating. Could that be part of some Java problem as well?

Invader02
5th July 2006, 03:57 PM
Wow that's wierd... how come my opera is working flawlessly and yours aren't?

Course then again what i did was
rpm -F opera*
over my old opera 8.54 installation...

schwim
5th July 2006, 05:17 PM
Well, I can't get any java applets to load, but I haven't loaded Opera from the terminal to see what errors I get. I assume it will be the same as you guys.

Have you checked the preferences to see if Opera is pointing to the right Java? I looked last night, but never got around to checking to see if it was the right one or not.

thanks,
json

savio_mit_glug
6th July 2006, 11:53 AM
Hello!

I had the same problem with Opera 9 Beta 2 running on Fedora Core 5.

I asked around at the Opera Forums and got some good answers. Why don't you try joining the Opera Forums? I got a lot of good advice there. My post about this problem is here:
http://my.opera.com/community/forums/topic.dml?id=140285
I'm not sure if you should be signed up and logged in to read it.
I'll try to explain what I did, but I'm just a newbie and there are lots of experts at the Opera Community forum who could help you much more.
Anyway, here's what I did:
After searching around the Opera forums, I found what I was looking for at:
http://my.opera.com/community/forums/topic.dml?id=106717

It seems that a file called libjava.so is somewhere on my system and I should find out where it is..

So, I tried


[root@localhost i386]# locate libjava.so
/usr/lib/libglibjava.so
[root@localhost i386]#

From what others said, I expected the file to be at /opt but the search didn't turn up anything at /opt, so I went to /opt and searched around some more and I found the file "libjava.so" at /opt/jre1.5/lib/i386/libjava.so

Then, I created a file called javapath.txt in the directory .opera (a hidden directory ) in my home directory and wrote the path of the libjava.so file inside it:


[savio@localhost .opera]$ emacs javapath.txt
[savio@localhost .opera]$ cat javapath.txt
/opt/jre1.5/lib/i386
[savio@localhost .opera]$ opera
ScimInputContextPlugin()

As you can see above, I don't get the error messages when I start up Opera anymore.

Hope this helps.

Yours,
Savio

7edora5
6th July 2006, 02:24 PM
Thanks for all the input. I will tackle the problems now one at a time. I could not get all the entries from the boot loader yet, because it looks my university is facing server issues with some of the installation packages right now so that I am stuck now anyway. In the meantime I am exploring FC5. Interesting new experience...