View Full Version : problems installing firefox 1.5

3rd July 2006, 08:04 PM
I am totally new to Linux and still learning :confused: . I am using FC4 and I have tried to install Firefox 1.5. I have downloaded the tar to my home directory, extracted it to the same location, and ran yum install firefox. When I open fireox, it still opens to 1.0.7. I have tried two different rpm's and both state that a newer version is currently installed, so they don't do anything. Can anyone help with what I am doing wrong?

Thanks in advance :D

Craig Pemberton
3rd July 2006, 08:11 PM
Generally what is in the offical yum repositories is the best compromise between stability and being up to date. Simply

yum install firefox
yum update

This will not install the rpm you downloaded, but should get you 1.5. . .

yum localinstall <filename.rpm> will install that rpm you downloaded.

If you used rpm -i instead of rpm -U you may have two versions of firefox installed on your system.

Try this to check

rpm -qa | grep firefox

4th July 2006, 05:00 AM
yum update did nothing more waste an hour and half. any other ideas?

4th July 2006, 05:19 AM
yum update did nothing more waste an hour and half. any other ideas?

Sir, I imagine with that appreciative attitude towards those that are trying to help you, no, I don't think the ideas are going to flow forth for your benefit.

Yum doesn't waste time. People screwing up their installs by installing multiple instances of an application wastes time. What I think you need to do is find those instances of FireFox, removing them and then installing whichever flavor of FF you want to run, whether it's Fedora's version or Mozilla's.

For FC 4, Fedora only offers up to 1.0.8, so if you want 1.5+, you'll need to download and install it. Find all your old installations by running "rpm -qa | grep firefox" In the terminal. Once you've found them, remove ALL of the previous installs, and run "yum localinstall <filename.rpm>" to install a version you've already downloaded, as Mr. Pemberton took the time to suggest.

You guys should be nicer to the enthusiasts trying to help you out of the bind you've put yourselves in.

Check this thread (http://forums.fedoraforum.org/forum/showthread.php?t=115574) for some solutions to a similar problem that another user's having.

Shame on you! :D

5th July 2006, 04:18 AM
I wasn't trying to be rude to Pemberton. I am just frustrated with trying to learn a completely new OS, on top of trying to fix a hardware problem on another PC that I've spent all day on. Again, my apologies if I came off as rude. I am just very, very new to Linux and wish very much to use 1.5 firefox as opposed to 1.0.8

5th July 2006, 04:43 AM
Just remember this, and your time here will be nothing but lollipops & rainbows:

1) The people helping you(with rare exception) didn't write the system you're having trouble with.

2) Anyone using FC has been through what you're going through, and they lived to tell the tale.

3) Any replies are done out of the kindness of the poster's heart, and there's no reason not to be appreciative for that.

That being said, we all get frustrated. We's cool, if you's cool. Cool?

RE: your firefox prob

If you want 1.5, you're going to need to do a manual install OR upgrade to FC5. FC4's repo's only go up to 1.0.8. So, if you want that, what you need to do is to download the repo from Mozilla, uninstall your current version, and install the rpm that you downloaded.

First, uninstall the version that came with your install. "yum remove firefox" should get rid of your official install. Then find out if you have any more versions floating around by running "rpm -qa | grep firefox" If you have any left, uninstall them using the rpm command "rpm -e packagename", since you didn't install it via yum, you can't uninstall them via yum :)

You good now? No more Firefox on your system? Install the new version now:

rpm -Uvh firefox-packagename-buncho'numbers.rpm

That should give you a fresh install of the firefox version you downloaded.

Then you're going to need to point your applications to it(telling them to open items in FF, if you want to use it as the primary browser). You can do this through the Control panel in your Desktop menu.

Let us know if you get stuck, and good luck!


8th July 2006, 07:56 PM
If you can read French a little bit :D there is a French guy Remi who runs his own repo with alone Firefox and Thunderbird and Cairo. He supports 35 languages...


Hopefully this helps you out. The site is very, very slow... ;)


17th July 2006, 11:40 PM
i wound up uninstalling firefox completely and then installing the tar and it installed for me. I appreciate everyone's help and patience with a newbie

18th July 2006, 06:22 PM
For future reference, if you download any source tarball and extract the contents (tar xvfz [name].tar.gz) there will usualy be a "INSTALL" file inside the base directory of the tarball telling you how to install the application.

seshomaru samma
24th July 2006, 01:48 PM
I've been following this thread with interest because I'm on FC4 and would like firefox 1.5
Can anyone point me to an RPM link?
all i manged to do was to find a tarball but couldnt install it (there was no INSTALL file)

24th July 2006, 01:55 PM
I've been following this thread with interest because I'm on FC4 and would like firefox 1.5
Can anyone point me to an RPM link?
all i manged to do was to find a tarball but couldnt install it (there was no INSTALL file)

A few seconds with Google turned up this:



seshomaru samma
24th July 2006, 02:35 PM
I guess my google skills are not as developed....

(I spent an hour :confused: :( )

seshomaru samma
27th July 2006, 11:49 AM
Still < I downloaded the RPM but it has a dependency called Cairo which yum didn't find
So I'm still with the old firefox....

5th August 2006, 01:34 PM
yum install cairo cairo-devel

5th August 2006, 08:17 PM
In my posting to this threat a little bit higher I referred to a French link. Actually he provides you with the data for adding his repository to yum and allows you to install the current version of Firefox with yum. Even if his site is mainly in French, you should be able to install firefox in English.

I have the remy repository standard active in yum and recently had an automatic update.

Good luck,