PDA

View Full Version : Sound is broken in Fedora Core 5



mkurtis
3rd July 2006, 04:48 PM
I just installed fedora core 5, then I went and got all the mp3 suppport from yum. The problem is that whenever I play any sound, the sound skips around like its coming from a cd player that you are shaking. It does that when I try to detect my soundcard too, i can hear the sound, it's just really choppy. My sound card is an onboard, Fedora sees it as "VIA 8235"

Thanks

Seve
4th July 2006, 02:30 PM
Hello:
Have a look here for configuring your multi-media as well as other items:
http://stanton-finley.net/fedora_core_5_installation_notes.html
It should help you.
Seve

mkurtis
4th July 2006, 03:38 PM
Thanks for the reply Seve. I can't find anything about soundcard on that page, just multimedia apps which i believe are working fine.

mkurtis
6th July 2006, 07:51 PM
I have been reading about problems with ALSA, I have version 1.0.11-4 and I have read that updating to 1.0.11-47 helps some people. How do I get this package, it doesn't show up in yum.

Seve
6th July 2006, 11:01 PM
I have been reading about problems with ALSA, I have version 1.0.11-4 and I have read that updating to 1.0.11-47 helps some people. How do I get this package, it doesn't show up in yum.
Hello:
I am not sure where you can get the package .. you may want to look at the development repos?
You may want to have a look here, hopefully it may help: http://people.redhat.com/stransky/alsa/
hth
Seve

mkurtis
7th July 2006, 07:26 PM
I went to that website and tried aplay, which only plays the first couple seconds of a wave and then repeats it indefinitely. I then installed the kernel-devel package and tried to install the alsa-driver tarball. It gave me this error on ./configure:
checking for kernel linux/version.h... no
The file /lib/modules/2.6.17-1.2139_FC5/source/include/linux/version.h does not exist.
Please install the package with full kernel sources for your distribution
or use --with-kernel=dir option to specify another directory with kernel
sources (default is /lib/modules/2.6.17-1.2139_FC5/source).

I tried directing it to /lib/modules/2.6.17-1.2139_FC5/source but it gave me the same error. I searched for linux.h and it found it at /usr/include. I pointed configure to there and it worked. When I tried make it gave me errors on every line, I think it is probably too long to post.

mkurtis
10th July 2006, 04:19 AM
I updated my kernel to 2.6.17-1.2145 using pup, and now I get different (and postable) errors on make:
make -C /lib/modules/2.6.17-1.2145_FC5/source SUBDIRS=/home/mkurtis/alsa-driver-1.0.11 O=/lib/modules/2.6.17-1.2145_FC5/build modules
make[1]: Entering directory `/usr/src/kernels/2.6.17-1.2145_FC5-i686'
CC [M] /home/mkurtis/alsa-driver-1.0.11/acore/hwdep.o
CC [M] /home/mkurtis/alsa-driver-1.0.11/acore/memalloc.o
CC [M] /home/mkurtis/alsa-driver-1.0.11/acore/sgbuf.o
CC [M] /home/mkurtis/alsa-driver-1.0.11/acore/memory_wrapper.o
CC [M] /home/mkurtis/alsa-driver-1.0.11/acore/pcm.o
make[4]: *** No rule to make target `/home/mkurtis/alsa-driver-1.0.11/acore/pcm_native.s', needed by `/home/mkurtis/alsa-driver-1.0.11/acore/pcm_native.o'. Stop.
make[3]: *** [/home/mkurtis/alsa-driver-1.0.11/acore] Error 2
make[2]: *** [_module_/home/mkurtis/alsa-driver-1.0.11] Error 2
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/usr/src/kernels/2.6.17-1.2145_FC5-i686'
make: *** [compile] Error 2

What should I do to fix this? I also got this on ./configure, which I don't know if it's an error but it does look suspicious (last two lines):
config.status: creating include/autoconf-extra.h
Hacking autoconf.h...

Thanks

kamfbd
7th September 2006, 09:43 PM
Hi,
try this link.
http://www.gurulabs.com/goodies/downloads.php

Maybe you do not have /sbin/cryptomount
Regards