PDA

View Full Version : Installation of aiglx messed up xserver BADLY



cruzdiaz
30th June 2006, 04:47 AM
Hello
I was trying to install aiglx following the instructions from the fedora project site, but the so gracious version installed by the ``update`` does not run in my pc because it was compiled for an old kernel.
Now my xserver does not run at all, and it has been impossible for me to remove this version and reinstall the old one.
Does somebody know how can I fix this?
I was trying to build xorg from scratch but this also failed.

My kernel: 2.6.16-1.2080
Message I`m getting:

BUILD OPERATING SYSTEM: LINUX 2.6.9-22.18.bz155725.ZELsmp i686, CURRENT OPERATING SYSTEM: LINUX 2.6.16-1.2080_FC5smp
...
(EE) MODULE ABI MAJOR VERSION (0) DOESN`T MATCH THE SERVER`S VERSION (1)
(EE) FAILED TO LOAD MODULE ``FGLRX`` (MODULE REQUIREMENT MISMATCH, 0)
(EE) NO DRIVERS AVAILABLE.

This is with the ati driver, but I`ve tried the vesa driver and all I get is a similar error.

cruzdiaz
30th June 2006, 05:24 AM
OK, maybe I overreacted... my xserver is running again, after getting rid of those evil aiglx modified packages.

I do think that there must be a way to control that kind of version conflicts though.