PDA

View Full Version : Reading a LVM FC5 i386 HD on a FC5 PPC Laptop, Need help!



CrossGT-6
30th June 2006, 12:37 AM
Ok I have been trying for some time to figure out how to access my old laptops HD I kept when I sold it. It was running FC5 i386.

I have it in a external enclosure and I can see the /boot but not the main partition. I need to pull the data off it but I can not access it.

I got some information from it that its a Linux_LVM but thats all I know. I thought installing FC5 PPC would allow me to access it. I still can not access it though. I am running the updates on it but basically I am at a loss as to how to mount that parition.

I made my partition ext3 this time and did not use lvm... if that was my error I can I guess I can reinstall but damit there has to be some way to access this drive and I am running out of idea's! :confused:

CrossGT-6
1st July 2006, 05:21 PM
Ok I tried reinstalling everything from the i386 dvd and the external drive on a family members desktop, tried mounting the drive to there installation but nothing works it errors when copying the install image to disc. So I am completely lost.

Maybe it is a bad disc but what I need is some help and no one here seems to have any ideas....

The LVM partition is ext3 but nothing will access the lvm I can look at it (aka see its a partition) but nothing more, no way to mount it that I have found nothing.

I am really getting upset and lost here. I have been getting some help at thre ubuntu forums but I find it odd that no one at the Fedora forums has any ideas....?

ccrvic
1st July 2006, 05:27 PM
I am really getting upset and lost here.

So calm down and start reading some manuals.

Start with the man page for vgscan.

Vic.

CrossGT-6
1st July 2006, 09:51 PM
I have been learing about some of the functions and I can see the drive using lvm but I can not figure out how to get the computer to mount the actual lvm on the other partition it see's the size but thats it. I have been reading the manual on lvm for awhile now.

I will try the spec on you recommend. Hopefully that will tell me how but I am still lost as to how to get the system to actually read the data on the lvm partition/setup.

SlowJet
1st July 2006, 10:19 PM
su -
rootpassword
vgs
# If the vg does NOT show as active (a) then
vgchange -a y VolGrouupxyz
# For more details
vgdisplay

lvs
# For more details
lvdisplay


mkdir /mnt/mylvmzyz #(I would normally put this under /home/userme//somemntpointdir)
mount /dev/mapper/VolGroupxyz-LogVolxyz /mnt/mylvmvolxyz
cd /mnt/mylvmxyz

# if needed to accesss
chown -R username:username /mnt/mylvmxyz
chmod 0755 -R /mnt/mylvmxyz


#if needed for SELinux
fixfiles relablle mnt/mylvmxyz

good luck,
SJ

CrossGT-6
2nd July 2006, 12:01 AM
Well I started to get errors when playing with lvm... hopefully its nothing but it seemed to be read errors.... something about first 0 to 2450. I will try everything above but I am about to give up.. i really REALLY hate to because there is a lot of stuff to refind and some things I don't have backed up I am not 100% sure though I have som many DVD's to look through on my extra data.

Thanks again and hopefully this will work!