PDA

View Full Version : Using an external Hard Drive for Windows and Linux



griffse
29th June 2006, 06:59 PM
All,

I have a Seagate 300GB mounted in a USB HDD enclosure that I would like to use for both Windows and Linux. I also need to be able to write files > 4GB to the disk. I have tried:
http://www.ridgecrop.demon.co.uk/index.htm?fat32format.htm

that solution and several other forum threads but I don't think the file size limitation has been sucessfully overcome. I can format that drive and have the entire 300GB, well 279.5GB, available to me. Does anyone know how to overcome this? Thanks in Advance!

SG :cool:

sammyd253
29th June 2006, 08:48 PM
Assuming I've followed everything correctly here, your format should be just fine. When you format a drive, especially one that big, you aren't going to have all 300GB available to you. The same thing happens to me with my 120GB HD. It formats as 111GB. The 300GB is just the space size that manufacturers put on their products because they use a different measurement method than the operating system itself. I'm sure you can find more information on that yourself if you want. Hope that helps some.

Effie04
29th June 2006, 09:03 PM
Well, maybbe you could format your 300GB HD with ext2/3 filesystem and use program like ext2ifs (http://uranus.it.swin.edu.au/~jn/linux/ext2ifs.htm) which installs support for EXT2/3 fs on windows.

other chance is taking a risk and using ntfs with writing permissions (though i dont know how stable it is for use...)

griffse
29th June 2006, 09:13 PM
Thanks to both for replies without the RTFM attitude.

Sammyd, I am able to format and have the drive's space available after the obligatory overhead by said filesystem. The problem is that you cannot write a file larger than 4.1 GB to FAT32. Just curious to see if anyoen has managed to overcome that.

Effie, thanks for the tip, I have debated using one of the filesystem "emulators" and formatting the drive as NTFS or EXT3 but neither of those are real appetizzing for read/write if you know what I mean.

Currently the drive is formatted ext3 and I will only use it for Linux right now or maybe one of the ext3 doodads for Windows if it becomes absolutely necessary. Thanks again for the help!

sammyd253
5th July 2006, 03:40 AM
Oh alright, I didn't know that. I'm using a 120GB drive formatted as FAT32 and all is working well right now. I haven't had a chance to test moving a file that's bigger than 4.1GB, only because I don't have a single file on my computer that's that big. If I run into any other problems, or stumble across a fix for your issue, I'll post about it. Until then, hope everything else is working fine for you.

wshawn
5th July 2006, 04:30 AM
You cannot create a file larger than (2^32)-1 bytes (this is one byte less than 4 GB) on a FAT32 partition.

Source: Microsoft Limitations (http://support.microsoft.com/default.aspx?scid=kb;EN-US;q314463#appliesto)