PDA

View Full Version : Noobie with NIC problems FC4



EvMan
28th June 2006, 12:39 PM
Hi, Im a noobie at this so all help is appreciated, nice simple answers would be good too.

I have installed fc4 on my PC and everything seems to have been working fine including my NIC which comes up as 3com 3c390. One of the first things I did after an install and general setup was '# yum upgrade'. After this was completed I rebooted the machine as a new kernel had been installed. I started with 2.6.11-1.1369_FC4 and now have 2.6.17-1.2139_FC4, this was automatically done by yum.

Upon rebooting the new kernel comes up with an error that 'sk98lin device eth0 does not seem to be present, delaying initialization'. This did not appear under the old kernel 2.6.11-1.1369_FC4 my NIC worked fine.

I seem to have read lots of forums but no one seems to have the same problem I do. If I type 'modprobe sk98lin' it returns Fatal: module sk98lin not found.

How do I tell if the drivers for the NIC are on the system or not?

'dmesg' returns nothing about eth* in the list that it outputs and if I go 'ifconfig' it simply shows a loopback adapter.

I have tried to install the drivers from an RPM from here http://dl.atrpms.net/all/sk98lin-8.31.2.3-8.rhfc4.at.i386.rpm but it comes back with 'sk98lin-kmdl-8.31.2.3-8.rhfc4.at is needed by sk98lin-8.31.2.3-8.rhfc4.at.i386'. I have not been able to work out what kmdl is either.

Any ideas?? Can I use the sk98lin module from the older kernel (working) in the newer kernel (not working)??

Thanks
EvMan :confused:

grepsy
29th June 2006, 02:41 AM
if you do an lspci do you get anything about your ethernet card?

lazlow
29th June 2006, 04:00 AM
EvMan

A couple of things: 1. Read the warniings about using atrpms (the can cause all kinds of trouble).

2. I THINK that that is the wrong driver. The typhoon driver is used for most of 3coms 10/100 nics and the sk98lin is for the 10/100/1000 nics. From what I could tell your nic is built into the motherboard?

3.Why don't your double check the nic model. It would also help if you would post your /etc/modprobe.conf.

4. You can locate any file by: open terminal, switch to root ("su -" not "su"), type "updatedb"(depending on the last time this was done it may take a few minutes), locate filename (may still be slocate in FC4).

Depending on your modprobe.conf this may be an easy fix.

Lazlow

EvMan
29th June 2006, 04:57 AM
I can't run any commands just yet, Im at work (for a couple of hours yet) and the box is at home.

Is there a command I can run to determine what nic model fc4 thinks is in the system?

I'll post my modprobe.conf as soon as I get home and run lspci.

The 2.6.11 kernel uses the sk98lin but the 2.6.17 doen't and I don't know why.

But thanks for the help all the same grepsy & lazlow. I'll try your suggestions after I get home and post the outcomes.

EvMan

lazlow
29th June 2006, 05:44 AM
In FC4 I think it is hardware. If you are using gnome I think it is Applications->system tools_> hardware.
It may be hardware monitor or browser, just look for somthing close. Is it a built in nic or a card? lspci will list all hardware on the pci bus. Heres mine:

00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev a3)
00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a3)
00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio Controller (rev a2)
00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev f2)
00:08.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev a2)
00:0a.0 Bridge: nVidia Corporation CK804 Ethernet Controller (rev a3)
00:0b.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce 6600] (rev a2)
05:08.0 Ethernet controller: 3Com Corporation 3CR990-TX-97 [Typhoon 168-bit] (rev 02)

I have two ethernet connections a 3Com 3cR990 nic card (typhoon driver) and the bilt in nvidia (forcedeth driver).

lazlow

EvMan
29th June 2006, 08:50 AM
This is the contents of my modprobe.conf file
------------------------------------------------------
alias eth0 sk98lin
alias scsi_hostadapter ata_piix
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
options snd-intel8x0 index=0
remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias char-major-81 cx8800
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
-----------------------------------------------------
When I run lspci in the 2.6.17 kernel I get the following
----------------------------------------------------
00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
00:01.0 PCI bridge: Intel Corporation 82865G/PE/P PCI to AGP Controller (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801EB (ICH5) SATA Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV28 [GeForce4 Ti 4200 AGP 8x] (rev a1)
02:02.0 Ethernet controller: 3Com Corporation 3c940 10/100/1000Base-T [Marvell] (rev 12)
02:09.0 Multimedia video controller: Conexant CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)
--------------------------------------------------------------------------------------------------------------
The NIC is onboard and it is an abit 'is7-e' mobo.

Where to from here do you think?

lazlow
29th June 2006, 09:33 AM
It is a 3c940 not the 3c390 that you had said intially.(the driver should be ok) The 2.6.17-1.2139_FC4 kernel has been having some issues. I would fall back to 2.6.16-1.2115. The last stable kernel I could find for FC4.

http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/i386/

You can double click on the kernel you want and it will install as you gollow the prompts.

Or you can yum install kernel-2.6.16-1.2115_FC4.i686 (I think)

See if that helps

lazlow

EvMan
29th June 2006, 11:17 AM
Okay my solution...and many thanks to lazlow for his help, even though I feel like the king of the Noobs for telling everyone I have a different NIC that I actually had.

After reading lazlow's advice I followed his link and tried to install 2.6.16-1.2115_FC4, but the installation process told me a new version was already installed.

So I took a punt as I was unsure what the following command would do to my install.

'yum remove kernel-2.6.17' (I was doing this in my first kernel 2.6.11)

I was prompted to answer yes or no, I voted in the affirmitave. This appeared to remove the newer kernel.

I re-ran the 2.6.16-1.2115_FC4 I just downloaded and it installed successfully, I rebooted my machine and launched the new kernel (2.6.16).

The network card worked first time, with no problems. Again I ran 'yum upgrade' it asked if I wanted to install kernel-2.6.17, I said no, it didn't want to install anything else so I assume everything is uptodate.

Everything now appears to be working as I believe it should.

Again my thanks to lazlow and to grepsy for there suggestions.

I'm very happy now. :D :) :cool:

A.Serbinski
4th May 2007, 04:42 PM
For anyone looking at this problem in the future, the problem is a bug in the modprobe.conf file. In 2.6.17, the sk98lin driver was replaced with skge. Change all references to sk98lin in /etc/modprobe.conf to skge.