PDA

View Full Version : Lost keyboard in KDE



mickeyboy
25th June 2006, 12:09 AM
Yesterday FC4, and today on a different computer FC5, both i386 computers, in KDE ,lost use of keyboard, mouse works okay. If you log into SU KDE the keyboard works fine, logging into Gnome keyboard also works.
Updates couldn't be affecting this problem, it happens in a /user directory, Something is changing setting in the user directory.
The one thing that these two different computers have in common is they are using a ATI 9200SE video adapter.

Jim

briggers
3rd July 2006, 05:44 PM
Yesterday FC4, and today on a different computer FC5, both i386 computers, in KDE ,lost use of keyboard, mouse works okay. If you log into SU KDE the keyboard works fine, logging into Gnome keyboard also works.
Updates couldn't be affecting this problem, it happens in a /user directory, Something is changing setting in the user directory.
The one thing that these two different computers have in common is they are using a ATI 9200SE video adapter.

Jim
Have the same or very similar problem. Have a small network of FC4 workstations using KDE and 2 FC4 servers. The home directories of all users are on one of the two servers and are mounted with nfs. All workstations kept up to date using auto Yum.
One user, and only one, has a dead keyboard on each of the workstations that she tries to log into. All the other users have good keyboards on all of the workstations. Can switch session from the "dead keyboard" user to another user on the same workstation and the keyboard works for the new user - switch sessions back and it still does not work for the original user. Started to happen on 29th June. Was fine before.
Can ssh into the user's machine - no problems.
Guess its in the KDE config but where??

mickeyboy
3rd July 2006, 08:20 PM
This is very strange, I have just had another box in my family, do the same thing.
On my FC4 box I tar -cvf my /home/user directory and deleted same and added a new user ,same name, and now I'm back in operation, with full keyboard support.
Crazy.
I sure hope someone figures this out, i'm not going install any new boxes , for anyone until it's fixed.
Luckly my brother also had Gnome installed and he's now doing everything from there, but he prefers KDE.
i googled and found that a few people has had this problem in Suse-10.
And I have noticed that all the boxes this has happen to has ATI video cards installed.

Jim

briggers
4th July 2006, 09:43 AM
OK, found the answer to my problem. Maybe it will help you.
We normally use KDE but tried logging this user in using Gnome - and the keyboard worked correctly
So problem had to be with KDE, not hardware, not FC4 and not X
Logged back into KDE and discovered (accidently that if a key was held down for half a second or more then it worked)
Hunted around for a setting that controlled the keyboard response rate and found in:
KDE Control Centre | Accessibility | Keyboard Filters (tab) | Use Slow Keys (checkbox) was ticked
Unticked and Applied
Voila -- keyboard worked as normal

I have no idea how this flag was changed - maybe there is a keyboard shortcut combination which toggles the flag - and for the moment I am not looking now that I know the solution to the problem.

Hope this helps you
Richard

mickeyboy
4th July 2006, 04:26 PM
Yes I found out from a LinuxQuestions user.
It is if you accidently hold down the "Shift" key for more than 8 seconds it
will disable the keyboard, to fix problem, hold down the "Shift" key again for 8 seconds and it will reenable your keyboard. And change the Slow Keys setting as you described.
Thanks much for your help.
Now I got to fix the problem with no Screensavers in Suse-10.1.

Jim

kokocamp
11th October 2006, 09:16 AM
Yes I found out from a LinuxQuestions user.
It is if you accidently hold down the "Shift" key for more than 8 seconds it
will disable the keyboard, to fix problem, hold down the "Shift" key again for 8 seconds and it will reenable your keyboard. And change the Slow Keys setting as you described.
Thanks much for your help.
Now I got to fix the problem with no Screensavers in Suse-10.1.

Jim

So, how to disable the automatic 8 secs trigger?

briggers
11th October 2006, 09:24 PM
So, how to disable the automatic 8 secs trigger?

KDE Control Center | Regional & Accessibility | Accessibility | Keyboard Filters
Change settings to suit

Richard

kokocamp
12th October 2006, 05:15 AM
KDE Control Center | Regional & Accessibility | Accessibility | Keyboard Filters
Change settings to suit

Richard

I dont see any Keyboard Filters link inside the Accessibility. The Accesibility window only shows Bell and Keyboard tab. The Keyboard tab contains 4 group box such as Sticky Keys, Slow Keys, Bounce Keys, Activation Gestures. What would i choosed?

Are you using FC4 as same as like me?

briggers
12th October 2006, 10:00 AM
Sticky Keys (read the descriptions on the page)
Yes, this is FC4 but more to the point it is KDE 3.5.5
If you are using an earlier version of KDE you should update to at least this version. I think it is the latest that you can update to using YUM since FC4 has gone to legacy in view of imminent arrival of FC6

Richard