PDA

View Full Version : FC5 -Rosegarden Problems



electroconvulsi
15th June 2006, 12:30 PM
somehow managed to install rosegarden from the rpm I downloaded onto my FC5 machine. During the install I was given a warning about malicious code and now its installed I cannot get it to run. Is there any extra configuration involved post install for this app? How do I uninstall it and then reinstall it using yum from a local repository and how do I creat a local repository?

JordanN
16th June 2006, 06:52 AM
Eventually, all PlanetCCRMA items will be available from Fedora Extras. Right now, however, you will need the PlanetCCRMA repositories:

Become root:

su

Remove your existing RoseGarden install:

rpm -e rosegarden

Next, install the PlanetCCRMA repositories:


rpm -Uvh http://ccrma.stanford.edu/planetccrma/mirror/fedora/linux/planetccrma/5/i386/planetccrma-repo-1.0-2.rhfc5.ccrma.noarch.rpm

Now, install rosegarden:

yum install rosegarden

electroconvulsi
16th June 2006, 08:54 AM
I Uninstalled my original copy of rosegarden and installed the repository as suggested then used command yum install rosegarden and this is the output I got. I think that there is something wrong with the repository.

[root@techno-101 ~]# yum install rosegarden
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
planetcore [1/7]
planetcore 100% |=========================| 951 B 00:00
livna [2/7]
livna 100% |=========================| 951 B 00:00
planetextras [3/7]
planetextras 100% |=========================| 1.1 kB 00:00
planetccrma [4/7]
planetccrma 100% |=========================| 951 B 00:00
core [5/7]
core 100% |=========================| 1.1 kB 00:00
updates [6/7]
updates 100% |=========================| 951 B 00:00
extras [7/7]
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
Parsing package install arguments
No Match for argument: rosegarden
Nothing to do

electroconvulsi
16th June 2006, 06:24 PM
To correct myself and greenlead who did take the time and effort to try to help something for which I thank him for very much and to help anyone else with the same prob. The correct argument to use to download Rosegarden once you have added he PlanetCCRMA repositories is "yum install rosegarden4"

electroconvulsi
16th June 2006, 07:36 PM
Anyway I have it installed and when I start it it comes up with the error message when starting

Rosegarden was unable to find a high-resolution timing source for MIDI performance.
This may mean you are using a Linux system with the kernel timer resolution set too low. Please contact your Linux distributor for more information.

To add to this there is no sound coming out. Im not sure how to get the sound happening on it but having used other similar apps in the past I know that i should be able to hear the metronome. There is no place to configure the sound card as far as is can tell either.

3006828
8th August 2006, 02:27 PM
make that 2 with no sound.. :P

must be a mixer setting that is incorect, but be buggered if i can find it. ?? :(

with a sblive here to sorry.

actually... no midi playback works with my sblive.... . . !!

to google i go.

3006828
8th August 2006, 02:40 PM
incase others like me mised this... this looks promising

http://www.linuxfocus.org/English/September2002/article259.shtml

3006828
8th August 2006, 03:33 PM
make that works like a charm..

yum install that sond font loader.. get yourself the sound font, add it to the modprobe.conf and away to midi greatness :D:D

3006828
8th August 2006, 03:51 PM
by the way the theme from Double Dragon is Awsome!