PDA

View Full Version : Python update 2.4.3 update missing dependency?



GrayFox
14th June 2006, 03:35 AM
High

I just tried to upgrade via yum extender to Python 2.4.3 and get a dependency error:

Missing Dependency: python = 2.4.2 is needed by package python-docs

rpm -qa | grep python yields:
libxslt-python-1.1.15-1.2.1
gnome-python2-desktop-2.14.0-1
gnome-python2-gconf-2.12.4-1
python-urlgrabber-2.9.8-2
mod_python-3.2.8-3
gnome-python2-gnomevfs-2.12.4-1
audit-libs-python-1.1.5-1
python-crypto-2.0.1-2.fc5
libselinux-python-1.30-1.fc5
python-docutils-0.4-2.fc5
gnome-python2-canvas-2.12.4-1
python-devel-2.4.2-3.2.1
python-ldap-2.0.6-5.2.1
postgresql-python-8.1.4-1.FC5.1
gnome-python2-gnomeprint-2.14.0-1
python-docs-2.4.2-1.1 <<<<<<<<<<<<<<<<<<<<<<<<<< here it is
libxml2-python-2.6.23-1.2
python-imaging-1.1.5-5.fc5
python-numeric-23.7-2.2.1
gnome-python2-gtksourceview-2.14.0-1
gnome-python2-extras-2.14.0-1
python-2.4.2-3.2.1
rpm-python-4.4.2-15.2
gnome-python2-2.12.4-1
gnome-python2-bonobo-2.12.4-1
python-sqlite-1.1.7-1.2
python-elementtree-1.2.6-4.2.1
gnome-python2-gtkhtml2-2.14.0-1
dbus-python-0.61-3.fc5.1

Any suggestions

GrayFox
14th June 2006, 03:51 AM
Well,

I deleted the rpm for python-docs-2.4.2-1.1 and was able to install the
other python updates offered tonight, regrettably I don't have any
on line documentation anymore.

The old doc package refuses to install ;(

Jerry