PDA

View Full Version : Setting of System default language



hosammy
9th June 2006, 06:34 AM
May I know how to reset to the System default language from English to Traditional Chinese?
I use English as the language used during the installation but don't how to change to Chinese

Regards...

hosammy
9th June 2006, 06:35 AM
May I add that my system is Fedora Core 5.

Lluisanunez
9th June 2006, 07:41 AM
At the login screen, press F10 and choose "Language" and then Chinese. You will be asked if the change is just for this session or to be set by default.

jbannon
9th June 2006, 08:43 AM
If you want to change it globally and you have the default tools installed then use system-config-language. If you don't have the tools installed then edit the file /etc/sysconfig/i18n and change the locale there. Don't forget to set your keyboard appropriately.

hosammy
12th June 2006, 06:18 AM
If you want to change it globally and you have the default tools installed then use system-config-language. If you don't have the tools installed then edit the file /etc/sysconfig/i18n and change the locale there. Don't forget to set your keyboard appropriately.

My /etc/sysconfig/i18n file is:
LANG="en_US.UTF-8"
SYSFONT="latarcyrheb-sun16"
SUPPORTED="en_US.UTF-8:en_US:en"

How do I change it to Traditional Chinese?

By the way, I have selected System-Administration-Language, but only "English (USA)" found inside. There is no such system-config-language in my FC5.
At the login screen, I pressed the F10 button, it allows me to change the Language but it does not change actually.

Please advise...

Wayne
12th June 2006, 06:38 AM
My /etc/sysconfig/i18n file is:
LANG="en_US.UTF-8"
SYSFONT="latarcyrheb-sun16"
SUPPORTED="en_US.UTF-8:en_US:en"

How do I change it to Traditional Chinese?

By the way, I have selected System-Administration-Language, but only "English (USA)" found inside. There is no such system-config-language in my FC5.
At the login screen, I pressed the F10 button, it allows me to change the Language but it does not change actually.

Please advise...

Did you actually install Chinese language support? If not, use the Add/Remove Software tool and in the left pane choose 'Languages' and in the right pane check 'Chinese Support' then follow the previous steps to make it default.

Wayne

Flyingbird
12th June 2006, 09:13 AM
add chinese language surpport ,then you can chosse chinese (PR) by type 'system-config-language' in terminal.hope this help.

下次记得安装要中文安装。:D

jbannon
12th June 2006, 09:28 AM
How many locales are installed? You can find this by running locale -a at the command prompt or by using ls /usr/share/zoneinfo. If you've done a default install you should see a longish list of locales. By default three Chinese locales are installed: Chinese PR (Peoples Republic of China), Taiwan and Singapore. If you're running KDE then you need to install the language support as suggested and then set it up through the regional options.

Omega Blue
12th June 2006, 09:52 AM
You probably don't need to if you have scim installed...