PDA

View Full Version : New Fedora User having trouble with Orinoco PC Card



JarHead
3rd April 2004, 10:09 AM
I've only been using Fedora for about 2 weeks now. I played with Mandrake 9.2 for a week before that but didn't find it to be as compatible with my hardware. With that said, I am pretty new to configuring a Linux system.

I am presently running Fedora Core 1 on an HP laptop (ZE4430US) and have gotten everything to work with the exception of my wireless devices. I gave up on trying to get my intergrated Broadcom 802.11G card working since I don't beleive there is any Linux support for it at this time. I do also have a Lucent Orinoco Silver PCMCIA card that I would like to get working. I have borrowed a DLink DWL-650plus wifi PCMCIA card as well for testing as necessary.

My problem thus far is this - Whenever I insert the Orinoco card I get freezing. If I boot with the card inserted I get a freeze in the boot process. I will locate the point at which this happens and report back. If I insert the card while the system is running then I will either get no response at all or I will get a single beep and the system will freeze. When the system gives no reaction to the card being inserted it will freeze if I remove the card and insert it again.
When I insert the Dlink card and boot the system does not freeze. I don't believe that the system is recognizing the card as 1) no lights come on on the card, 2) in the network section of the system settings group in the Gnome menu I don't seem to be able t configure the card at all. I have made no attempt to install drivers or otherwise configure the system for this card so that might be the problem with that card. If I remove and insert the Dlink card while the system is running I will get a single beep upon inserting it and the system will not freeze.
I've spent quite a bit of time Googling for a solution and have reinstalled Fedora twice after trying countless things and getting a cluttered up install after doing so. Is there any help or advise you could offer me in getting my Orinoco card working?

I don't know if it may be an issue with the PCMCIA setup or the card setup itself. Maybe the ACPI that seems to be working properly is causing an issue? I do know that both cards work flawlessly under Win XP.

JarHead
3rd April 2004, 10:26 AM
I just thought I'd mention that I am running the 2.4.22-1.2174.nptl kernel though I did try compiling 2.6.4 and couldn't get any further - went back to 2.4.22 when I couldn't get my touchpad to "tap-to-click"

SuperNu
5th April 2004, 04:06 PM
The only solutions I can offer you for the Broadcom card are to check out the NDISWrapper Project (http://ndiswrapper.sourceforge.net) or purchase the Linuxant DriverLoader (http://www.linuxant.com/driverloader/) software. Other sites to check out are http://www.linux-wlan.org/docs/wlan_adapters.html and http://www.prism54.org. They might help you out.

--SN

egurski
6th April 2004, 11:29 PM
I am currenttly running with a wireless connection. There were some tweaks I had to do to get it working.

The tweaks were to setup the wireless so that it knew which SSID to connect, what if any was the working key (security purposes) , what chanel to search and wether it was auto sensing.


Ed:)

ieatlint
7th April 2004, 01:48 AM
OK, not sure I can offer a solution but I can provide some info on troubleshooting.

I ran FC1 without problems using a dell minipci card (which goes through pcmcia-cs like a pcmcia card) using the orinoco_cs module. This dell card has the same exact chip as your orinoco.

I've since upgraded to FC2-test1, which worked fine and now FC2-test2, which has issues.
First thing to do is to boot the system without the card. Verify `cardmgr` is running by typing `service pcmcia status` or checking the process list for /sbin/cardmgr.

If it is not, there's your problem right there. Find out why..

If it is, then it should give you all the information you need.
Now kudzu doesn't need to run to install the modules and get the card working, as pcmcia-cs does it for you. You're best off in a console while trying to do this, so type `init 3` as root or CTRL+ALT+F1 and login as root.
Now type `tail -f /var/log/messages` You can ignore what goes up there at first, but that will give you info on why your computer is freezing and how far it gets. Insert the card and watch the screen.
Posting what you find here will be able to let someone really help.

If it doesn't freeze, type `cardctl status` which will report something like...
[root@lintlap root]# cardctl status
Socket 0:
3.3V 16-bit PC Card
function 0: [ready]
Socket 1:
no card
Socket 2:
no card
... then type `lsmod |grep orinoco` and it should list a few modules.

This should be enough info to really start troubleshooting it. My problem with FC2-test2 was that yenta_socket (a required module for the pcmcia controller) was not being loaded for unknown reasons, so I had to hack the rc.d file for pcmcia to get it working...

rmh3093
15th April 2004, 10:39 PM
my toshiba satelite 5105-S901 has an orinoco wireless card and I am having all sorts of problems, it only want to work with stock kernel the way it is but when I compile a kernel i can not get the orinoco to work, computer shows that it recieves a link in the gnome applet and it pickes up the SSID but cant ever get an IP

Yestrday
19th May 2004, 11:33 PM
"I had to hack the rc.d file for pcmcia to get it working..."

Could you please elaborate on what you did to rc.d?

ieatlint
20th May 2004, 01:35 AM
Well I've yet to upgrade to FC2, still on FC2-test3. When I did the ghetto hack on the init script I was running FC2-test2, the problem was solved as of test3.

What I did, however, was far from eloquint. I simply noticed that yenta_socket wasn't getting loaded into the kernel. Whyfore, I do not know. But manually typing "modprobe yenta_socket" would solve all my problems (until reboot, anyway).
So I simply added the line "modprobe yenta_socket" towards the top of the pcmcia init file (/etc/init.d/pcmcia) and my problem was solved.
Assuming you're on FC2, I wouldn't count on this being the same problem you're having. A review of my previous post here explaining how to debug it may help.
As yenta_socket wasn't loading, my system was completely unaware it had a pcmcia bus. If `lsmod` lists yenta_socket, then your problem is not as mine.
If it doesn't, and `modprobe yenta_socket` suddenly loads the bus and devices attached to it, then proceed with the modification to the init file (or do a propper job of tracking down why it isn't working).

kf6kmx
26th May 2004, 12:34 AM
Originally posted by ieatlint
My problem with FC2-test2 was that yenta_socket (a required module for the pcmcia controller) was not being loaded for unknown reasons, so I had to hack the rc.d file for pcmcia to get it working...

Same here..
I have an Orinoco Silver in my Panasonic CF27.. everything works, BUT yenta_socket doesnt load..
havent bothered to hack the rc.d yet, I just threw together a shell-script with the modprobe and service commands that I use when I'm in range of my wifi..

I'm not running the test version however, I have the Core2 release.

Is that happeneing on other modules, or just the yenta_socket?

Yestrday
26th May 2004, 07:35 AM
The problem seems to have spontaneously fixed itself. I found some posts telling me to modprobe yenta_socket, and in the time it took me to turn on my laptop and give it a try it was working.

No Dice

Ug
12th August 2004, 09:30 PM
The full solution is
su -
modprobe yenta-socket
service pcmcia restartIts a bug in FC2 which fails to load the module to allow the kernel to communicate with some PCMCIA subsystems via the yenta-socket module.

PeterBl
21st January 2005, 04:02 PM
I'm getting a similar freeze (FC3, Presario 2106, Orinoco silver), but the cause must be different: yenta_socket is loaded at pcmcia start time. When I insert the card, everything locks up and a power cycle is the only option. The /var/log/messages shows:

Jan 20 23:23:31 localhost cardmgr[5485]: initializing socket 0
Jan 20 23:23:31 localhost kernel: cs: memory probe 0xa0000000-0xa0ffffff: clean.Jan 20 23:23:31 localhost cardmgr[5485]: socket 0: Lucent Technologies WaveLAN/IEEE Adapter
Jan 20 23:23:31 localhost cardmgr[5485]: product info: "Lucent Technologies", "WaveLAN/IEEE", "Version 01.01", ""
Jan 20 23:23:31 localhost cardmgr[5485]: manfid: 0x0156, 0x0002 function: 6 (network)
Jan 20 23:23:31 localhost cardmgr[5485]: executing: 'modprobe hermes'
Jan 20 23:23:31 localhost cardmgr[5485]: executing: 'modprobe orinoco'
Jan 20 23:23:31 localhost cardmgr[5485]: executing: 'modprobe orinoco_cs'

and the next line is the restart. Any clues?