PDA

View Full Version : Yum deleted libpam



jsdewey
6th June 2006, 06:21 PM
Last night, I launched Yum, updated everything except the Gnome things, and then downloaded Audacity. Then, I browsed the web for awhile and I tried to launch Yum for something, and couldn't get it to work. i also couldn't get my Super User File Browser to work either. I shut down my computer, and went to bed. When I tried to get it to boot today, I couldn't get to the login screen. I tried removing rhgb quiet in grub, and I got as far as getting to the text login screen, but then it stopped there. I type in my username, and it doesn't work. Is there anyway of getting libpam back (I'm pretty sure it's libpam)? It wouldn't matter if it was temporary, just long enough for me to install K3B and burn a few files, then reinstall. Thanks.

d3viant
6th June 2006, 07:46 PM
Try booting to runlevel 3 - add a 3 to the end of your kernel parameters. This may get you as far as logging in as root and typing "yum install libpam"

OperatorOne
6th June 2006, 08:05 PM
I was about to post about the EXACT same issue. I booted to run level 3 and it will not let me logon. I type root at the prompt and hit enter and it clear the screen and redraws the logon prompt. HELP! I need my system for work, and I don't want to go back to Windows.

icydog
6th June 2006, 08:32 PM
runlevel 1?

linux4kix
6th June 2006, 08:39 PM
you need to boot into single user mode to bypass pam authentication. Put an S at the end of the kernel line in grub. You will then need to manually start your network interface.

shinjiman
10th June 2006, 11:28 AM
If you can run yum for updates, you can try to installing the package which including libpam:


yum install pam

after I've installed pam, the processes that require the libpam.so is fixed. :D

OperatorOne
13th June 2006, 07:54 PM
Has anyone resolved this by chance? I have reinstalled FC5 at this point, and updated evey package except PAM, as I don't want to hose my system again. Just curious if anyone else hosed their machine and was able to fix it by booting into single-user mode, just in case YUM hoses my pam again.

Cheers

u-noneinc-s
13th June 2006, 09:46 PM
There was another thread. I'll look it up and paste it at the end.
He booted into linux rescue (started network connection when prompted). Then chroot /mnt/sysimage to get root permission with write access, then yum install pam (and maybe pam-devel. He got his system back, but KDE or QT was a little broken. I don't know if he figured it all out or not.

Actually, it's one of your threads and I don't know if he got his other problems solved or not but he did recover Fedora.
http://www.fedoraforum.org/forum/showthread.php?t=112233&page=2&pp=15

And there's always linux4kix suggestion in post #5 above

OperatorOne
13th June 2006, 11:10 PM
Yeah if it gets hosed I think that's the route I'll try. Im going to experiment on a machine that's not my main notebook just to make sure. heh.