PDA

View Full Version : ext3 partition bad superblock



homunculus
6th June 2006, 01:33 AM
I reformatted an existing NTFS partition to ext3 with gparted. Everything seemed to go fine and gparted said the operation was completed.(no error messages) When I try to mount the partition though i receive this message:

mount: wrong fs type, bad option, bad superblock on /dev/sda5,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

i then ran dmesg | tail and got this:

dmesg | tail
ide: failed opcode was: unknown
end_request: I/O error, dev hda, sector 0
hda: command error: status=0x51 { DriveReady SeekComplete Error }
hda: command error: error=0x54 { AbortedCommand LastFailedSense=0x05 }
ide: failed opcode was: unknown
end_request: I/O error, dev hda, sector 0
printk: 3 messages suppressed.
NTFS-fs error (device sda5): read_ntfs_boot_sector(): Primary boot sector is invalid.
NTFS-fs error (device sda5): read_ntfs_boot_sector(): Mount option errors=recover not used. Aborting without trying to recover.
NTFS-fs error (device sda5): ntfs_fill_super(): Not an NTFS volume.

i'm a noobie and i haven't the slightest idea of what all that means but if anyone can help i'd really appreciate it. Also qtparted shows my root directory as fs unknown but the boot directory shows as ext3 and the new directory shows as ext3. Thanks.

homunculus
6th June 2006, 01:56 AM
And I got this:

[root@localhost ~]# e2fsck /dev/sda5
e2fsck 1.38 (30-Jun-2005)
/dev/sda5: clean, 11/9748480 files, 352028/19482820 blocks
[root@localhost ~]# e2fsck /dev/sda5 -f -v
e2fsck 1.38 (30-Jun-2005)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information

11 inodes used (0%)
1 non-contiguous inode (9.1%)
# of inodes with ind/dind/tind blocks: 0/0/0
352028 blocks used (1%)
0 bad blocks
1 large file

0 regular files
2 directories
0 character device files
0 block device files
0 fifos
0 links
0 symbolic links (0 fast symbolic links)
0 sockets
--------
2 files

I don't know if that means anything to any body.

jhetrick62
6th June 2006, 03:00 AM
Why don't you just format the entire partition using mkfs? Man mkfs for the options. It worked for me several months ago.

Jeff

homunculus
6th June 2006, 03:07 AM
I'm signed in as root run MKFS.EXT3 message is:
/dev/sda7 is apparently in use by the system; will not make a filesystem here!

and yes I have run umount: /dev/sda7 and am told :/dev/sda7: not mounted

all of the partitions on this machine are on one hard drive. in order: windows, linux boot, root, and then this partition. I don't know if that makes a difference.

jhetrick62
6th June 2006, 03:12 AM
First, I would not sign in as root. I would open and terminal and su - to get to root. Signed in that way is very dangerous and I would only do it if your other users are borked.

When you installed, you must have had a swap partition. Post back the output of "fdisk -l". This will identify all partitions and also post output of "mount"

Jeff

homunculus
6th June 2006, 03:17 AM
OK, here's the output of fdisk -l:

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda1 * 1 4880 39198568+ 7 HPFS/NTFS
/dev/sda2 4881 19457 117089752+ f W95 Ext'd (LBA)
/dev/sda5 4881 4893 104359+ 83 Linux
/dev/sda6 4894 9755 39053983+ 8e Linux LVM
/dev/sda7 9756 19457 77931283+ 83 Linux

and here's the output of mount:

/dev/mapper/VolGroup00-LogVol00 on / type ext3 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
automount(pid1997) on /net type autofs (rw,fd=4,pgrp=1997,minproto=2,maxproto=4)

and I wasn't actually signed on as root but rather as you indicated as superuser. Thank you.

Firewing1
6th June 2006, 03:22 AM
I'm not sure if it's /dev/sda5 or /dev/sda7 you want to delete & reformat, but this will do it:

su -
parted
select /dev/sda
print
mkfs
[ parition number - use the output of 'print' as a reference ]
ext3
quit
exit
Then:
reboot
Firewing1

jhetrick62
6th June 2006, 03:25 AM
It appears that you have an LVM structure and I don't use that myself, I use non-lvm partitions. I believe that the format commands are different for LVM. I just googled it, but it will take some reading. Someone here should be more familiar with this I'm hoping.

Sorry! Jeff

jhetrick62
6th June 2006, 03:26 AM
Firewing is far more expert than I, good to see him jump in.

homunculus
6th June 2006, 03:30 AM
All went according to plan up until the file system prompt. When I entered ext3 it responded that support is not implemented yet. Can I upgrade ext2 to ext3 after formatting the partition without losing data? Does it matter? This will only be for storing media files to be accessed by windows and fedora.

jhetrick62
6th June 2006, 03:56 AM
You would be better off fomatting fat32 honestly if you are going to use dual access. It's cleaner for windows and FC will easily mount mount a vfat partition. You can even format it in Windows as long as you do the RIGHT partition unless windows can't read LVM, but I think it can. Again, I don't run that stuff. but all of my dual-access partitions on my dual-boot machine are fat32 formatted.

Jeff

homunculus
6th June 2006, 07:01 PM
I tried that but I kept getting errors about the device not being umounted so I rebooted and couldn't get any farther than GRUB. Not knowing any of the parameters for the commands or filenames for that matter I decided to try the rescue cd. That was unable to mount any of the partitions so I decided to reformat and re-install. That's what I'm doing now. Thanks for help, though..