PDA

View Full Version : Sendmail takes around 1 billion years?



skabana
20th February 2004, 06:58 AM
My new Fedora boot takes about a billion years to initialize sendmail at boot-up. After it finally completes this, it takes about 500 million years to init sm-client. Can anyone tell me why this might occur? It seems similar to another thread (http://www.fedoraforum.org/forum/showthread.php?s=&threadid=36), but I wasn't sure if his symptoms matched mine or not. I am connected to the internet by a cable modem.
I don't use sendmail anyway- how do I simply remove it from boot-up?

Thanks.

mhelios
20th February 2004, 07:50 AM
to stop the running service:

/sbin/service sendmail stop
to stop it from starting on boot:

/sbin/chkconfig senmail off

MadRedHatter
20th February 2004, 08:06 AM
menu>system settings>server settings>Services
this is the gui for turning on and off services at startup

ofeeley
21st February 2004, 12:41 AM
My new Fedora boot takes about a billion years to initialize sendmail at boot-up. After it finally completes this, it takes about 500 million years to init sm-client. Can anyone tell me why this might occur?

Well mhelios has answered your question practically. The reason why is probably that your networking isn't set up properly.

Is it working yet?

skabana
23rd February 2004, 01:20 AM
Thanks everybody this has fixed my problem.

foolish
27th February 2004, 12:12 AM
Remember that there is a commandline version of redhat-config-services called ntsysv that is very handy sometimes.

mhelios
27th February 2004, 03:12 AM
Originally posted by foolish
Remember that there is a commandline version of redhat-config-services called ntsysv that is very handy sometimes.
Actually ntsysv is the TUI version - Text User Inferface. The command-line version is /sbin/chkconfig.

jalrnc
1st March 2004, 08:38 PM
You don't need to disable sendmail, sendmail should startup just fine. Try adding your hostname to be resolved to 127.0.0.1. You can do this by including the following line in your /etc/hosts file:

127.0.0.1 localhost.localdomain localhost your_host_name

halmsx
4th May 2004, 08:19 AM
geez, thank jalrnc, you solved my problem!

halmsx/