PDA

View Full Version : Mplayer and Xine Blue screen when attempting to play movie



ciphermonk
31st May 2006, 12:29 PM
Hello all,

I've looked at the various posts on mplayer and xine concerning getting them working under FC5. I've uninstalled and re-installed them several times. The codecs are under /usr/lib/win32 /usr/lib/codecs /usr/local/lib/win32 and /usr/local/lib/codecs. All are flagged with 755 permisions. Whenever I try to play an avi or a wmv, all I get is the audio and a blue screen. I've tried deleting all the codecs and I get the same thing which kind of leads me to believe that the players somehow aren't using them. I'm using the latest codec pack from mplayer's site. Any suggestions/comments?

Wolpiro
31st May 2006, 12:37 PM
Try to install Kaffeine from Livna repository.
For Livna repository:
# rpm -ihv http://rpm.livna.org/fedora/5/i386/livna-release-5-4.noarch.rpm
and write this for kaffeine:
# yum -y install kaffeine

Good Luck!

Wolpiro
31st May 2006, 12:39 PM
I forgot, the codecs must be under '/usr/lib/win32' folder.

ciphermonk
31st May 2006, 01:06 PM
Same thing. Blue screen. Now I did update to the aiglx xserver but then I reverted back to the standard xorg. Could that be playing a part in this?

Wolpiro
31st May 2006, 01:25 PM
Do you have an ATI Graphic Card?

Wolpiro
31st May 2006, 02:48 PM
Have you tried to upgrade all the possible on Xine, Mplayer or Kaffeine?

ciphermonk
31st May 2006, 03:18 PM
Nope.. it's an Intel 955 I beleive running the i810 driver. I've already updated xine, kaffeine and mplayer to the newest builds.. No change

ciphermonk
31st May 2006, 05:02 PM
Just reinstalled the whole box just to make sure that it wasn't something i had done in the previous install/config and I'm getting the same thing... wonder what the problem could be

chikiwiki
31st May 2006, 05:11 PM
Hello.

I think your codecs are in the wrong folder. They should be in /usr/lib/win32
NOT /usr/local/lib/win32

Also, make sure you have all of the codecs. You can download them from the mplayer site. I don't remember the exact web address, but just Google "mplayer" and it will come up as the first entry.

ciphermonk
31st May 2006, 05:35 PM
I added them there and there was no change in the result. It's like mplayer or xine aren't even using them

Wolpiro
31st May 2006, 05:50 PM
I really don't known, I'm sorry...

blue13130
31st May 2006, 10:11 PM
I had this problem with hearing audio and only seeing a bluescreen when using mplayer and xine and I fixed it by this FAQ section in the xine website. Basically try adding the line 'Option "XaaNoOffscreenPixmaps"' to the device section of your xorg.conf file (/etc/X11/xorg.conf) Here is the relevant section from my xorg.conf file:

Section "Device"
Identifier "Videocard0"
Driver "trident"
VendorName "Videocard vendor"
BoardName "Trident Cyberblade/i1"
Option "XaaNoOffscreenPixmaps"
EndSection
and here is the link to the FAQ on the xine website:
http://xinehq.de/index.php/faq#BLUESCREEN

I hope this works for you!

ciphermonk
1st June 2006, 01:58 PM
Did that and saw no change... I did find something interesting though. I'm running Fedora on my laptop where the native resolution of the screen is 1400x1050. When I'm at work, it's in a docking station attached to a real monitor where I run it at 1600x1200. At 1600x1200, all I get is a blue screen from xine, mplayer or any other video player for that matter. When I drop the res down to 1400x1050, it works fine. Now if I can only figure out why this is happening...

Wolpiro
1st June 2006, 02:11 PM
This is the mistery of life... ;)

MasterVong
25th June 2006, 11:39 PM
Hi,

I've had the same problem but have been unable to find a solution.

I installed Xine, totem-xine, mplayer and the mplayer plugin according to the Stanton Finley guide. Totem flashes a blue box before closing when I try to open it, when I try to view an embeded video stream with the mplayer plugin it shows a blue box with audio before it goes full screen leaving me with a black screen and I need to restart. The same happens with xine. I've tried reinstalling all of them, updating and have reinstalled fedora core 5 twice but with the same results.

I also tried the XaaNoOffscreenPixmaps suggestion off of the xine website with no results.

I have the Intel 82852/855GM Integrated Graphics card

I've completely out of ideas :( any suggestions?

MasterVong
26th June 2006, 05:06 AM
Also the mplayer plugin plays quicktime video fine, so I'm guessing that points to windows formats, but the visualization in xine when music plays has a blue line at the top and also becomes frozen with a blank screen if I make it full screen.