PDA

View Full Version : nvidia driver not working anymore



Stone Dragon
31st May 2006, 10:33 AM
Does anyone else have the problem, that X is not starting anymore after kernel and module upgrade? In xorg.conf, "nvidia" is automatically changed then to "nv" and X is working again...
This is on my amd64 box with the newest kernel. Unfortunately the old kernel does not work too, because the modules for it were uninstalled automatically.

I'm quite surprised about this behaviour, as xorg.xonf was changed automatically and now I can only work with the nv module.

Seve
1st June 2006, 02:34 AM
Hello:
You have to install the driver again for the new kernel.
You should be able to use the Nviida rpm from livna which is the safest and easiest.
See this guide here for instructons:http://www.stanton-finley.net/fedora_core_5_installation_notes.html#nVidia


Seve

Stone Dragon
2nd June 2006, 09:51 PM
I uninstalled and installed again kmod-nvidia. It still keeps crashing. If I use "nv" in xorg.conf, it works (but I'd like to use 3d anyway, so I need nvidia driver).
I'm at the end of my wit here. Maybe this Xorg.0.log output (the end of it after the crash) can help:




lots of uninteresting stuff here...
...
(II) XINPUT: Adding extended input device "NVIDIA Event Handler" (type: Other)
(II) Mouse0: ps2EnableDataReporting: succeeded

*** If unresolved symbols were reported above, they might not
*** be the reason for the server aborting.

Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x82) [0x478552]
1: /lib64/libc.so.6 [0x3b0dc2f550]
2: /usr/lib64/libGLcore.so.1(_nv000358gl+0x17) [0x3ec235dba7]

Fatal server error:
Caught signal 11. Server aborting

Stone Dragon
2nd June 2006, 10:28 PM
OK, it works now! What I was doing:
Removing all traces of old kernel-modules (nvidia.ko) then issue a depmod -a
Then I reinstalled the kmod-nvidia again and it worked... strange one...