PDA

View Full Version : I know it's not this difficult...



aristotlewilde
31st May 2006, 03:43 AM
Back in 1996, I learned the logic behind Windows 95 while coming down off some serious acid one night.

If I could lean Windows in this way, why the hell won't my sober adult brain wrap itself around Linux?

I've got a great FC5 install that LOOKS great thanks to fiddling with KDE and GNOME, but I am still at a loss when it comes to installing programs.

First off, I am having trouble with the updater getting errors when I run it,

More importantly though, I am havign trouble manaually installing software like gDesklets or SuperKaramba.

I know it isn't this hard. Can anyone give me tips? I'm looking for eitehr a simple to follow walkthrough so I can succeed once and move on from there, or a trick in thought processes to get me on track.

smfinley
31st May 2006, 03:49 AM
This (http://stanton-finley.net/fedora_core_5_installation_notes.html) may help.

bob
31st May 2006, 03:53 AM
You didn't mention which version you're using, so I'll be very general here. Use Yum to do your updates, either in command-line or by using Yumex ("yum install yumex"). There are two basic ways to set up yum to handle all your needs; either use the livna repository in addition to 'core', 'updates' and 'extras' as described here: (again, check your version up top) http://www.fedorafaq.org/ OR you can use the rpmforge group as described here: http://stanton-finley.net/ .

What's important here is that there are two different repository groups involved and constantly mixing the two can cause problems with version numbers. Here's the warning about that: http://stanton-finley.net/fedora_core_5_installation_notes.html#Warning

So, you can learn how to use yum from here: http://fedora.redhat.com/docs/yum/ or by typing 'man yum' in a terminal for more details.

aristotlewilde
31st May 2006, 04:18 AM
I am using Fedora Core 5. I tried using the Stanton Finley instructions, now when I try using software updater, I get this...

An unhandled exception has occurred.....

Component: Software Updater
Summary: TBd92eccef ConfigParser.py:462:_read:MissingSectionHeaderErro r: File contains no section headers.
file: ///etc/yum.repos.d/macromedia.repo, line: 1
'macromedia]\n'

Traceback (most recent call last):
File "/usr/sbin/pup", line 382, in ?
main()
File "/usr/sbin/pup", line 377, in main
pup = PackageUpdater()
File "/usr/sbin/pup", line 77, in __init__
GraphicalYumBase.__init__(self, False)
File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 122, in __init__
self.doConfigSetup()
File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 104, in doConfigSetup
self.getReposFromConfig()
File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 135, in getReposFromConfig
parser.read(files)
File "/usr/lib/python2.4/site-packages/yum/parser.py", line 225, in read
IncludingConfigParser.read(self,filename)
File "/usr/lib/python2.4/site-packages/yum/parser.py", line 126, in read
ConfigParser.read(self,filename)
File "/usr/lib64/python2.4/ConfigParser.py", line 267, in read
self._read(fp, filename)
File "/usr/lib64/python2.4/ConfigParser.py", line 462, in _read
raise MissingSectionHeaderError(fpname, lineno, line)
MissingSectionHeaderError: File contains no section headers.
file: ///etc/yum.repos.d/macromedia.repo, line: 1
'macromedia]\n'

Local variables in innermost frame:
cursect: None
fp: <open file '///etc/yum.repos.d/macromedia.repo', mode 'r' at 0x2adfcef43468>
e: None
fpname: ///etc/yum.repos.d/macromedia.repo
mo: None
optname: None
lineno: 1
line: macromedia]

self: <yum.parser.IncludedDirConfigParser instance at 0x2adfcef3ba28>

aristotlewilde
31st May 2006, 04:33 AM
I went in and deleted the new files in yum config and everything reverted back to where it was prior to trying to update. May have something to do with me running 64 bit?

markkuk
31st May 2006, 08:41 AM
Component: Software Updater
Summary: TBd92eccef ConfigParser.py:462:_read:MissingSectionHeaderErro r: File contains no section headers.
file: ///etc/yum.repos.d/macromedia.repo, line: 1
'macromedia]\n'

There's a '[' missing from the start of the macromedia.repo configuration file. Yum repo files contain sections that start with the section name in brackets (just like Windows .INI files). If the opening bracket is missing, yum can't parse the file.

I guess you simply made an error cutting and pasting the repo file from Stanton's page.