PDA

View Full Version : aMSN for FC5



thebigsam
30th May 2006, 07:40 PM
Does anyone know is I can get aMSN for FC5? the aMSN site has it for FC3 and 4 but i cant seem to get either of them to work?

Alternativly does anyone no of an msn type program that supports webcam?

freak
30th May 2006, 08:01 PM
you can always download the tarball (http://amsn.sourceforge.net/dlfile.php?file=amsn-0.95.tar.gz).

thebigsam
30th May 2006, 08:37 PM
ok, but i have no idea how to install from such. perhaps you could enlighten me?

thebigsam
30th May 2006, 11:16 PM
right i followed the read me file for the install. However when i type
./configure

i get the following output and error

[root@theta amsn-0.95]# ./configure
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for g++... no
checking for c++... no
checking for gpp... no
checking for aCC... no
checking for CC... no
checking for cxx... no
checking for cc++... no
checking for cl... no
checking for FCC... no
checking for KCC... no
checking for RCC... no
checking for xlC_r... no
checking for xlC... no
checking whether we are using the GNU C++ compiler... no
checking whether g++ accepts -g... no
checking how to run the C preprocessor... gcc -E
checking for prefix by checking for wish... /usr/bin/wish
checking tcl build dir... using tcl library in /usr/lib
checking tk build dir... using tk library in /usr/lib
checking for main in -lstdc++... no
configure: error: stdc++ library not found
[root@theta amsn-0.95]#

Know anything to help ?

Elbryan
6th June 2006, 05:36 PM
I think you have to install gcc for c++ compiler ..

CheezyArmpit
6th June 2006, 08:37 PM
i managed to compile it before but it needed the TLS library, which I downloaded (tried both versions, old 1.4 and new 1.5)

i pointed aMSN to the right path (/opt/tls1.4 etc.) as it asks, and yet it still refused to beleive that the tls library was there, so i gave up

also the auto-downloading install thing for tls doesn't work, you have to get it from the sourceforge page.

thebigsam
6th June 2006, 10:03 PM
I made sure i had the Development packages install ( its in add remove packages ) and it all worked fine :D

icepic
23rd June 2006, 02:10 AM
I installed aMSN for FC4 and I was getting the TLS error as well, to fix the problem i typed "yum install amsn" in the console and it worked after that!