PDA

View Full Version : Slow Boot Help.



The_Void
30th May 2006, 01:53 PM
Wasn't really sure where to post this topic because I know it's because of my ethernet being enabled, but it has to do with my boot time. Anyways first let me describe the prob. When ethernet is enabled machine boot slow. When ethernet disable machine boot fast. Yep thats it. It would hang up on the start up items sendmail and sm-client. So I removed the sendmail app. It then would hang on postfix. So I finally disabled my card and it's boot nice and fast. Enable it and it's slow again. I mean even loading apps when i finally do get into my desktop are slow to run. The thing is, is I've had this problem before. I did a reinstall and same problem. I did a reinstall and same problem. I did a reinstall and problem fixed. No more slow boot up no matter what service or hardware was enabled. Did a reinstall and back to the prob. i would hate to think that there is something not being loaded properly on the install and it's hit or miss. It either works perfect after install or keep installing till you get it. And no i didn't change any options at all when installing. All installs were done exactly the same with same options and apps. I'm just trying to see if anyone has a suggestion before i try reinstalling again. Thanks.

cheerio158
4th June 2006, 02:33 PM
I had the (same*?) problem and solved it by changing my machine name from: mymachine to mymachine.localddomain. (mymachine is not the real name).

To do this:
(1) Edit /etc/sysconfig/network
(2) Edit /etc/sysconfig/hosts and change the requiste localhost line to look like this:
127.0.0.1 localhost localhost.localdomain

* sendmail and sm-client would hang for a *LONG* time for me too

=== // ===

Meanwhile, I'm struggling with a similar problem where my rt2500 wireless driver stopped working and the machine boots very slowly when the /etc/sysconfig/networking/devices file is set to ONBOOT=Y. (The above solution didn't help.)

Gnome startup is particularly slow.

I don't see any errors in /var/log/messages and when I set ONBOOT=N, everything works fine - except that I don't have networking.

I'm running FC5 2.6.16-1.2122_FC5 and the network adapter is a USB DWL-GI22/RE.

Anybody have any ideas?

cheerio158
5th June 2006, 12:05 PM
Followup:

I solved my slow-boot and slow performance issue by adding (again) the following line in my /etc/sysconfig/networking/devices/ifcfg-rausb0 file:
KEY=A4BEB3B8EC

I examined the the networking startup scripts and it looked like the keys-XXXXX is ignored and it looks to ifcfg-XXXXX instead for the WEP encryption.

BTW - has anyone else noticed how the lame system-config-network tends to take 100% CPU and hangs once you have more than one devices configured?

Here is the wireless driver that I am using: rt2x00 (http://rt2x00.serialmonkey.com/wiki/index.php/Main_Page)