PDA

View Full Version : Gcc



complete-noobie
26th May 2006, 09:36 PM
I'm trying to install programs in general and most of them are telling me that I have an incompatible version of GCC. So I tried installing the newest one for FC5 but it told me that it was already installed. What do I do to get these things working? Kaleb

cypher543
26th May 2006, 09:40 PM
Maybe they need an older version, perhaps?

I dunno... I'm not a very good C programmer. :P

markkuk
26th May 2006, 10:36 PM
In general, you shouldn't install programs from source. It's the last resort if you can't find a suitable RPM package from anywhere.

RahulSundaram
28th May 2006, 02:19 PM
I'm trying to install programs in general and most of them are telling me that I have an incompatible version of GCC. So I tried installing the newest one for FC5 but it told me that it was already installed. What do I do to get these things working? Kaleb

You can try installing the packages compat-gcc* which install a older version of the GCC compiler. If you are new to Linux, its better to just use equivalent RPM packages installed using yum.