PDA

View Full Version : Root password denied, only in terminal...



p4r4n01d
26th May 2006, 01:21 AM
Hi peeps,
First off i am a n00b to Linux and am running FC5. I mounted NTFS partitions successfully, but must have updated the core (or something) and lost ntfs support, so i reverted back to my previous FC5 version. I got ntfs back.

Anyway, i were playing around with chown command in order to add a file to /etc/yum.repos.d and got an error i couldnt create a file in that dir as i weren't owner. Anyway, it turned out i weren't owner on most things so thought i'd try chown command to add this file and were successful :-) . ... ... then i got cocky and did something like:

chown -R 'my username' /

in order to get ownership off all my linux files. It started trying to change owndership of the ntfs partitions too though, which are RO so is pointless so i thought 'sod this' and halfway through did a ctrl-c to stop in its tracks. Ever since then i cannot login as root, but ONLY in the terminal. I can get root to change admin stuff etc. So i know my password is right.

Sorry 'bout the detail...any ideas??

Thanks in advance

Fibonacci
26th May 2006, 01:31 AM
chown -R 'my username' /

That was a Bad Thing to do.


Sorry 'bout the detail...any ideas??

Yes, chown -R root /root. Or, for that matter, chown to root anything that isn't on your home dir.

p4r4n01d
26th May 2006, 01:52 AM
thanks for the quick reply but just keep getting 'operation not permitted'. I'll leave this thread another day or so then just re-install FC5, there's nothing i'm gonna lose apart from a bit of configuration. Still, your suggestions are welcome, and i'm sure i'll learn by my mistakes. :-)

u-noneinc-s
26th May 2006, 02:05 AM
Try in a terminl
su - hit enter type root password hit enter, then try Fibonacci's suggestion again.

Now you know, there is a reason things are owned by root, so yes you have already learned a valuable lesson. :eek:
If this works, your /home/yourusername may now be owned by root, so you can cd /home and issue the same
command, but replace root/root with yourusername/yourusername. Now type exit and you are out of root's env.

If it doesn't work, there may be other suggestions. If you decide to reinstall, next time remember for root commands
use su - or sudo and leave permissions alone (with very few exceptions). ;)

a thing
26th May 2006, 06:21 AM
That was a Bad Thing to do.

To claify that: by letting a regular user have access to everything, you pretty much make that user another root. So using that user is now as insecure as using root.

Revenant
23rd September 2006, 06:20 AM
I am expert windows user and have a degree in computer science but have managed to avoid serious contact with Linux mostly the whole time with the exception of my UNIX courses...which I quickly forgot.

I have agreed to test out a Linux operating system for a local writers group which I am a part of and here is my dilemma. I got the group talked into buying the same laptops a few months back, an eMachines 4620. Yeah, yeah, laugh it up...but all I have had so far with it is a good experience...under windows.

I have thus far tried installing Slackware, Ubuntu, Kubuntu, and Mandrava and Red was the first one where my Ethernet adapter worked on install so I'm going with it so far.

So here is the deal now. I...uh...don't remember setting a root password in the installation. Is there anyway to retrieve it or change it or hack it cause root wont log in under terminal.

Second problem is with my broadcom 4318 wireless adapter. I need a fix that is going to get that online without a lot of linux knowledge (yeah led by the hand) because I have to get it working on at least 8 other laptops just like mine. I have searched this topic on the thread and see that there is stuff out there but what I really need something that says "Your and idiot, here you go". I'll play around and learn Linux later but right now I need the hardware to just work so I can go back and say "See, this is free and it works great!"

Thanks,
Keith