PDA

View Full Version : Error updating latest livna Nvidia drivers



sdwr98
25th May 2006, 03:21 PM
Hello,

I just came back from a week on vacation and found a bunch of updates. I ran


sudo yum update

and it failed trying to update the nvidia drivers:



--> Running transaction check
--> Processing Dependency: nvidia-kmod-common = 1.0.8756 for package: kmod-nvidia-smp
--> Processing Dependency: nvidia-kmod-common = 1.0.8756 for package: kmod-nvidia-smp
--> Processing Dependency: nvidia-kmod-common = 1.0.8756 for package: kmod-nvidia-smp
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
--> Processing Dependency: nvidia-kmod-common = 1.0.8756 for package: kmod-nvidia-smp
--> Processing Dependency: nvidia-kmod-common = 1.0.8756 for package: kmod-nvidia-smp
--> Processing Dependency: nvidia-kmod-common = 1.0.8756 for package: kmod-nvidia-smp
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
Error: Unable to satisfy dependencies
Error: Package kmod-nvidia-smp needs nvidia-kmod-common = 1.0.8756, this is not available.
Error: Package kmod-nvidia-smp needs nvidia-kmod-common = 1.0.8756, this is not available.
Error: Package kmod-nvidia-smp needs nvidia-kmod-common = 1.0.8756, this is not available.


This is what uname -r gives me:



2.6.16-1.2111_FC5smp


Any thoughts?

Thanks,

Scott

stanmc
25th May 2006, 03:35 PM
Ditto!!

I'm using Yumex and I have Kernel 2122 and nvidia 8756. Using yumex to update the livna nvidia drivers to 8762 I get several dependencies references and an error message that pops up saying
-------------------------------
Package kmod-nvidia-smp needs nvidia-kmod-common=1.0.8756, this is not available.
-------------------------------

I'm trying to update to 8762. I even booted into the non-smp kernel and tried updating, but it wanted to update the smp version. So where is nvidia-kmod-common(out of date 8756?) and how do I install it? Or should I just wait ;)

I couldn't wait. I removed the kmod-nvidia(8756) for all three kernels on my machine 2107/2111/2122 along with the xorg-x11-drv-nvidia-1.0.8756-3.lvn5. I then rebooted and used yumex to install the kmod-nvidia(8762) and xorg-x11-drv-nvidia-1.0.8762-2.lvn5. Everything is fine, I just got killed in Quake4-demo. That is the ultimate proof you have the nvidia drivers running correctly. :D

sdwr98
25th May 2006, 07:39 PM
Looks like we're not the only ones...

http://bugzilla.livna.org/show_bug.cgi?id=1004

Seve
25th May 2006, 10:33 PM
Hello:
use # yum -y --enablerepo livna update xorg-x11-drv-nvidia
and you will have a problem free update to version 1.0.8762
Seve

stanmc
26th May 2006, 08:30 AM
Hello:
use # yum -y --enablerepo livna update xorg-x11-drv-nvidia
and you will have a problem free update to version 1.0.8762
Seve
Thanks Seve. I used livna enabled in Yumex and that is what caused the problem originally. The xorg-x11-drv-nvidia-1.0.8762-2.lvn5 file seemd to have a flaw. Shortly after I removed everything and reinstalled they brought out xorg-x11-drv-nvidia-1.0.8762-3.lvn5 whicih didn't have the conflict. I did a yumex update shortly after I got everything working with vesion 2 and it updated to version 3. Wish I would've known of the conflict before I started the update. I could've waited ;) It made for an interesting day.