PDA

View Full Version : Problem with internal modem



CyberTop
25th May 2006, 11:57 AM
HI,
i'm a novel user of linux
I use linux Fedora Core 5 with the kernal 2111.
Fedora not rilevated the internal modem, it is a AC97 SOFTV92 Data fax modem with SMARTCP.
How I make to resolve this problem?
for me is very very important

tashirosgt
25th May 2006, 02:53 PM
You mean the modem is not recognized by FC5. Is this modem built-in to the motherboard or is it a PCI card?

CyberTop
25th May 2006, 05:00 PM
You mean the modem is not recognized by FC5. Is this modem built-in to the motherboard or is it a PCI card?

this modem built-in to the motherboard

CyberTop
25th May 2006, 05:02 PM
This is the result of scanmodem:


DO use the following line as the email Subject Line, to alert cogent experts:
scanModem, Fedora Core release 5 (Bordeaux)
Kernel kernel 2.6.16-1.2111_FC5
Occassionally reponses are blocked by an Internet Provider mail filters.
So do in a day also check the Archived responses at DISCUSS@linmodems.org
Code updated on: 2006_April_11
------------ -------------- System information ------------------------
Fedora Core release 5 (Bordeaux)
Kernel
on System with processor: i686
currently under kernel: 2.6.16-1.2111_FC5
Be sure to read the Ethernet section of Modem/YourSystem.txt
DEVPPP=crw------- 1 root root 108, 0 25 mag 13:18 /dev/ppp
A /dev/modem symbolic link is not present
USB modem not detected.

Checking for audio card
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] Sound Controller (rev a0)
Reading /proc/asound/pcm
00-01: Intel ICH - MIC ADC : SiS SI7012 - MIC ADC : capture 1
00-00: Intel ICH : SiS SI7012 : playback 1 : capture 1
01-00: Intel ICH - Modem : SiS SI7013 Modem - Modem : playback 1 : capture 1

The modem is supported by an ALSA modem driver plus slmodemd,
OR alternatively (not both) by
an hsfmodem package from http://www.linuxant.com/drivers. Further diagnostics
below may resolve between the two.
ALSA modem drivers are included in 2.6.n kernel packages and currently include:
snd-hda-intel, a joint audio + modem driver
snd-ali5451 , " "
intel8x0m , depending on intel8x0 audio driver
snd_via82xx_modem, " snd_via82xx "
snd-atiixp-modem , " snd-atiixp "
Driver loading itself does NOT resolve between ALSA and hsfmodem alternatives.

The potentially supporting drivers now loaded on this System are:
0 snd_intel8x0
1 snd_intel8x0m


The kernel was assembled with compiler: 4.1.0
with current System compiler GCC=4.1.0
-------------
Found make utility.
-------------
Checking for kernel-headers needed for compiling.
Kernel-headers supporting compiling are resident:

Modem candidates are at PCI_buses: 00:02.6

Providing detail for device at 00:02.6
with vendor-ID:device-ID
----:----
Class 0703: 1039:7013 Modem: Silicon Integrated Systems [SiS] AC'97 Modem Controller (rev a0) (prog-if 00 [Generic])
SubSystem 1043:1816 ASUSTeK Computer Inc. Unknown device 1816
Flags: bus master, medium devsel, latency 32, IRQ 17
Checking for IRQ 17 sharing with modem.
O-APIC-level SiS SI7012, SiS SI7013 Modem


-----PCI_IDs------- --CompilerVer-
Feature List: Primary Subsystem Distr KernelVer kernel default CPU
./scanModem test 1039:7013 1043:1816 redhat 2.6.16-1.2111_FC5 4.1.0 4.1.0 i686
The following two Root commands should set up the modem.
modprobe snd-intel8x0m
slmodemd --alsa -c YOUR_COUNTRY modem:1
Get the SLMODEMD.gcc4.tar.gz from http://linmodems.technion.ac.il/packages/smartlink/

The controller: 1039:7013 SIS 630
is capable of supporting soft modem chips from AT LEAST manufacturers:
Pctel
AgereSystems
Conexant
Intel
Smartlink
The Subsystem PCI id does not itself identify the modem Codec.
Checking for autoloaded ALSA modem drivers

Driver snd-intel8x0m may enable codec acquisition
=== Begin mc97 codec query ===
the MC97 file is: /proc/asound/card1/codec97#0/mc97#1-1
--------
1-1/0: Conexant id 22

Extended modem ID: codec=1 LIN1
Modem status : PRA(GPIO) PRB(res) PRC(ADC1) PRD(DAC1) PRE(ADC2) PRF(DAC2) PRG(HADC) PRH(HDAC)
Line1 rate : 8000Hz
--------
from /proc/asound/card1/codec97#0/mc97#1-1+regs
0:7c = 4358
0:7e = 5422
Translating into: CXT22
a ConeXanT codec
Use a hsfmodem package from http://www.linuxant.com/drivers
=== End mc97 codec query ===

Beginning check for older ac97_codec modems.
An older ac97_modem codec was not detected.

The modem has a Conexant codec: CXT22
and there support for the modem controller: 1039:7013 SIS 630
Some Linux Distributions include the hsfmodem driver.
Search your packages information for "hsfmodem" and "Conexant".
If not found there, download a hsfmodem package from http://www.linuxant.com/drivers .

Test the effectiveness of the hsfmodem package from http://www.linuxant.com/drivers/hsf/index.php.
== Checking PCI IDs through modem chip suppliers ==

Vendors 127a and 14f1 are Conexant, inheritor of Rockwell modem technology. There are also Conexant chipsets
in some modems from vendors 158b - Allied Data Tech., 1024 - Zenith ,141a - Apache Micro and 148d Digicom Systems.
With respect to software support there are two main types, hcfpcimodem* and hsfmodem* .
Download driver code packages from http://www.Linuxant.com/drivers
At http://linmodems.technion.ac.il/resources.html#conexant , there are scripts aiding installation:
For HSF modems.
For HCF modems.
There is additional Conexant information written to Modem/Conexant.txt

== Checking PCI IDs through modem chip suppliers ==
Vendor 1039 is SiS, Silicon Integrated System, producing soft modem controllers and subsystems.

======= PCI_ID checking completed ======
Update=2006_April_11

Analyzing information for PCMCIA device at PCI Bus 00:0a.0
00:0a.0 CardBus bridge: Ricoh Co Ltd RL5c475 (rev b8)
Subsystem: ASUSTeK Computer Inc. Unknown device 1814
Flags: bus master, medium devsel, latency 168, IRQ 16
GREPping for an inserted PCMCIA modem with filter: ommunication
If a PCMCIA modem is currently inserted and the sockets activated by
/etc/init.d/pcmcia start
then the PCMCIA bridge is NOT transparent.

If the modem is known to have a Lucent digital signal processing chipset,
then PCMCIA.tar.gz variant assembled by Joern Wustenfeld is necessary,
rather than the standard ltmodem-8.31b1.tar.gz at http://ltmodem.heby.de/
Checking for modem symbolic link support lines within /etc/udev/ files


The kernel-2.6.16-1.2111_FC5 was compiled with CONFIG_REGPARM, providing more compact and faster code.


dequate match of gcc versions of the compiler and kernel.
A /dev/modem symbolic link is not set.

The following information blocks just query some ppp support items.

================================================== ==
grep -rs ppp /etc/modprobe.*
-------------------------------------
/etc/modprobe.d/modprobe.conf.dist:alias tty-ldisc-3 ppp_async
/etc/modprobe.d/modprobe.conf.dist:alias tty-ldisc-14 ppp_synctty
/etc/modprobe.d/modprobe.conf.dist:alias ppp-compress-18 ppp_mppe
/etc/modprobe.d/modprobe.conf.dist:install ppp-compress-21 /bin/true
/etc/modprobe.d/modprobe.conf.dist:alias ppp-compress-24 ppp_deflate
/etc/modprobe.d/modprobe.conf.dist:alias ppp-compress-26 ppp_deflate
-------------------------------------
PPP support module bsd_comp.ko not found!
Resident PPP support modules are properly uncompressed .
----active COMM services are ------------
eth0 Link encap:Ethernet HWaddr 00:11:2F:AC:D8:25
inet6 addr: fe80::211:2fff:feac:d825/64 Scope:Link
This COMM mode should be closed before using the modem, or DNS services may fail.
Be sure to read the section about ppp related modules and aliases in Modem/YourSystem.txt
---- dmesg queries -------
ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 5 6 7 10 11 14 15) *0, disabled.
apm: BIOS not found.
audit: initializing netlink socket (disabled)
ibm_acpi: ec object not found
acpi-cpufreq: CPU0 - ACPI performance management activated.

pppd version 2.4.2 may not be fully compatible with 2.6.8 kernel releases.
If an initial CONNECT is achieved without PPP being subsequently established,
drop back to a 2.4.1 version. This has worked for PCTEL AMR modem users,
supported by the http://www.smlink.com slmodem software.
Check pppd version with:
pppd --version
See http://linmodems.technion.ac.il/archive-fourth/msg03167.html


For kernel-version 2.4.20-8 , a failure in automatic loading of PPP related modules
has been reported. It was necessary to manually load with:
/sbin/modprobe /lib/modules/2.4.20-8/kernel/drivers/net ppp_generic
/sbin/modprobe /lib/modules/2.4.20-8/kernel/drivers/net ppp_deflate
/sbin/modprobe /lib/modules/2.4.20-8/kernel/drivers/net ppp_synctty
/sbin/modprobe /lib/modules/2.4.20-8/kernel/drivers/net ppp_async
or dialout efforts failed.

The Internet Configuration Wizard writes a configuration file:
/etc/ wvdial.conf
containing a line default line
Stupid Mode = yes
Better dialup performance may be achieved by commenting out this line as:
# Stupid Mode = yes
If the Smartlink slmodemd is used for port creation, an added line is necessary
Carrier Check = no
Also non-USA Users may need to add to the [Modem0] block:
Init2 = AT+GCI=hexadecimal_country_code
but test without it first.

redhat is not yet providing pre-compiled drivers for WinModems

now??????????

tashirosgt
26th May 2006, 08:29 AM
Wow! The scanmodem program produces a very elaborate output! Perhaps someone will interpret it for us. My own simplistic approach would be to try the first thing that it suggested:
> The following two Root commands should set up the modem.
> modprobe snd-intel8x0m
> slmodemd --alsa -c YOUR_COUNTRY modem:1
> Get the SLMODEMD.gcc4.tar.gz from http://linmodems.technion.ac.il/packages/smartlink/

Have your tried those steps?