PDA

View Full Version : 3d acceleration with ati



hellfried
25th May 2006, 12:07 AM
following the instructions in http://stanton-finley.net/fedora_core_5_installation_notes.html#nVidia i get an error message when i do 'fglrxinfo' and am not getting fps of >1000 when i do glxgears.

[root@localhost ~]# fglrxinfo
Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.4.2 )

any help would be appreciated.
i have an ati radeon x550 card.

fhubers
25th May 2006, 12:10 AM
DRI is not loading for some reason - can you add your /var/log/Xorg.0.log? Might give us an idea why it isn't loading.

Plexxxy
25th May 2006, 01:07 AM
Make sure the 'Driver' line in your /etc/X11/xorg.conf (under the device section) is set to "fglrx" and not the default "ati".

hellfried
25th May 2006, 10:57 AM
if i change the line from 'vesa' to 'fglrx' my screen goes dead when i do 'startx' and the 'no signal' sign pops up on my monitor.

fhubers
25th May 2006, 11:16 AM
Can you post your xorg.conf?

hellfried
25th May 2006, 11:29 PM
Can you post your xorg.conf?


# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, a font server independent of the X server is
# used to render fonts.
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"

### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "VE710b"
DisplaySize 340 270
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 30.0 - 80.0
VertRefresh 50.0 - 75.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "vesa"
VendorName "Videocard vendor"
BoardName "ATI Technologies Inc RV370 [ATI Sapphire X550 Silent]"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1280x1024"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

Iron_Mike
26th May 2006, 02:41 AM
You need to check if the X550 card is supported by the drivers. If it is, you need to enable the driver

aticonfig-system-display --enable

and then

aticonfig --initial

reboot and check with fglrxinfo

hellfried
26th May 2006, 03:28 PM
You need to check if the X550 card is supported by the drivers. If it is, you need to enable the driver

aticonfig-system-display --enable

and then

aticonfig --initial

reboot and check with fglrxinfo

[root@localhost ~]# aticonfig-system-display --enable
bash: aticonfig-system-display: command not found

this is what i get

friez
26th May 2006, 04:43 PM
the command should be
ati-fglrx-system-display --enable

hellfried
26th May 2006, 05:01 PM
the command should be
ati-fglrx-system-display --enable

[root@localhost ~]# ati-fglrx-system-display --enable
bash: ati-fglrx-system-display: command not found

sheridon
26th May 2006, 05:11 PM
Have you done the "yum install kmod-flgrx" (without quotes ofcourse)

This is the guide that I used to get my ATI 9600 pro to work....

http://forums.fedoraforum.org/forum/showthread.php?t=79243&highlight=ati+driver

hellfried
27th May 2006, 06:34 AM
Have you done the "yum install kmod-flgrx" (without quotes ofcourse)

This is the guide that I used to get my ATI 9600 pro to work....

http://forums.fedoraforum.org/forum/showthread.php?t=79243&highlight=ati+driver

i decided to start off with a clean slate and did a fresh install of fedora. after configuring and updating yum as outlined in 'stanton-finley.net' page i proceeded to install the ati driver. i am now stuck at the section #8. this is what i get :

[root@localhost ~]# rpm -qa | grep fglrx
kmod-fglrx-smp-8.25.18-1.2.6.16_1.2122_FC5
xorg-x11-drv-fglrx-8.25.18-1.lvn5

obviously it does not match but when i go to http://rpm.livna.org/fedora/4/ i am not able to find an appropiate ati driver. in fact this is all wrong. am i supposed to be looking for a matching xorg-x11-driver or the ati driver? i am all confused and am still staring at the butt-ugly 800 x 600 screen resoultion! help me!

fhubers
30th May 2006, 11:34 PM
Are you running FC5 or FC4? If you are running FC5 you need to look in http://rpm.livna.org/fedora/5/ if you are running FC4 then the FC5 kmod you loaded is wrong.

sheridon
31st May 2006, 01:53 AM
i decided to start off with a clean slate and did a fresh install of fedora. after configuring and updating yum as outlined in 'stanton-finley.net' page i proceeded to install the ati driver. i am now stuck at the section #8. this is what i get :

[root@localhost ~]# rpm -qa | grep fglrx
kmod-fglrx-smp-8.25.18-1.2.6.16_1.2122_FC5
xorg-x11-drv-fglrx-8.25.18-1.lvn5

obviously it does not match but when i go to http://rpm.livna.org/fedora/4/ i am not able to find an appropiate ati driver. in fact this is all wrong. am i supposed to be looking for a matching xorg-x11-driver or the ati driver? i am all confused and am still staring at the butt-ugly 800 x 600 screen resoultion! help me!

Those do actually match, 8.25.18-1 is the numbers you are matching.... I have the same display when I do that command..... So you can continue following the guide..

:D

hellfried
31st May 2006, 06:14 AM
Those do actually match, 8.25.18-1 is the numbers you are matching.... I have the same display when I do that command..... So you can continue following the guide..

:D

thanks for the heads up. actually i have installed suse 10.1(64bit) over the fc5 partition. maybe some other time. thank you again! :)