PDA

View Full Version : firefox swf no sound



Marcolux
24th May 2006, 10:06 PM
Hello
i installed the macromedia FLash plugin in my firefox 32bits
when a launch a swf file, it seem to work fine the only problem is there is no sound
Could somebody help me?
Thanks
-i'm trying to watch a linux tutorial i found in the network, LinuxCBT Cd tutirial;

PilotJLR
25th May 2006, 12:02 AM
I had the problem for a while - try going to System | Preferences | Volume Control. Then click the "Capture" tab and turn each volume all the way up and make sure it's not muted (no red X's).
Makes no sense why Capture settings affect this, I know... but this is what fixed mine.

tangotiger
25th May 2006, 02:55 AM
I don't know whether this could be useful to you but the Flash plugin wouldn't ouput sound (though it'd seem to run smoothly) if some other application is using sound (like amarok and apps like that). Usually, I'd close all applications that could interfere with sound before watching anything on youtube. I think it's an OSS thing. Correct me if im wrong. :D

b00st
25th May 2006, 05:59 AM
I don't know whether this could be useful to you but the Flash plugin wouldn't ouput sound (though it'd seem to run smoothly) if some other application is using sound (like amarok and apps like that). Usually, I'd close all applications that could interfere with sound before watching anything on youtube. I think it's an OSS thing. Correct me if im wrong. :D

nope, its any sound in general.

Thetargos
25th May 2006, 06:24 AM
I don't know whether this could be useful to you but the Flash plugin wouldn't ouput sound (though it'd seem to run smoothly) if some other application is using sound (like amarok and apps like that). Usually, I'd close all applications that could interfere with sound before watching anything on youtube. I think it's an OSS thing. Correct me if im wrong. :D
Well, you are partially correct there: if another sound-producing application is running before flash uses the sound card, it will not be able to use the sound card. This happens in particular with non-hardware mixing capable cards, so only one app can use the sound card at any time when using OSS applications (flash, skype, TeamSpeak, binary distribution of Quake 3 and ET, etc).

Marcolux
25th May 2006, 08:05 AM
i turned off all the programs that use the sound card, but i have always the same problem
The flash video appears but without sound and, the flash video is playing fast.
When i installed the Flash plugin in my FC5 (KDE), the Amarok was turned on.
MAybe i have to reinstall the plugin.
Where can i find 'System | Preferences | Volume Control.'?
Thanks

tangotiger
25th May 2006, 09:00 AM
KDE? You might want to check whether you have arts enabled... it could be the one locking down your soundcard. (I usually turn it off because I can't think of another application that actually uses it)

'System | Preferences | Volume Control.' is a gnome menu. If you don't have that installed, you should try "alsamixer" in the Konsole. It's almost the same except you use tabs and arrowkeys to control.

Marcolux
25th May 2006, 01:08 PM
where can i chech that??
Where do i find alsamixer?

Thanks

Marcolux
25th May 2006, 01:08 PM
i only found Kmix

tangotiger
25th May 2006, 01:23 PM
@ arts -> Open Control Centre (under All Applications in the start bar), look under "Sound & Multimedia" -> Sound System, Under "General" Tab, if "Enable the sound system" is checked, means you got arts enabled. Uncheck it.

@ alsamixer -> Under System-> Open Terminal. In the prompt, type "alsamixer". You should see a funky but slightly antique GUI. Move to [Capture] by pressing TAB and check you got everything right on that tab. Press ESC when you're done.

Marcolux
25th May 2006, 01:44 PM
the arts is disabled and i i have opened the alsamixer, but i the flash video is alwways without sound

Dumbledore
25th May 2006, 05:20 PM
I had that problem for a while, and I never figured out exactly what was causing the problem. But I like your diagnosis of Amarok being on when you installed Flash, so I would try uninstalling it (if you installed it with an rpm, you can use the rpm -e command to uninstall it) and reinstalling it. That's just a guess, since after I accidentally wiped my hard drive, I reinstalled my OS and Flash worked fine after that.

Thetargos
25th May 2006, 06:11 PM
Installing and re-installing the plugin doesn't make any sense! Here's an idea of what you could try to do: Start a failsafe session (there will only be a terminal window), first off, start alsamixer and press F3, if there is no change, you were already in the playback tab. Make sure that Master, PCM and Wave have volume and are enabled (i.e they don't have a blue 'MM' at the bottom, you enable/disable [mute/unmute] with the M key). Depending on your hardware make sure the AC97 bar has volume and is enabled. Close alsamixer with the [ESC] key. Open firefox (or Konqueror) and try to play some flash files with sound (before you try the movie you want). As you are in a failsafe session, there should not be any programs blocking your sound card, and hence you should be abl to hear something.

Another question which is kida obvious, but can also make the difference... Where did you install Flash, to what directory?

Marcolux
25th May 2006, 08:27 PM
Muchas Gracias Theatargos

Thetargos
25th May 2006, 09:30 PM
De nada, asumo que funcionů

You're welcome, I assume it worked...

JordanN
25th May 2006, 09:53 PM
What version of Flash is required to play the file? Some sites now require Flash 8, while only Flash 7 is available for Linux.