PDA

View Full Version : Ownership issues??



Beepa
24th May 2006, 09:06 PM
What gives as root I thought I can change anything I want. I want to be able to access files on my floppy from my other user name. So I logged in as root and tried to set the group to adm for all folders in the /media folder and it says permission denied???? What gives with that. It is silly that I would have to be in logged in as root to access any other media input??? Can someone tell me how to get around this issue? I also tried just changing the group attribute of the files on the floppy and that was denied as well?? :confused: I really don't want to have to log in as root to access data from my floppy and/or cdRom so if someone can tell me how to change this I'd really appreciate it?? :(
PS. Guess I'm used to RH9 (it took me 15 mins to find the floppy folder) is the mnt folder obsolete now? It would seem so since everything is now accessed through /media? What about usb ports will they also mount in /media instead of /mnt?? :confused:

pparks1
24th May 2006, 09:33 PM
You should be able to change the permissions on the /media folder. What command are you tying exactly? I tried the following and both worked.


chmod 777 /media
chown root:adm /media


Any chance that the floppy was write protected?

Beepa
24th May 2006, 10:46 PM
But I tried chown using the format you showed adding both the owner and group and it worked. I checked and beepa is owner of all files on the floppy as it should be since it was mounted by that logon.
Maybe I missed typed something?? But I have resolved the problem now. Thank you for your quick response and too for the little trick of using the : to separate attributes using chown. I didn't know you could use that format.
One of the problems I was having was I didn't have the permissions on the folder I was coping the file into set up correctly.

bkasap
8th June 2006, 12:45 PM
can't create folder because linux don't accept my permissions.
am i not the owner?