PDA

View Full Version : Installing tar.Z ethernet driver



Lude
24th May 2006, 01:37 AM
I couldnt find anything on this either. I need to install the ethernet driver for my mobo so the internet will work at startup. I have to activate eth1 everytime. The mobo CD has linux drivers for everything, however, they are in a .tar.Z compression. Ive looked that extension up and didnt find much. Any help installing this driver, mainly uncompressing it really, would be much appreciated. Thanks.

Mat
24th May 2006, 01:58 AM
# tar -xZf file.tar.Z will uncompress it

Lude
24th May 2006, 10:43 PM
Hmm it says no such file or directory everytime. im logged in as root and the file is on the desktop and in home and i tried it as is, then tried cd Desktop then what you said and the same thing happens everytime. Any ideas? Here is the exact error:

[root@localhost ~]# tar -xZf yukon.tar.Z
tar: compress: Cannot exec: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors


Thanks.

Mat
24th May 2006, 11:35 PM
well, that error clearly states that the file is not there (in your output it should be /root/yukon.tar.Z)

you can use "ls" to show all contents of the current directory.. and you might use wildcards too
so, maybe try to do "ls yukon*" (without the quotes) to see, what the real name is..

are you sure the file is on the desktop of root? or on the desktop of another user (e.g. lude)? in that case, first go to that directory (cd /home/lude/Desktop) and do that ls command again..

when you see the file in the ls output you can use the tar command..


--> another thing worth mentioning in this context is tab-completion.. whenever you enter files or paths in the console, you can just type the first characters of that file and then hit the <Tab> key.. it will complete that.

e.g. you want to go lude's home..
type "cd /ho" and <tab> (the computer will add the rest)
then type lu and <tab> and so on..

works with files too.. "tar -xZf yukon<tab>" will add the rest of the file..


Mat

Lude
25th May 2006, 12:00 AM
ive never had a problem with it finding stuff on my desktop or in my root folder. could you look at this screenshot and see if im overlooking anything and doing something wrong. http://www.surrealstudio.net/images/tar.png . i even typed "ls" in both areas and the file was there in both, and i did "tar -xZf yuk" and pressed tab and it completed the file and i pressed enter and got the same error. thanks again.

Mat
25th May 2006, 02:51 AM
damn!! my apologies... I misread the error message..

tar is not complaining about the missing archive, it is complaining about the missing compress binary (which is used to uncompress the file..)

you need to install the package ncompress (e.g. via "yum install ncompress") before..



sorry, I should have been more careful
Mat

marko
25th May 2006, 03:05 AM
I think gzip can uncompress a Z file (file compressed with 'compress')
without needing the actual compress utility. At least that's what the
man page says for gzip
but then you'd use the small z and not the big Z option

tar zxf yukon.tar.Z

mark