PDA

View Full Version : Amarok 1.4.0 update breaks gstreamer



icydog
23rd May 2006, 11:37 PM
Amarok 1.4.0 beta3 worked fine, but then I did a regular yum update today and it installed Amarok 1.4.0, the release version. Well, it only comes with two output plugins -- helix and void. There used to be a /usr/lib/kde3/libamarok_gst10engine_plugin.so, but the update removed this.

I can't play music with amarok now.

Is anyone else having this problem, and have you found a solution?

scotta3234
23rd May 2006, 11:42 PM
Well I didn't have the same Gstreamer problem as you but I switched to the Xine engine anyways because the gstreamer engine cant play streaming music. I'd just install the Xine-lib package from yum and also get the amarok-extras-nonfree package. After you do that you can use the Xine engine and listen to music and streams.

QuantumKnot
24th May 2006, 12:17 AM
Amarok 1.4.0 beta3 worked fine, but then I did a regular yum update today and it installed Amarok 1.4.0, the release version. Well, it only comes with two output plugins -- helix and void. There used to be a /usr/lib/kde3/libamarok_gst10engine_plugin.so, but the update removed this.

I can't play music with amarok now.

Is anyone else having this problem, and have you found a solution?

Yes, I can confirm that there is no gstreamer plugin anymore in the new amarok :eek: Though my libamarok_gst10engine_plugin.so is still there.

Also, amarok seems to hog my CPU when I close it. When looking at it from top, it has about 5 processes, kswap0 goes crazy and my machine freezes for a while. :eek:

GL1800
24th May 2006, 12:30 PM
After launch of the latest one, I saw a message flash by, saying that gstreamer was being "rejected", maybe, and that it was going to change over to the xine engine, which it did, and the music just kept coming.

Flu
24th May 2006, 12:59 PM
I was able to fix this issue by doing the following:

1) yum install compat-libstdc++-33
2) Download RealPlayer 10 for Linux from here: http://www.real.com/linux/ (Download RPM Package Link)
3) rpm -Uvh RealPlayer10GOLD.rpm
4) Open Amarok. Open the "Settings/Configure Amarok" section, then select "Engine"
5) Alter the Helix engine locations to the following:
Core directory: /usr/local/RealPlayer/common
Plugins directory: /usr/local/RealPlayer/plugins
Codecs directory: /usr/local/RealPlayer/codecs

After making these changes and restarting Amarok, mp3 files will now play fine again. This setup includes crossfading support as well, which is a nice bonus.

tabish121
29th May 2006, 02:11 PM
I've installed xine-lib and amarok-extras-nofree but when I restart amarok and select xine as the engine I still can't play mp3's. Is there some other step I am missing here?

steve1961
29th May 2006, 02:19 PM
I've installed xine-lib and amarok-extras-nofree but when I restart amarok and select xine as the engine I still can't play mp3's. Is there some other step I am missing here?


Install the codecs for xine:

http://stanton-finley.net/fedora_core_5_installation_notes.html

tabish121
29th May 2006, 03:05 PM
Sweet, thought I had done that already, must have been on one of my other machines. Thanks for the help.