PDA

View Full Version : Directoryindex now automatically showing index.html



GeneralChaos
23rd May 2006, 07:11 PM
noticed a little problem today, on my website all my sub directories had a blank index.html file in it, so the average person who pokes around couldnt see the directory list. For some reason now it is listing the contents of the directories.

I dont want to go through and add tons of .htaccess files, so does anyone have an idea on this?

I have,

<Directory />
Options FollowSymLinks
AllowOverride none
</Directory>

and

DirectoryIndex index.html index.html.var

which both seem correct.

sentry
23rd May 2006, 07:22 PM
There's an easier way to disable indexing.

Under <Directory "/var/www/html"> find the Options Indexes entry and add a minus (-) sign in fromt of it so it looks like Options -Indexes

GeneralChaos
24th May 2006, 04:47 AM
I had things setup as virtual hosts, so I tried the options inside the virtual host tag but that didnt work, so what I ended up doing was making a directory tag:

<directory "/var/www/*omitted*">
Options Indexes
AllowOverride None
Order allow,deny
Allow from all
</directory>

seems to be working...shouldnt adversely effect anything I dont think...htaccesses should work as they have been.