PDA

View Full Version : General desktop responsiveness - any hints?



Rtsbasic
23rd May 2006, 03:12 PM
I've recently been experimenting with Linux again, and am running it side by side with Windows - I find myself using both on a daily basis right now. As a result of this, I've noticed the general feel of the GUI in Linux is quite sluggish in comparison to Windows. My system is by no means slow (AMD3000XP, 1GB Ram, NV6600GT), and has all the correct drivers installed, but it still feels slow. Simple things like changing tabs in applications (Firefox & Gnome-Terminal notably), clicking on menu's, etc.

Are there any tweaks I can perform to make it feel more responsive? Maybe at a kernel level, or with the drivers. I have enabled render_accel already and that did make a noticable difference, but by no means solved the problem. I have installed an i686 kernel from yum, but maybe there are further optimizations that can be done?

Cheers.

VictorienSardou
25th May 2006, 04:33 PM
run glxgears from a command prompt and see what the FPS is.
have you installed the nvidia prop drivers which are available from livna?

tizza10
25th May 2006, 07:47 PM
I have always found Gnome to be less responsive than the other desktops, but still useable.

Apparently Gnome in FC5 is noticebly quicker, but I have not tried it myself

Have you tried KDE or the other desktops for comparison?

p4r4n01d
26th May 2006, 01:59 AM
only been a FC5 user 2 weeks but have found GNOME to be sluggish compared to Windoze. I tried KDE which seems quicker. I have noticed 100% processor usage when i move windows around etc.

Rtsbasic
27th May 2006, 09:11 PM
Running glxgears gives the following result:

[rtsbasic@localhost engage]# glxgears
25521 frames in 5.0 seconds = 5104.168 FPS
22058 frames in 5.0 seconds = 4411.522 FPS
25630 frames in 5.0 seconds = 5125.929 FPS
25618 frames in 5.0 seconds = 5123.536 FPS
25653 frames in 5.0 seconds = 5130.495 FPS

Which I am perfectly happy with, the Nvidia drivers are definately working as I can play Quake 3 with an average of 180FPS on highest settings. And still, I can't switch tabs in Firefox without having to wait. I updated to the latest Nvidia driver this evening, no change. Someone has to know at which layer this sort of slowdown is happening? I highly doubt it is specific to my machine - my setup is a very common one.

To be fair, I switched to E17 today to give it a go, and it feels a lot more responsive. Using regular GTK apps like Firefox are still slow to respond though. Is there anything I can do to speed it up? Disable font AA? Switch to some other version of X or tinker with this composite/xgl stuff?

joetesting311
28th May 2006, 12:21 AM
Excuse my ignorance, how can I enable render accel? This speeds video up??

Also, I believe my kernel is for a i386 but a

cat /proc/cpuinfo

shows:

processor : 0
vendor_id : GenuineIntel
cpu family : 15
model : 2
model name : Intel(R) Pentium(R) 4 CPU 3.00GHz
stepping : 9
cpu MHz : 2999.134
cache size : 512 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 1
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe cid xtpr
bogomips : 6007.55

processor : 1
vendor_id : GenuineIntel
cpu family : 15
model : 2
model name : Intel(R) Pentium(R) 4 CPU 3.00GHz
stepping : 9
cpu MHz : 2999.134
cache size : 512 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 1
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe cid xtpr
bogomips : 5997.60

How can I be sure I'm getting the most out of my kernel / video??


[Posted by 69.94.1.4 via http://webwarper.net This is added while posting a message to avoid misuse.
Try: http://webwarper.net/webwarper.exe Example of viewing: http://webwarper.net/ww/~av/google.com ]

Rtsbasic
28th May 2006, 12:45 AM
Someone else will have to advise you on the kernel as you use a dual core processor, there are definately i686 kernels available via Yum though.

Are you using an Nvidia or ATI card? The newest Nvidia driver has 2D rendering accelerated by default, but you can force it by putting the following option into your /etc/X11/xorg.conf file:


Option "RenderAccel" "true"

In the video card device section. To help you find the section, my complete one looks like this:


Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "nVidia Corporation NV43 [GeForce 6600/GeForce 6600 GT]"
Option "RenderAccel" "true"
EndSection

Small update on my app lag problem..I notice it the most with Firefox. I've been using Mozilla for the last hour or so and it feels more responsive. Any GTK application I launch still feels like its suffering a bit, but when running in E17 (which is very nice btw) and using Mozilla, its not too noticable. Has to be said, E17 is blazingly fast compared to Gnome & KDE. To be fair theres a lot less of it, but still.

joetesting311
28th May 2006, 12:50 AM
I forgot to offer my .02. In Firefox, put this in the address bar

about:config

Maybe there are memory issues that need to be tweaked

It's an ATI Radeon 9260 256 Megs so I would assume it's got some power stuff. I'll try that entry.

[Posted by 69.94.1.4 via http://webwarper.net This is added while posting a message to avoid misuse.
Try: http://webwarper.net/webwarper.exe Example of viewing: http://webwarper.net/ww/~av/forums.fedoraforum.org/forumdisplay.php?f=7 ]

Rtsbasic
28th May 2006, 01:03 AM
You will need to install the 3D drivers if you haven't already. There should be a guide in the How To section on setting up 3D with your ATI card.

I have tried tweaking Firefox via the about:config screen, using tweaks I found in the How To section, which claim to speed up the loading time of websites. They haven't helped the slowness of the interface though.

joetesting311
28th May 2006, 01:07 AM
I think I did install the 3d drivers as I followed the instructions on fedorafaq.org. Maybe I didn't.


[Posted by 69.94.1.4 via http://webwarper.net This is added while posting a message to avoid misuse.
Try: http://webwarper.net/webwarper.exe Example of viewing: http://webwarper.net/ww/~av/forums.fedoraforum.org/forumdisplay.php?f=7 ]

a thing
28th May 2006, 02:17 AM
By correct, you mean the binary blobs from ATI or nVidia? Those are likely the problem.

gavinw6662
28th May 2006, 03:05 AM
Apparently Gnome in FC5 is noticebly quicker, but I have not tried it myself



It is - but firefox is noticeably slower. You should try to package up your own firefox - I did with FC5 and it is wicked fast compared to redhat's.