PDA

View Full Version : Making PHP supporting MING



Saketram
22nd May 2006, 10:13 PM
In my Fedora (2.6.15-1.2054_FC5), I have PHP 5.1.2.

I want to install MING, so I had downloaded the php_ming.so.gz module and uncompressed it and placed in /usr/lib/php/modules/. And then restarted httpd.


Then I runned the following PHP scripts:
======================================
<?
dl('php_ming.so');

$swf = new SWFText();
?>
======================================
OUTPUT:
Warning: dl() [function.dl]: Unable to load dynamic library '/usr/lib/php/modules/php_ming.so' - /usr/lib/php/modules/php_ming.so: cannot enable executable stack as shared object requires: Permission denied in /var/www/test/mingtest.php on line 2

Fatal error: Class 'SWFText' not found in /var/www/test/mingtest.php on line 4
=======================================


I also tried with PHP onloading by adding the following file under /etc/php.d/ming.ini

ming.ini
=======================
extension=php_ming.so
=======================

All external modules does works well, I see them in phpinfo(), except this MING.


Do I have to Rebuild PHP with MING support? If yes, requesting detailed steps.


Please somebody help me to resolve this problem.

Saketram
23rd May 2006, 07:11 AM
In order to load this modules at Apache server stating time with PHP, so
I do not have to use dl function in PHP. Then I tried the following
script, and please see the response.
================== CODE ===========================
<?
$swf = new SWFText();
?>
=================== RESPONSE =======================
Fatal error: Class 'SWFText' not found in /var/www/test/mingtest.php on
line 2
================================================== ===

What is problem here? Help please

Saketram
23rd May 2006, 10:38 AM
I think, it should not work because of the security feature of Fedora Core 5. May be wrong too.
Whatever it is, I should have to work with MING, so I am requesting help here....

Saketram
23rd May 2006, 11:42 AM
One more check I had done, but I failed there too to get the working MING.

ANOTHER TRIAL TOO:
================================================== ========
[kumaran@localhost ~]$ cat > test.pl
use SWF;
[kumaran@localhost ~]$ perl -cw test.pl
Can't load '/usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi/auto/SWF/SWF.so' for module SWF: /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi/auto/SWF/SWF.so: cannot restore segment prot after reloc: Permission denied at /usr/lib/perl5/5.8.8/i386-linux-thread-multi/DynaLoader.pm line 230.
at test.pl line 1
Compilation failed in require at test.pl line 1.
BEGIN failed--compilation aborted at test.pl line 1.
[kumaran@localhost ~]$
================================================== =========

In addition, by disabling SELinux seting to disable state in "Security Level Configuration" window, and restarted the system and again when I run the program, I got the same error messages.
So this makes me to thing, that the MING not working is not the security feature of Fedora Core 5.

Still trying in other ways, and also expecting your valuable help .....