PDA

View Full Version : No USB keyboard at boot



homunculus
20th May 2006, 10:58 PM
My USB keyboard is not enabled at the OS choice screen. I have an old PS2 keyboard but I'm wondering if there's a way to enable the usb keyboard for the choice screen. The usb keyboard is enabled at the initial boot because I can use it to enter the BIOS. I am new to linux so I may have missed something. Any help is greatly appreciated.

homunculus
21st May 2006, 03:30 PM
I have tried looking for info on how to alter the bootloader so that it may load usb support when it runs but I'm a complete newbie so I don't really know what to add or where so I don't want to screw things up worse.

daneel971
21st May 2006, 03:31 PM
enable "usb legacy support" in the bios.

homunculus
21st May 2006, 03:41 PM
I had read about that somewhere but my BIOS doesn't have that option, trust me I've looked everywhere. In addition, the keyboard and mouse are both wirless usb and they work to get me into the BIOS setup and they worked during the install.

daneel971
21st May 2006, 03:54 PM
Did you already try to set "USB Keyboard support" to "BIOS" intead of "OS" ?

homunculus
21st May 2006, 04:11 PM
Where? In the BIOS. there are no options for usb keyboard support in my BIOS version. I can't edit GRUB because windows is the default OS in the bootloader. So I can't choose anything except windows when my box boots.

daneel971
21st May 2006, 04:24 PM
I looked at the manual of your motherboard on abit's site. Search under "integrated peripheral -> onchip PCI device".

this is the link for the manual - check if it matches your model
http://www.abit-usa.com/products/mb/manual.php?categories=1&model=176

homunculus
21st May 2006, 04:35 PM
This is why 'they' say you must learn at the feet of your masters. Thank you, that has turned the trick. My apologies for not having read enough and for assuming that it was something I had to edit in Fedora.

daneel971
21st May 2006, 04:42 PM
you're welcome :)