PDA

View Full Version : libMagick.so on Fedora 5



klemer1001
20th May 2006, 08:47 PM
I can't install RMagick on Fedora 5, about the missing libMagick.so.6 library on Fedora Core 5.
Where can I find libMagick.so.6?

tashirosgt
21st May 2006, 03:54 AM
Search for libMagick.so on pbone.net. The libXYZ.so.6 kind of libraries are often links to libXYZ.so libraries. Do you have a libMagick.so library without the ".6"?

markkuk
21st May 2006, 10:10 AM
FC5 has libMagick.so.9 in the ImageMagick package. Looks like you are trying to install a binary package built for a much older version of ImageMagick. You need to rebuild RMagick from source if you can't find a FC5 RPM package.

gavinw6662
22nd May 2006, 03:07 AM
you can also use

yum whatprovides filename

so yum whatprovides libMagick.so.6

you might find that there is some other package now that has that file in it. The only drawback to this - is that it can only search the repos you have set up in yum. So if you only use the default Fedora repos without adding any extra 3rd party repos - you then search rather limited number of packages. I know I have installed some apps that require some older files, and yum whatprovides had some wacky packagename - but it included the file that I needed.