PDA

View Full Version : How to compile ZSNES?



CrossGT-6
20th May 2006, 04:36 PM
Ok I tried doing the yum install of snes9x but when I finally found the file nothing launches... and I am about to give up on it. (Not just yet but I am not going to wait on just one emu).

So I need to figure out how to compile ZSNES for FC5 64bit. Or if anyone knows of an RPM that will actually work as it seems the FreshRPMS for SNES9x does not work.

Thanks guys. I have been doing searches on compiling but I am getting debrian, etc and they still don't seem t work with what I was doing... or I am doing it wrong which is very possible.

CrossGT-6
21st May 2006, 03:42 PM
Tried a guide for Deb. No luck so def still need some help here.

Finalzone
21st May 2006, 08:06 PM
You can learn how to build a rpm package by modifying an existing source rpm from ZSNES. I am in a process to rebuild this package but it appeares to have some issue with .configure file.

Addendum: ZSNES is not available on Extras repository because of Fedora policies.

SuperNu
21st May 2006, 10:44 PM
ZSNES uses a lot of 32-bit x86 assembler code, so I do not know if it is possible to compile a 64-bit zsnes. I have heard that it is possible with using yasm instead of nasm and to use ipher's wip zsnes (http://www.ipherswipsite.com/), but I don't know. You could always try using a 32-bit chroot jail as well.

--SN

CrossGT-6
22nd May 2006, 01:48 AM
Wow all over my head, if I could just get it working I would be happy but if anyone gives me directions that a noob can figure out I will follow them ^-^

I def want to do it. I have the ipher ZSNES DL'd... I am just not sure what to do next.

SuperNu
22nd May 2006, 05:19 AM
First, make sure you have the following requirements, nasm >= 0.98.39, libpng and libpng-devel >= 1.2.0, SDL and SDL-devel >= 1.2.0, zlib >= 1.1.0, yasm (for 64-bit)

From the command line:BuildRequires:
tar xvjf ZSNESS_0514.tar.bz2
cd zsnes/src/
./autogen.sh
make
su - (enter root's password)
make install

This should work, but like I stated before, zsnes uses a lot of x86 assembly code, so I am not sure if it will work using x86_64 or not. Good luck and let us know if everything works.

--SN

CrossGT-6
22nd May 2006, 05:23 AM
Well I found out that windows media 9 does not play on x86_64.

I also seem to have a weird problem with Azureus as it... well leaves these annoying windows open even when u click hide unless u close and reopen it.... and then it does it again... so fun.