PDA

View Full Version : yum broke!



shane2peru
19th May 2006, 08:41 PM
Ok, I did this

UPDATE: Let us begin by adding atrmps to your repo data base, if you already have it skip this step . Now open terminal and become root and run this command:
Code:

gedit /etc/yum.repos.d/atrpms.repo

and add this lines:
Quote:
[atrpms]
name=ATrpms for Fedora Core $releasever stable
baseurl=http://apt.atrpms.net/fedora/$releasever/en/$basearch/at-stable
enabled=1
gpgcheck=1
and click on SAVE , also root import the gpg key from the terminal: rpm --import http://atrpms.net/RPM-GPG-KEY.atrpms
as specified in these directions.
http://forums.fedoraforum.org/forum/showthread.php?t=43718&highlight=DWL-G630
and now yum is broke. I'm sure I broke the repos, but I don't know anything about FC5 I came over from using Ubuntu. Any ideas? When I
yum check-update I get this error
]# yum check-update
Loading "installonlyn" plugin
Setting up repositories
atrpms [1/4]
http://apt.atrpms.net/fedora/5/en/i386/at-stable/repodata/repomd.xml: [Errno 14] HTTP Error 404: Date: Fri, 19 May 2006 19:39:41 GMT
Server: Apache/2.0.54 (Fedora)
Content-Length: 324
Content-Type: text/html; charset=iso-8859-1
Trying other mirror.
Cannot open/read repomd.xml file for repository: atrpms
failure: repodata/repomd.xml from atrpms: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from atrpms: [Errno 256] No more mirrors to try.
Help! - I know I messed it up. I was trying to get my DWL-G630 D-link card to work. It works out of the box with Ubuntu.

Shane

smfinley
19th May 2006, 08:44 PM
http://stanton-finley.net/fedora_core_5_installation_notes.html#Warning
http://fedoraproject.org/wiki/JohnMahowald/ATrpmsWarning

shane2peru
19th May 2006, 08:54 PM
Thanks for the super quick reply! I followed the instructions for setting up my repos, and when I got to the yum -y update here is the error I got:
yum -y update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
atrpms [1/7]
http://apt.atrpms.net/fedora/5/en/i386/at-stable/repodata/repomd.xml: [Errno 14] HTTP Error 404: Date: Fri, 19 May 2006 19:51:51 GMT
Server: Apache/2.0.54 (Fedora)
Content-Length: 324
Content-Type: text/html; charset=iso-8859-1
Trying other mirror.
Cannot open/read repomd.xml file for repository: atrpms
failure: repodata/repomd.xml from atrpms: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from atrpms: [Errno 256] No more mirrors to try.


How do I get rid of those atrpm things?

Shane

terr9898
19th May 2006, 09:28 PM
When i try to bring up the repomd.xml file thru my browser, I get a 404 too. Seems that the server is having issues. Have you tried disabling the ATRPMS repo and then doing the update?

shane2peru
19th May 2006, 09:50 PM
I don't know how to get rid of those repos. I made them by accident by following those instructions. I didn't know they were bad. How do you disable them?

Shane

terr9898
19th May 2006, 10:31 PM
You need to delete/move that atrpms file in /etc/yum.repos.d.

Alternative:
Put the directive 'enabled=0' in the atrpms file.

u-noneinc-s
19th May 2006, 10:34 PM
First just do rm /etc/yum.repos.d/atrpms.repo and then try yum check-update again.

Also, search the forum for yum atrpms. Use the advanced search and refine the search to the last week (or 2). In the
user name section, add Firewing1. With a little luck you'll find one that was broken by atrpms, and Firewing1 had a
command listed for tracking any remnant atrpms.

EDIT: removed redundant (one)

shane2peru
19th May 2006, 10:37 PM
Thanks that fixed it. I didn't ever do get it to update, so I don't think there are any remnants. I think it is atrpm free now! Thanks.

Shane

u-noneinc-s
19th May 2006, 10:39 PM
terr9898 beat me to the punch. I still recommend removing atrpms, but enable=0 should work. Be careful what you get from
them and don't use it for updates.
I think it's the only place to get mythtv. If that's your reason for using atrpms, maybe DL the file instead of yumming it(?).

EDIT I think I need some typing lessons. Way too slow ;) :D