PDA

View Full Version : cups conflicts with foomatic < 3.0.2-33.3



snoze
19th May 2006, 03:27 AM
Hi guys.
I am trying to update my fc5 and getting following error message

cups conflicts with foomatic < 3.0.2-33.3

anyluck :eek:

terr9898
19th May 2006, 08:31 PM
Try this:
1) Remove the foomatic rpm
2) Run the 'yum update' cmd
3) After the update is complete, run 'yum install foomatic'

rhasselbaum
19th May 2006, 10:14 PM
I had the same problem. Thanks for the tip.

Any idea why Yum couldn't resolve this on its own?

ilusha
29th May 2006, 05:21 PM
Read the message more carefully!!! "... conflicts with ... < 3.0.2-33.3"
I faced with this problem and had a better idea: remove any old versions of foomatic!
1) rpm -qa | grep foomatic ---- find all versions of the package installed in your system:
foomatic-3.0.2-33.3
foomatic-3.0.2-33.2

2) rpm -e foomatic-3.0.2-33.2
After this uninstall yum goes work well.

naught
1st August 2006, 05:48 PM
Thanks a lot for this posting. I just used it to resolve this issue and a similar one. It's nice to have a place to go for a n00b like me. :)

What i wound up doing was following ilusha's advice. I removed the older package foomatic-3.0.2-33.2 and that cleared it up. There was also some other package that needed to be removed (forgot which one) and wound up having to remove the -gui that it was dependent on before i was successful.

Once again, thanks for the EASY and CLEAR advice!