PDA

View Full Version : Mounting a USB flash drive



mickeyboy
19th May 2006, 02:46 AM
FC5, trying to mount a USB flash drive but it won't mount, below is output of Dmesg.
Is't FC5 supposed to automount without putting line in /etc/fstab?

Initializing USB Mass Storage driver...
scsi4 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 3
usb-storage: waiting for device to settle before scanning
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
Vendor: Model: USB DISK Pro Rev: PMAP
Type: Direct-Access ANSI SCSI revision: 00
SCSI device sda: 1965056 512-byte hdwr sectors (1006 MB)
sda: Write Protect is off
sda: Mode Sense: 23 00 00 00
sda: assuming drive cache: write through
SCSI device sda: 1965056 512-byte hdwr sectors (1006 MB)
sda: Write Protect is off
sda: Mode Sense: 23 00 00 00
sda: assuming drive cache: write through
sda:<6>usb 1-10: reset high speed USB device using ehci_hcd and address 3
usb 1-10: device descriptor read/64, error -110
usb 1-10: device descriptor read/64, error -110
usb 1-10: reset high speed USB device using ehci_hcd and address 3
usb 1-10: device descriptor read/64, error -110
usb 1-10: device descriptor read/64, error -110
usb 1-10: reset high speed USB device using ehci_hcd and address 3
usb 1-10: device not accepting address 3, error -110
usb 1-10: reset high speed USB device using ehci_hcd and address 3
usb 1-10: device not accepting address 3, error -110
usb 1-10: USB disconnect, address 3
sd 4:0:0:0: scsi: Device offlined - not ready after error recovery
sd 4:0:0:0: SCSI error: return code = 0x50000
end_request: I/O error, dev sda, sector 0
Buffer I/O error on device sda, logical block 0
sd 4:0:0:0: rejecting I/O to offline device
Buffer I/O error on device sda, logical block 0
sd 4:0:0:0: rejecting I/O to offline device
Buffer I/O error on device sda, logical block 0
unable to read partition table
sd 4:0:0:0: Attached scsi removable disk sda
usb-storage: device scan complete
usb 1-10: new high speed USB device using ehci_hcd and address 4
usb 1-10: device descriptor read/64, error -110
usb 1-10: device descriptor read/64, error -110
usb 1-10: new high speed USB device using ehci_hcd and address 5
usb 1-10: device descriptor read/64, error -110
usb 1-10: device descriptor read/64, error -110
usb 1-10: new high speed USB device using ehci_hcd and address 6
usb 1-10: device not accepting address 6, error -110
usb 1-10: new high speed USB device using ehci_hcd and address 7
usb 1-10: device not accepting address 7, error -110


Trying to do a fdisk on drive, but!!
# /sbin/fdisk /dev/sda

Unable to open /dev/sda
# /sbin/fdisk /dev/sda1

Unable to open /dev/sda1

scotta3234
19th May 2006, 03:20 AM
Yes, the autofs service should automatically mount your drive. Make sure your usb device is fat32 which would enable it to be plug in play, plus having the extra advantage of sharing files between windows and linux. You can easily format it under windows to fat32.

-edit- I just checked with my usb drive and it's under /media/disk

a thing
19th May 2006, 03:36 AM
Looks like something with the drive or the USB port is screwed up. Can you use it from another computer? If yes, try plugging it into different USB ports.

mickeyboy
19th May 2006, 10:56 AM
I have plugged it into three different computers a nd get same results.
How do you set the the partition to fat32 in windows, i'm a Linux hack, I don't know Windows.
I started in Linux right out of the womb.

Jim

dazaau
19th May 2006, 11:36 AM
that I can help with! I am still figuring linux out :-)
go to my computer
right click on the drive
select format
change file system to FAT32
everything is easy in windowz ...

but not as powerful :-)

a thing
19th May 2006, 01:38 PM
Or just /sbin/mkfs.vfat DEVICE on GNU/Linux.

mickeyboy
20th May 2006, 01:29 AM
I put the flash drive in $windowsXP (Boy did that really hurt) and went into My Computer and XP read it as a FAT32 file , I formatted it there but Linux FC4or5 can't find /dev/sda .
This is a Patriot 1gb flash drive.
I also have a Lexar 1gb Jump drive and it reads-write with no problems.
Thanks Guys
\Jim

MAnix
20th May 2006, 08:30 PM
plug it into the usb port, type lsusb at the bash prompt to see if it is detected. it may not be finding it very well. if others work, linux may not be problem but may be chipset of the usb device. the manufacturuers love to play around with us and change them loads. hope that helps??

absurd2718
24th May 2006, 08:49 AM
I am having a similar problem. I am using FC5 on an AMD64 system and get the
following error message when I plug in my USB thumbdrive or external harddrive.
# dmesg
...
usb 1-1: new high speed USB device using ehci_hcd and address 1
usb 1-1: device not accepting address 54, error -110

The necessary kernel modules appear to be loaded.
# lsmod | grep usb
usb_storage 103841 0
scsi_mod 181137 4 usb_storage,sg,libata,sd_mod

# lsmod | grep hcd
ohci_hcd 54877 0
ehci_hcd 65229 0

Strangely, it used to work on this system. I would just plug the device in,
and it would automount without even needing an entry in fstab. I recently
upgraded my RAM from 1 GB to 3 GB, which is when the problem started occurring.
I also have a linux laptop that works fine with both my USB devices, so they
seem to be working correctly.

I appreciate any help solving this.

absurd2718
24th May 2006, 09:13 AM
Okay, I just solved this problem after posting this. I followed the advice under the section "device not accepting address" on the following sites here:
http://www.linux-usb.org/FAQ.html
http://www.linux-usb.org/notAcceptFeedback.html

It was as simple as just removing the hcd modules and immediately adding them again. As root,
# rmmod ohci_hcd
# rmmod ehci_hcd
# modprobe ohci_hcd
# modprobe ehci_hcd
I then inserted my USB thumbdrive, and it automounted as before.

Hopefully, this solves the problem, and the modules don't need to be regularly re-probed to use USB devices.