PDA

View Full Version : How can I connect to XDMCP from XP?



ViriiGuy
18th May 2006, 06:45 PM
I have been searching and searching, but yet to no avail. I would like to be able to
connect to XDMCP in FC5 from my XP box. I know the first response will likely mention
using VNC instead, but VNC will only allow me to connect to which ever account is already
logged in. This is not going to work for me.

What I have is a headless FC5 Server. No keyboard, no mouse, no monitor. It is meant to
only be accessed remotely so I can stick it in the closet and forget it. This will eventually
be my web/mail server. But I would like to be able to log into it remotely and use the GUI.

But as I said I do not want to have to hook up a KB/Mouse/Monitor so I can log into an
account, start a vnc server, then unhook all those items. Surely there has to be a way to
log into the XDMCP from XP so I can choose which account to log into.


Thank you,
Randy

Oh yea, not to mention VNC is NOT secure even in the least.

psyklops
19th May 2006, 12:04 AM
xwin32 is a readily available one that's downloadable on a trial. We use ReflectionsX from WRQ at work and I've used Hummingbirds Exceed software as well...

jcliburn
19th May 2006, 12:59 AM
Check out cygwin. It's free and it works well.

Firewing1
19th May 2006, 03:19 AM
See my server setup method. It uses XDMCP over VNC so no user needs to be logged in, XDMCP does that for you. When you VNC you see the login screen. Works perfectly for your description.
Firewing1

ViriiGuy
19th May 2006, 03:21 AM
Thank you for that. Regardless of cost, which one would you say is the best performer?
I am trying Xwin-32 right now, and even on my local network it is very slow.

Another thing I have noticed is I can only access xdmcp via the box's private ip address, not by domain. If I type in ****.com it will not connect. Even though the ports are forwarded to that box.

ViriiGuy
19th May 2006, 03:58 AM
See my server setup method. It uses XDMCP over VNC so no user needs to be logged in, XDMCP does that for you. When you VNC you see the login screen. Works perfectly for your description.
Firewing1

I tried Gin's method and could not get it to work, tomorrow I will have a look at yours.

Firewing1
20th May 2006, 12:28 AM
The current VNC is broken... They just released a update today, it should fix the issue. (before when trying to connect all you'd get is a white screen. Make sure to
yum updatebefore trying my method...)
As for performance, XDMCP over GDM works VERY well. Even when it's not across my local network, I get great performance.
Firewing1

misjka
27th October 2006, 01:40 PM
Hi!
I'm also trying to connect via xdmcp (software Xming), and I've tried to follow your howto for setting up VNC. The host is running FC5 & KDE.

For starters, gdm wasn't installed on the host so I had to do so. I also did the chkconfig off and on on vncserver and xinetd.d, and changed the xinetd.d configuration files.

Then I executed gdmsetup, and things just blow my head off... Start saying that the :0 display was already taken, wanting me to say yes or no... Said no, but the question just returned. Then I answered yes and the screen went black + a message saying the display was changed to #2... A couple of times I pressed the OK button but the message just returned...

So, via putty on the xp machine I rebooted the host but after that there was no login screen anymore :(. Please, how do I reset that?

And is there really no other simpler way to make the xdmcp work?

Greet's,
Mike

misjka
27th October 2006, 02:02 PM
Anyway, I continued the steps in the howto's (although not the ssh part in the end) and suddenly as I tried to connect from my xp via xdmcp the fedora "work in progress" icon turned up by the mouse pointer :)... Some progress after all :), but nothing else happened besides the host was working hard with the hard disk, though... And I still cannot get at login screen locally on the host... :(

misjka
27th October 2006, 03:52 PM
But hey: The gdm-binary seems to be eating up all the CPU capacity, swapping the disk all over the place >:(

misjka
27th October 2006, 03:59 PM
Now, I killed the gdm-binary...
And then I tried to manually execute the gdmgreeter, but then I get "librsvg-2.so.2: cannot open shared object file: No such file or directory"...

misjka
29th October 2006, 06:33 PM
Well, I'm getting kind of desperate over here - having a Linux host with no X login available :eek: ... Anyone having a clue how to change back to the normal X login screen after been using that gdmsetup utility (that seemed to screw things up for me)...?

jcliburn
30th October 2006, 03:31 AM
I'm not at all sure I follow what you're saying, but if X isn't starting, login to the system (using a text console or remote ssh session) and see if you can find error messages in /var/log/messages or /var/log/Xorg.0.log.

misjka
30th October 2006, 07:48 AM
Ah, thanks!
I solved it temporarily by removing gdm from the system, then it went quite alright again :).