PDA

View Full Version : ASUS A3A No sound from S/Pidf Headphone outlet



dietkinnie
16th May 2006, 09:31 PM
Hi All,

I have just installed a clean copy of Fedora Core 5,...and seem to be having problems with the S/Pdif "Headphone outlet". No sound is coming out from the damn thing !! and the funny thing is that my onboard speakers work fine :confused: I have been trying to find a solution to this for the last two days and have nearly given up all hope. So now its up to you guys/gals to help me solve this....

SouthPaw
17th May 2006, 12:52 PM
dietkinnie,
I dont know much about your hardware setup. I experienced sound problems with clean FC5 install. The best thing to do would be goto http://www.alsa-project.org/ find your sound card and see what problems have been reported. Downloading the lastest ALSA may help solve your problem.

jmarius
17th May 2006, 03:59 PM
Does your motherboard uses nforce chipsets? On my Asus a7n8x deluxe I installed the nforce drivers from nvidia (the nvsound module) and s/pdif works fine. I know it's an oss driver but it works fine for me.

dietkinnie
17th May 2006, 06:42 PM
I dont know why but it seems to have detected two devices.

1:Intel Hda using the Alsa mixer
2:Realtek ALC880 using the oss mixer

Both have the same effect on the S/pidf output.

This is my audio card :
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 04)

jmarius
17th May 2006, 06:49 PM
Then, as SouthPaw suggested, you might want to try the latest alsa drivers from the alsa project website.

dietkinnie
7th July 2006, 12:18 PM
I finally got this to work.

This is what I did.

1. Got the latest alsa devel drivers]
2. Installed them
3. After install do the following vim /etc/modprobe.conf

I commented out the old info I had in the file and pasted the lines below the comments.

#alias snd-card-0 snd-hda-intel ----old
#options snd-card-0 index=0 --old
#options snd-hda-intel index=0 --old
#remove snd-hda-intel { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r –ignore-remove snd-hda-intel--old
#Below is the new info
options snd-hda-intel model=z71v position_fix=1
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-card-0
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

Then reboot!!!
After reboot open a terminal and type alsamixer and check for devices that are muted and unmute.

It works like a charm