PDA

View Full Version : Not a valid block device



jshaev
16th May 2006, 04:32 AM
Hello,

I am trying to mount two partitions. Everything is on one harddrive and I want to mount my ntfs and fat32 partitions. I got the nfts drivers and my fdisk reads:

/dev/sda1 * 1830 8459 53255475 7 HPFS/NTFS
/dev/sda2 1 13 104391 83 Linux
/dev/sda3 14 1829 14587020 8e Linux LVM
/dev/sda4 8460 9733 10233405 c W95 FAT32 (LBA)

But when I run mount -t ntfs /dev/sda1 /mnt/Windows -r -o umask=0222
I get:
mount: /dev/sda1 is not a valid block device

I receive a similar message when I do a mount -a with my /etc/fstab with these additional lines:
/dev/sda1 /mnt/Windows ntfs ro,defaults,umask=0222 0 0
/dev/sda4 /mnt/FatPartition vfat rw,defaults,umask=0222 0 0

I then receive:
mount: /dev/sda1 is not a valid block device
mount: /dev/sda4 is not a valid block device


Any idea what I'm doing wrong?

Thanks.

giulix
16th May 2006, 08:28 AM
What's the output of the following commands, run as root


ls -l /dev/sda[1-9]
file /dev/sda[1-9]
blkid /dev/sda[1-9]

?

jshaev
17th May 2006, 12:27 AM
Thanks for the response, here is what I get:


What's the output of the following commands, run as root


ls -l /dev/sda[1-9]

[root@x1-6-00-90-f5-3f-99-1d-1 ~]# ls -l /dev/sda[1-9]
brwx------ 1 root root 8, 1 May 16 15:20 /dev/sda1
brwx------ 1 root root 8, 2 May 16 15:20 /dev/sda2
brwx------ 1 root root 8, 3 May 16 15:20 /dev/sda3
brwx------ 1 root root 8, 4 May 16 15:20 /dev/sda4

file /dev/sda[1-9]

[root@x1-6-00-90-f5-3f-99-1d-1 ~]# file /dev/sda[1-9]
/dev/sda1: block special (8/1)
/dev/sda2: block special (8/2)
/dev/sda3: block special (8/3)
/dev/sda4: block special (8/4)

blkid /dev/sda[1-9]
nothing happens.


?

Thanks for any help from this new information.

giulix
17th May 2006, 01:40 AM
Ok, everything's fine there. Can you give the output of


/sbin/lsmod

too, please ?

jshaev
17th May 2006, 04:17 AM
Ok, everything's fine there. Can you give the output of


/sbin/lsmod

too, please ?

Sure:



[root@x1-6-00-90-f5-3f-99-1d-1 ~]# /sbin/lsmod
Module Size Used by
udf 73285 1
ppdev 8645 0
autofs4 19013 1
hidp 15937 2
rfcomm 34517 0
l2cap 23617 10 hidp,rfcomm
bluetooth 44069 5 hidp,rfcomm,l2cap
sunrpc 136573 1
ip_conntrack_ftp 7601 0
ip_conntrack_netbios_ns 3009 0
ipt_REJECT 5441 1
xt_state 2241 3
ip_conntrack 49261 3 ip_conntrack_ftp,ip_conntrack_netbios_ns,xt_state
nfnetlink 6489 1 ip_conntrack
xt_tcpudp 3265 5
iptable_filter 3137 1
ip_tables 11657 1 iptable_filter
x_tables 12613 4 ipt_REJECT,xt_state,xt_tcpudp,ip_tables
acpi_cpufreq 6729 0
vfat 11969 0
fat 47709 1 vfat
ntfs 187924 0
video 14917 0
button 6609 0
battery 9285 0
ac 4933 0
ipv6 225697 10
lp 12297 0
parport_pc 25445 1
parport 34313 3 ppdev,lp,parport_pc
floppy 57733 0
nvram 8393 0
ohci1394 31749 0
ieee1394 288665 1 ohci1394
uhci_hcd 28881 0
ehci_hcd 29005 0
sg 32349 0
joydev 9473 0
r8169 27337 0
snd_hda_intel 17233 1
snd_hda_codec 112065 1 snd_hda_intel
nvidia 4544884 12
snd_seq_dummy 3781 0
snd_seq_oss 28993 0
snd_seq_midi_event 7105 1 snd_seq_oss
snd_seq 47153 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 8909 3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss 45009 0
snd_mixer_oss 16449 1 snd_pcm_oss
snd_pcm 76869 3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_timer 22597 2 snd_seq,snd_pcm
snd 50501 11 snd_hda_intel,snd_hda_codec,snd_seq_oss,snd_seq,sn d_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd _timer
i2c_i801 8525 0
hw_random 5849 0
soundcore 9377 1 snd
i2c_core 20673 2 nvidia,i2c_i801
snd_page_alloc 10441 2 snd_hda_intel,snd_pcm
dm_snapshot 15981 0
dm_zero 2113 0
dm_mirror 19729 0
dm_mod 50521 9 dm_snapshot,dm_zero,dm_mirror
ext3 116169 2
jbd 52693 1 ext3
sata_promise 11333 1
libata 53969 1 sata_promise
sd_mod 16449 1
scsi_mod 124649 4 sg,sata_promise,libata,sd_mod


If I can get the fat32 working, I don't need to worry about the ntfs. I was thinking that maybe the problem is I created the partition using partition magic in winxp instead of using a linux partition tool. I can't format the ntfs, but the fat32 wouldn't be a problem. Could this be the problem?

Thanks.

giulix
17th May 2006, 09:28 AM
Yes, if the partition is unformatted, that is probably the reason.

jshaev
18th May 2006, 02:22 AM
Actually, what I meant was that I had formatted the partition using partition magic instead of parted or some linux tool. However, I removed the partition and recreated it all using parted and it didn't help.

Thanks for any additional help.

a thing
18th May 2006, 02:27 AM
Have you tried fscking them from a live CD?

giulix
18th May 2006, 08:53 AM
I suspect the drivers of your promise SATA raid controller have some problems... Do you have this type of controller on your system ?

jshaev
24th May 2006, 03:48 AM
Yes, these are the host controllers:

SCSI/RAID Host Controller (the manufacturer for this is "standard mass storage controllers")
and
WinXp Promise SATA378 IDE controller

I actually had problems even getting the hard drive recognized at all during install, but when booting from the rescue disk it installed the drivers and it worked out.

Perhaps there is still a problem with the driver? If so how could I install corrected drivers?

Thanks for the help and sorry for the delay.

giulix
24th May 2006, 12:36 PM
Mmmh... not familiar with that chip. Here (http://linux-ata.org/sata-status.html)'s an up-to-date status report.

nejode
24th May 2006, 09:21 PM
Hi...

Have you tried running (as root!) "mount -t ntfs(or vfat?) /dev/sda1 /mnt/Windows" without the "-r -o umask=0222" parameters? Those are ok for fstab.

jshaev
27th May 2006, 07:06 AM
Thank you for the response but
No luck:

[root@Jason ~]# mount -t vfat /dev/sda4 /mnt/FatPartition/
mount: /dev/sda4 is not a valid block device

Thanks for any further help.

jshaev
27th May 2006, 07:59 PM
If I create the partition and filesystem from parted I get this when trying to mount:

[root@Jason /]# mount -t vfat /dev/sda4 /mnt/FatPartition/
mount: /dev/sda4 already mounted or /mnt/FatPartition/ busy

But I know it's not mounted because:

[root@Jason ~]# mount -l
/dev/mapper/VolGroup00-LogVol00 on / type ext3 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/dm-1 on /boot type ext3 (rw) [/boot]
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
automount(pid2161) on /net type autofs (rw,fd=4,pgrp=2161,minproto=2,maxproto=4)/dev/hda on /media/DVD_VIDEO type udf (ro,noexec,nosuid,nodev,uid=500)

so what would make /mnt/FatPartition busy?

Thanks

xstation
27th May 2006, 08:19 PM
I have fc5 on menu like so



but starts to boot as far as blue screen last thing i see is booting fisrt time configuration the blue screen stays the same see the arrow but cannot move it.

the menu;lst entry looks like this in the menu;lst
title Fedora Core (2.6.15-1.2054_FC5)
root (hd0,2)
kernel /boot/vmlinuz-2.6.15-1.2054_FC5 ro root=LABEL=/1 rhgb quiet
initrd /boot/initrd-2.6.15-1.2054_FC5.img


now the menu.lst file from which the above entry was copied is not a fedora os its linux but not fedora.

the actual menu.lst in the fedora 5 os looks like this :

default=0
timeout=5
splashimage=(hd0,2)/boot/grub/splash.xpm.gz
hiddenmenu
title Fedora Core (2.6.15-1.2054_FC5)
root (hd0,2)
kernel /boot/vmlinuz-2.6.15-1.2054_FC5 ro root=LABEL=/1 rhgb quiet
initrd /boot/initrd-2.6.15-1.2054_FC5.img

now how should the the entry in the menu.lst file from which fedora 5 will boot lokk like is the above correct?

what does get as far as it does on booting but does not make it to the log in screen?



xstation :)

nejode
29th May 2006, 10:48 PM
jshaev: just for the record..... in your first post you said that you had only one HDD (sata I suppose), if it's that way, do you have the raid drivers enabled in the bios? Have you tried disabling the raid function? I In all the sata capable mobo's you have the option to enable the sata hdd's with a raid or "non-raid" condition.

Another check, did you try using Slax live boot CD? It mounted all the pata-sata hard drives in every machine I used it. The ISO only weighs about 200 mb. Here's the link: http://slax.linux-live.org/?lang=en

jshaev
30th May 2006, 08:01 PM
My BIOS gives me the option of either RAID or ATA...I have it selected to ATA.

As far as the Slax live boot...would setting this up and seeing if it mounts allow me to mount them in FC5?

Thanks.

nejode
31st May 2006, 09:56 PM
Well my friend, as far as booting fron a Slax live CD... It just to see if another distro will mount your partitions. If it does, then your problem is within FC5. If it doesn't, then we have to check other variables (bios settings, partition table, etc). As I commented before, I had that same problem (with Mandrake 10.0) some time ago and could not find the solution. Had to format Mandrake and install Suse, and the problem dissapeared. Since then, I've installed FC3, FC4, FC5, Kubuntu and Ubuntu 5.10, Suse 10 (and a couple of others), and the problem hasn't showed up again... that indicates that the problem was within the Mandrake install, and never could find the cause. As far as my FC5 install, I had to expressly indicate the partitioner during install to mount my Kubuntu partition in "/kubuntu", because at the first try I didn't and Fedora would't even boot. As you can see, I'm interested too in finding the solution for your problem so we can all benefit from it. Regards...

nejode