PDA

View Full Version : Problem Printing



g8keepR
13th May 2006, 03:18 PM
I have an epson 2200 printer (connected via USB) which has been working fine with CUPS up until now. I can't print anything, the job doesn't even show up in the print queue (however I do see it in /var/spool/cups ... odd)

I've tried the following with no luck:
Re-installing the printer.
Setting up a new queue.
re-installing foomatic and associated packages.
Tried changing USB ports. (dmesg shows the printer there)

usb 1-1: new high speed USB device using ehci_hcd and address 9
drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 9 if 0 alt 0 proto 2 vid 0x04B8 pid 0x0007

I've also tried:
lpstat -v
device for Epson: usb:/dev/usb/lp0

So I know its there.

set the cupsd.conf debug to "debug" mode:

This is an excerpt from the /var/log/cups/error_log:

D [13/May/2006:10:10:49 -0400] [Job 1] New page: 1 1
D [13/May/2006:10:10:49 -0400] [Job 1] Inserting option code into "PageSetup" section.
D [13/May/2006:10:10:49 -0400] [Job 1] No page header or page header not DSC-conforming
D [13/May/2006:10:10:49 -0400] [Job 1] Stopping search for page header options
D [13/May/2006:10:10:49 -0400] [Job 1] Found:
D [13/May/2006:10:10:49 -0400] [Job 1] pageHeight sub % Move down...
D [13/May/2006:10:10:49 -0400] [Job 1] --> Output goes directly to the renderer now.
D [13/May/2006:10:10:49 -0400] [Job 1]
D [13/May/2006:10:10:49 -0400] [Job 1]
D [13/May/2006:10:10:49 -0400] [Job 1] Starting renderer
D [13/May/2006:10:10:49 -0400] [Job 1] JCL: <job data>
D [13/May/2006:10:10:49 -0400] [Job 1]
D [13/May/2006:10:10:49 -0400] [Job 1] renderer PID kid4=3720
D [13/May/2006:10:10:49 -0400] [Job 1] renderer command: gs -q -dPARANOIDSAFER -dNOPAUSE -dBATCH -sDEVICE=ijs -sIjsServer=ijsgimpprint -dIjsUseOutputFD -sDeviceManufacturer=EPSON -sDeviceModel=escp2-2200 -dDEVICEWIDTHPOINTS=612 -dDEVICEHEIGHTPOINTS=792 -r360x360 -sProcessColorModel=DeviceRGB -sIjsParams="Quality=360swuni,InkType=PhotoCMYK7,MediaType=Plai n,MediaSource=Standard,Dither=Adaptive,ImageType=2 ,Density=1.000000,Brightness=1.000000,Gamma=1.0000 00,Contrast=1.000000,Saturation=1.000000,Cyan=1.00 0000,Magenta=1.000000,Yellow=1.000000" -sOutputFile=- -
D [13/May/2006:10:10:49 -0400] [Job 1] foomatic-gswrapper: gs '-dPARANOIDSAFER' '-dNOPAUSE' '-dBATCH' '-sDEVICE=ijs' '-sIjsServer=ijsgimpprint' '-dIjsUseOutputFD' '-sDeviceManufacturer=EPSON' '-sDeviceModel=escp2-2200' '-dDEVICEWIDTHPOINTS=612' '-dDEVICEHEIGHTPOINTS=792' '-r360x360' '-sProcessColorModel=DeviceRGB' '-sIjsParams=Quality=360swuni,InkType=PhotoCMYK7,Med iaType=Plain,MediaSource=Standard,Dither=Adaptive, ImageType=2,Density=1.000000,Brightness=1.000000,G amma=1.000000,Contrast=1.000000,Saturation=1.00000 0,Cyan=1.000000,Magenta=1.000000,Yellow=1.000000' '-sOutputFile=| cat >&3' '/dev/fd/0' 3>&1 1>&2
D [13/May/2006:10:10:49 -0400] [Job 1]
D [13/May/2006:10:10:49 -0400] [Job 1] Closing renderer
D [13/May/2006:10:10:49 -0400] [Job 1] GNU Ghostscript 7.07 (2003-05-17)
D [13/May/2006:10:10:49 -0400] [Job 1] Copyright (C) 2003 artofcode LLC, Benicia, CA. All rights reserved.
D [13/May/2006:10:10:49 -0400] [Job 1] This software comes with NO WARRANTY: see the file PUBLIC for details.
D [13/May/2006:10:10:49 -0400] [Job 1] GNU Ghostscript 7.07: Could not open the scratch file /var/spool/cups/tmp/gs_FlTG1q.
D [13/May/2006:10:10:49 -0400] [Job 1] **** Unable to open the initial device, quitting.
D [13/May/2006:10:10:49 -0400] [Job 1] renderer return value: 1
D [13/May/2006:10:10:49 -0400] [Job 1] renderer received signal: 1
D [13/May/2006:10:10:49 -0400] [Job 1] Process dying with "Possible error on renderer command line or PostScript error. Check options.", exit stat: 3
D [13/May/2006:10:10:49 -0400] [Job 1] error: Illegal seek (29)
D [13/May/2006:10:10:49 -0400] [Job 1] Possible error on renderer command line or PostScript error. Check options.
D [13/May/2006:10:10:49 -0400] [Job 1] tail process done writing data to STDOUT
D [13/May/2006:10:10:49 -0400] [Job 1] KID4 finished
D [13/May/2006:10:10:49 -0400] [Job 1] KID3 exited with status 3
D [13/May/2006:10:10:49 -0400] [Job 1] Renderer exit stat: 3
D [13/May/2006:10:10:49 -0400] [Job 1] Renderer process finished
D [13/May/2006:10:10:49 -0400] [Job 1] Killing process 3719 (KID3)
D [13/May/2006:10:10:49 -0400] [Job 1] Process dying with "Error closing renderer", exit stat: 3
D [13/May/2006:10:10:49 -0400] [Job 1] error: Illegal seek (29)
D [13/May/2006:10:10:49 -0400] [Job 1] Error closing renderer
E [13/May/2006:10:10:49 -0400] PID 3717 stopped with status 3!
D [13/May/2006:10:10:49 -0400] UpdateJob: job 1, file 0 is complete.
D [13/May/2006:10:10:49 -0400] CancelJob: id = 1
D [13/May/2006:10:10:49 -0400] StopJob: id = 1, force = 0
D [13/May/2006:10:10:49 -0400] StopJob: printer state is 3


Oh and get this ... If I go under the KDE Print Manager to PRINTERTOOLS->EPson Inkjet and check "use direct connection" I can conduct any of the tests!

Any ideas?

g8keepR
13th May 2006, 09:03 PM
Ok I've solved the problem.

Somehow /var/spool/cups/tmp was deleted.
After I made that directory, I was then able to configure the CUPS server again in the KDE Print Manager.
Here I found that under "Security" Deny from All was listed.
After I removed that ... everything worked!

How these settings all of a sudden appeared, I do not know, but I'm back in business.