PDA

View Full Version : Touchpad problems on HP ze2000



epkulse
12th May 2006, 02:15 PM
I experience strange behaviour on my laptop when using the touchpad. For instance, if I drag my finger to the left or right when in Firefox it starts moving Back and Forward. And, it is extremely sensitive - not at all comfortable. I have tried to modify settings in xorg.conf - no luck. Also tried to gsynaptics - didn't work at all. Anyone with a good clue?

BR

/Uffe

techmatt
16th May 2006, 03:37 AM
I am having the same problem along with one of my fellow techs I hope some one anwser this soon.

epkulse
16th May 2006, 09:23 AM
OK, I'm really interested to see if there is a solution. It is very annoying...

bbfuller
16th May 2006, 09:47 AM
Personally, I've found the synaptics touchpad driver nothing but an annoyance on both of my laptops. It seems to be installed if you have an actual "Synaptics" pad or and "Alps" pad. I have both and the default settings have never made sense for either of mine.

Fortunately, my requirements from a touchpad are basic. As long as I can move the mouse pointer, tap and double tap, and tap and drag I'm satisfied.

I found that you can achieve this with the instruction:

psmouse.proto=exps

appended to the Grub configuration file.

Open the file /boot/grub/menu.lst and add the above at the end of the line that begins:

kernel /vmlinuz........

You'll need to do this as root.

Be sure that you can edit the file from a command prompt in case it doesn't work for you and you need to remove the ammendment without a graphical desktop.

epkulse
16th May 2006, 07:40 PM
Tested that, but I ended up in "panic". Is that possibly related to xorg.conf, which I have not changed yet? These statements are used today:

"Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "InputDevice"
Identifier "Synaptics"
Driver "synaptics"
Option "Device" "/dev/input/mice"
Option "Protocol" "auto-dev"
Option "Emulate3Buttons" "yes"
EndSection
"

bbfuller
16th May 2006, 08:13 PM
Well, I certainly didn't get panic messages, but I seem to remember that I did have to create a new xorg.conf. You should still be able to get to the command prompt (if not you can edit the grub configuration line from the initial boot loader screen) if you just rename xorg.conf to perhaps oldxorg.conf it should force it to start the configuration from scratch. If not I'll experiment again when I get back from holiday in a couple of weeks.

epkulse
16th May 2006, 08:18 PM
OK, Iĺl make it another try by renaming the xorg.conf...

bbfuller
16th May 2006, 08:19 PM
Incidentally, here is a copy of the xorg.conf I ended up with:

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, a font server independent of the X server is
# used to render fonts.

FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "LCD Panel 1024x768"
DisplaySize 290 220
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 31.5 - 48.5
VertRefresh 40.0 - 70.0
# Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "nVidia Corporation NV17 [GeForce4 420 Go]"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

epkulse
16th May 2006, 08:43 PM
Hi again,

tested it now. Had to remove all references to synaptics in xorg.conf. Seems to be working now, haven't tried the behaviour problems yet - but it appears to be improved a lot...

Big thanks for your immediate support! This forum is wonderful...

techmatt
19th May 2006, 03:24 AM
that worked perfectly thanks

scotta3234
19th May 2006, 03:26 AM
You didn't have to touch your xorg.conf
You could have gone into firefox and typed about:config

Then go to mousewheel.horizscroll.withnokey.action and set this equal to 0

techmatt
19th May 2006, 04:34 AM
the only problem with that is it did it in gnome also