PDA

View Full Version : Am I the only one in the world who's not able to use 64bit ATI driver on FC5?



qinhan
11th May 2006, 08:55 PM
Is everyone happy with the current 64 bit ATI driver?
I've posted my problem here and there many times without getting any solutions. I did fresh install of 64bit FC5, updated the kernel, and installed the latest ATI driver and kernel module from Livna. What I get is
a blank screen after RHGB finishs. And the system hangs there. No error in the Xorg log file. I've posted my Xorg.0.log here (http://forums.fedoraforum.org/showthread.php?t=106955) .
My graphical card is ATI x700pro.

nachor13
11th May 2006, 10:44 PM
Hello,
I have the same problem with my ATI card (system hangs after RHGB, logs seem OK). Unfortunately, I haven't found solution yet.
I'm able to boot without rhgb and then system seems to be OK until I try to close desktop or switch to console - it hangs in such a case.
I have Gigabyte X800 card. It was working without problems in Fedora 4. It works correctly using "radeon" driver. My current system is Fedora 5 x86_64 kernel 2111, fglrx 8.24.8.

qinhan
12th May 2006, 01:34 AM
Seems we are having similar problems. Anyway, guess we'll wait until FC6 is released to see if the problem will be resolved or not. Really pissed off by the driver problem.

mlavalle
13th May 2006, 08:41 PM
I'm having the same problem, the screen stays blank when loading the X Windows System. I disabled the Red Hat graphical boot system so X doesn't load before then. I've tried a number of suggestions on various forums but haven't found a solution yet.

I suspect this is more an issue with the ATI drivers than Fedora though, as I've seen this problem mentioned on Gentoo and Debian forums as well.

fhubers
23rd May 2006, 12:43 AM
Mine is working fine with the 2.6.16-1.2122_FC5 kernel - have you followed all the instructions at http://www.fedorafaq.org/#radeon especially pertaining to the SELinux stuff? I am using Livna modules - remember you have to install both the 64 bit and 32 bit compatability modules.

DanielP
23rd May 2006, 12:46 AM
The solution is less than perfect but simply press Ctrl+Alt+F7 when the system has finished booting. I've got the very same problem and posted a thread about it just a short while ago.