PDA

View Full Version : SELinux + NFS on FC4 = :-(



marsh9999
10th May 2006, 08:51 PM
I am having a problem setting up NFS on my FC4 machine. I can serve up shares on the box but only if I disable SELinux.

With SELinux disabled
# exportfs
/l1 client39
/l2 client39
/l3 client39

With SELinux enabled
# exportfs


I have made no changes to the SELinux configuration. In fact I'm not even sure where the config files are if I wanted to. I had to use system-config-securitylevel to turn it off and on.

Thanks in advance for any light you folks can shed on the subject.

Seve
10th May 2006, 09:36 PM
Hello:
Have you looked at your /etc/hosts.allow file?
Also, if you have not had a look here, it might be helpful :http://forums.fedoraforum.org/showthread.php?t=102621

Seve

marsh9999
10th May 2006, 10:01 PM
# cat /etc/hosts.allow
#
# hosts.allow This file describes the names of the hosts which are
# allowed to use the local INET services, as decided
# by the '/usr/sbin/tcpd' server.
#

portmap: 192.168.0.31
lockd: 192.168.0.31
mountd: 192.168.0.31
rquotad: 192.168.0.31
statd: 192.168.0.31

192.168.0.31 is the address of teh client machine, is that not correct?

Seve
10th May 2006, 10:19 PM
# cat /etc/hosts.allow
#
# hosts.allow This file describes the names of the hosts which are
# allowed to use the local INET services, as decided
# by the '/usr/sbin/tcpd' server.
#

portmap: 192.168.0.31
lockd: 192.168.0.31
mountd: 192.168.0.31
rquotad: 192.168.0.31
statd: 192.168.0.31

192.168.0.31 is the address of teh client machine, is that not correct?
Hello:
Try setting your SeLinux to Permissive and see what the warnings are, it may help diagnose the problem.
Seve

u-noneinc-s
10th May 2006, 11:08 PM
system-config-securitylevel in a terminal should give you a security gui. Check SELinux settings there.
(I haven't done any NFS, but maybe SELinux needs to be made aware of/relabel somethings)?

marsh9999
11th May 2006, 08:51 PM
Hello:
Try setting your SeLinux to Permissive and see what the warnings are, it may help diagnose the problem.
Seve

Where would I find the warnings? I'm not seeing anything in /var/log/secure or on the screen.