PDA

View Full Version : NFS problem



marsh9999
9th May 2006, 05:24 PM
Hello,

Trying to set up a nfs server on my network, and I am clearly makeing some kind of n00b mistake. The box is a running FC4 2.6.16-1-2100 kernel.

My /etc/exports file:
/l1 client31(rw,sync)
/l2 client31(rw,sync)
/l3 client31(rw,sync)

Using ps I can see nfsd is running etc however when I type exportfs I see nothing. exportfs -r nothing. No error mesg, nothing in the logs, even adding the -v flag I get no feedback at all. :confused: Any advice would be greatly apreciated, thanks.

**** update

Turning off selinux fixes the problem. I would rather not run without SELinux enabled, any clues on how to troubble shoot this prblem? Thanks again.

Dubious Dave
9th May 2006, 05:36 PM
Try using the How To Article in this forum for NFS. I used it for a FC4 to FC5 NFS.

marsh9999
9th May 2006, 05:42 PM
Sorry if I am being thick here but searching "fc4 nfs howto" is the first thing I tried. Where is this howto you speak of? Thanks.

Dubious Dave
9th May 2006, 09:50 PM
Instead of searching go to the main forum. Scroll down to find the Fedora Resources section. First sub-forum in that section is How-To Articles. Fifth topic is "How to setup NFS shares in FC5". That's what I used. Worked well between FC4 & FC5. Keep in mind that it was written for FC5 to FC5, but the FC4 stuff is almost identical.

Funny part is, using this very same article to setup NFS between two FC5s has resulted in failure so far. But I will figure it out.

Good luck.

finsh
16th May 2006, 06:12 PM
Where do I explain this program

Dubious Dave
17th May 2006, 12:57 PM
What do you mean?